Changeset 7907d8c


Ignore:
Timestamp:
06/21/2006 03:14:36 PM (15 years ago)
Author:
Randy McMurchy <randy@…>
Branches:
10.0, 10.1, 11.0, 6.2, 6.2.0, 6.2.0-rc1, 6.2.0-rc2, 6.3, 6.3-rc1, 6.3-rc2, 6.3-rc3, 7.10, 7.4, 7.5, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, ken/refactor-virt, krejzi/svn, lazarus, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
294d670
Parents:
60a4832
Message:

Updated to Evolution-2.6.2

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@6187 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
3 edited

Legend:

Unmodified
Added
Removed
  • general.ent

    r60a4832 r7907d8c  
    518518<!ENTITY gnucash-version              "1.8.12">
    519519<!ENTITY gimp-version                 "2.2.11">
    520 <!ENTITY evolution-version            "2.4.2.1">
     520<!ENTITY evolution-version            "2.6.2">
    521521
    522522<!-- Chapter 35 -->
  • introduction/welcome/changelog.xml

    r60a4832 r7907d8c  
    4646      <itemizedlist>
    4747        <listitem>
     48          <para>[randy] - Updated to Evolution-2.6.2.</para>
     49        </listitem>
     50        <listitem>
    4851          <para>[randy] - Added new package gnome-mount-0.4 (not fully
    4952          complete, but added now to fix a validation issue).</para>
  • xsoft/office/evolution.xml

    r60a4832 r7907d8c  
    55  %general-entities;
    66
    7   <!ENTITY evolution-download-http "&gnome-download-http;/evolution/2.4/evolution-&evolution-version;.tar.bz2">
    8   <!ENTITY evolution-download-ftp  "&gnome-download-ftp;/evolution/2.4/evolution-&evolution-version;.tar.bz2">
    9   <!ENTITY evolution-md5sum        "cee3e0ac6ca43e5060468c3b938bea72">
    10   <!ENTITY evolution-size          "11.5 MB">
    11   <!ENTITY evolution-buildsize     "248 MB">
    12   <!ENTITY evolution-time          "7.4 SBU">
     7  <!ENTITY evolution-download-http "&gnome-download-http;/evolution/2.6/evolution-&evolution-version;.tar.bz2">
     8  <!ENTITY evolution-download-ftp  "&gnome-download-ftp;/evolution/2.6/evolution-&evolution-version;.tar.bz2">
     9  <!ENTITY evolution-md5sum        "24b97cf70a3c1e9e34f6e328e6910ab1">
     10  <!ENTITY evolution-size          "12.3 MB">
     11  <!ENTITY evolution-buildsize     "278 MB">
     12  <!ENTITY evolution-time          "9.2 SBU">
    1313]>
    1414
     
    1919    <othername>$LastChangedBy$</othername>
    2020    <date>$Date$</date>
    21     <keywordset>
    22       <keyword role="package">evolution-&evolution-version;.tar</keyword>
    23       <keyword role="ftpdir">evolution</keyword>
    24     </keywordset>
    2521  </sect1info>
    2622
     
    7066    <para role="recommended"><xref linkend="nss"/></para>
    7167
    72     <para>The <application>NSS</application> package is not
    73     required if you have <xref linkend="firefox"/>,
    74     <xref linkend="thunderbird"/> or <xref linkend="seamonkey"/> installed.
    75     These packages contain internal copies of <application>NSS</application>
    76     (or they used a system-installed copy). If any of the three packages
    77     are installed, one way or another you will already have
    78     NSS/NSPR libraries on your system.</para>
     68    <para>The <application>NSS</application> package is not required if you
     69    have <xref linkend="firefox"/>, <xref linkend="thunderbird"/>,
     70    <xref linkend="seamonkey"/> or
     71    <ulink url="http://www.mozilla.org/products/mozilla1.x/">Mozilla</ulink>
     72    installed. These packages contain internal copies of
     73    <application>NSS</application> (or they used a system-installed copy).
     74    If any of the four packages are installed, one way or another you will
     75    already have NSS/NSPR libraries on your system.</para>
    7976
    8077    <bridgehead renderas="sect4">Optional</bridgehead>
    81     <para role="optional"><xref linkend="gstreamer"/>,
    82     <xref linkend="openldap"/>,
     78    <para role="optional"><xref linkend="openldap"/>,
     79    <xref linkend="hal"/>,
     80    <xref linkend="dbus"/>,
    8381    <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
    8482    <ulink url="http://www.pdc.kth.se/kth-krb/">krb4</ulink>,
    8583    <ulink url="&gnome-download-http;/gnome-pilot-conduits/2.0/">GNOME
    86     Pilot conduits</ulink> (requires
    87     <xref linkend="pilot-link"/> then
     84    Pilot conduits</ulink>
     85    (requires <xref linkend="pilot-link"/> then
    8886    <ulink url="&gnome-download-http;/gnome-pilot/2.0/">GNOME Pilot</ulink>),
    89     <ulink url="&gnome-download-http;/gnome-spell/1.0/">
    90     GNOME Spell</ulink>,
    91     <xref linkend="dbus"/>,
     87    <ulink url="&gnome-download-http;/gnome-spell/1.0/">GNOME Spell</ulink>,
     88    <ulink url="http://gstreamer.freedesktop.org/">GStreamer-0.8.x</ulink>,
     89    <ulink url="http://www.gnome.org/projects/NetworkManager/">NetworkManager</ulink>
     90    (<ulink url="&gnome-download-http;/NetworkManager/">download</ulink>),
     91    <ulink url="http://www.galago-project.org/news/index.php">libnotify</ulink>,
     92    <ulink url="http://www.mono-project.com/Main_Page">Mono</ulink>,
    9293    <!-- <xref linkend="kdebase"/>, -->
     94    <xref linkend="intltool"/>,
    9395    <xref linkend="gtk-doc"/>, and
    9496    <xref linkend="docbook-utils"/></para>
     
    109111      installed on your system. If you elected not to install
    110112      <application>NSS</application> (or one of the other packages mentioned
    111       above), you'll need to remove the following four parameter settings from
     113      above), you'll need to remove the following two parameter settings from
    112114      the <command>configure</command> command below:</para>
    113115
    114116      <literallayout><parameter>            --enable-nss
    115             --enable-smime
    116             --with-nspr-includes=/usr/include/nspr
     117            --enable-smime</parameter></literallayout>
     118
     119      <para>The <application>Evolution</application>
     120      <command>configure</command> script only looks for the stand-alone
     121      <application>NSS</application> package and the
     122      <application>Mozilla</application> and
     123      <application>Firefox</application> browsers for the NSS/NSPR libraries.
     124      If you are using <application>Thunderbird</application> as your source
     125      for the NSS/NSPR libraries, you will have to add the following two
     126      parameter settings to the <command>configure</command> command
     127      below:</para>
     128
     129      <literallayout><parameter>            --with-nspr-includes=/usr/include/nspr
    117130            --with-nss-includes=/usr/include/nss</parameter></literallayout>
    118131    </note>
    119132
    120 <screen><userinput>./configure --prefix=`pkg-config --variable=prefix ORBit-2.0` \
    121             --libexecdir=`pkg-config --variable=prefix ORBit-2.0`/lib \
     133<screen><userinput>./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
    122134            --localstatedir=/var/lib \
    123135            --sysconfdir=&gnome-etc-dir; \
     136            --libexecdir=$(pkg-config \
     137                --variable=prefix ORBit-2.0)/lib \
    124138            --enable-nntp \
    125139            --enable-nss \
    126             --enable-smime \
    127             --with-nspr-includes=/usr/include/nspr \
    128             --with-nss-includes=/usr/include/nss &amp;&amp;
     140            --enable-smime &amp;&amp;
    129141make</userinput></screen>
    130142
     
    134146
    135147<screen role="root"><userinput>make install &amp;&amp;
    136 ln -v -s evolution-2.4 \
    137     `pkg-config --variable=prefix ORBit-2.0`/bin/evolution</userinput></screen>
     148ln -v -s evolution-2.6 \
     149    $(pkg-config --variable=prefix ORBit-2.0)/bin/evolution</userinput></screen>
    138150
    139151  </sect2>
     
    159171    support.</para>
    160172
    161     <para><parameter>--with-{nspr,nss}-includes</parameter>: This parameter is
     173    <!--
     174    <para><parameter>-with-{nspr,nss}-includes</parameter>: This parameter is
    162175    used to identify where the Mozilla Network Security Services interface
    163176    headers are located. By default, <application>Evolution</application> uses
     
    165178    and chances are you will not have <application>Mozilla</application>
    166179    installed.</para>
     180    -->
    167181
    168182    <para><option>--with-openldap</option>: This parameter will compile
     
    178192    device.</para>
    179193
    180     <para><command>ln -v -s evolution-2.4 `pkg-config
    181     --variable=prefix ORBit-2.0`/bin/evolution</command>: This optional command
    182     creates a convenience symlink to the <command>evolution-2.4</command>
     194    <para><command>ln -v -s evolution-2.6 $(pkg-config
     195    --variable=prefix ORBit-2.0)/bin/evolution</command>: This optional command
     196    creates a convenience symlink to the <command>evolution-2.6</command>
    183197    binary.</para>
    184198
     
    194208
    195209      <seglistitem>
    196         <seg>evolution and evolution-2.4</seg>
    197         <seg>lib/evolution/2.4/* (contains support libraries, conduits,
    198         and other components)</seg>
    199         <seg>&gnome-etc-dir;/gconf/gconf.xml.defaults/{,schemas/}apps/evolution
    200         and the following subdirectories of $GNOME_PREFIX/:
    201         include/evolution-2.4,
     210        <seg>evolution and evolution-2.6</seg>
     211        <seg>$GNOME_PREFIX/lib/evolution/2.6/* (contains support libraries,
     212        conduits, and other components)</seg>
     213        <seg>The following subdirectories of $GNOME_PREFIX/:
     214        include/evolution-2.6,
    202215        lib/evolution,
    203         share/{{,omf/}evolution, {gnome/help,idl}/evolution-2.4}</seg>
     216        share/{{,omf/}evolution, {gnome/help,idl}/evolution-2.6}</seg>
    204217      </seglistitem>
    205218    </segmentedlist>
     
    213226        <term><command>evolution</command></term>
    214227        <listitem>
    215           <para>is a symlink to the <command>evolution-2.4</command>
     228          <para>is a symlink to the <command>evolution-2.6</command>
    216229          program.</para>
    217230          <indexterm zone="evolution evolution-prog">
     
    221234      </varlistentry>
    222235
    223       <varlistentry id="evolution-2.4">
    224         <term><command>evolution-2.4</command></term>
     236      <varlistentry id="evolution-2.6">
     237        <term><command>evolution-2.6</command></term>
    225238        <listitem>
    226239          <para>is an email, calendar and address book suite.</para>
    227           <indexterm zone="evolution evolution-2.4">
    228             <primary sortas="b-evolution-2.4">evolution-2.4</primary>
     240          <indexterm zone="evolution evolution-2.6">
     241            <primary sortas="b-evolution-2.6">evolution-2.6</primary>
    229242          </indexterm>
    230243        </listitem>
Note: See TracChangeset for help on using the changeset viewer.