Changeset 7e81406


Ignore:
Timestamp:
03/18/2020 02:23:36 PM (2 years ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
10.0, 10.1, 11.0, 11.1, lazarus, qt5new, trunk, upgradedb, xry111/intltool, xry111/test-20220226
Children:
348ca51
Parents:
63228ac1
Message:

git: ensure using python 3

If --with-python=python3 is not used, and Python 2 is not installed,
some tests would fail.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@22854 af4574ff-66df-0310-9fd7-8a98e5e911e0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • general/prog/git.xml

    r63228ac1 r7e81406  
    121121      role="nodep" linkend="pcre"/>), in either case configured with
    122122      <literal>--enable-jit</literal>,
    123       <xref linkend="python2"/>,
    124123      <xref linkend="subversion"/> with Perl bindings (for <command>git
    125124         svn</command>),
     
    155154    </para>
    156155
    157 <screen><userinput>./configure --prefix=/usr --with-gitconfig=/etc/gitconfig &amp;&amp;
     156<screen><userinput>./configure --prefix=/usr \
     157            --with-gitconfig=/etc/gitconfig \
     158            --with-python=python3 &amp;&amp;
    158159make</userinput></screen>
    159160
     
    270271
    271272    <para>
    272       <option>--with-python=python3</option>: Use this switch to allow using
    273       <application>Python 3</application>. <application>Python</application> is
    274       only used for the <command>git p4</command> interface to Perforce
    275       repositories.
     273      <option>--with-python=python3</option>: Use this switch to use
     274      <application>Python 3</application>, instead of the EOL'ed
     275      <application>Python 2</application>. Python is used for the
     276      <command>git p4</command> interface to Perforce repositories,
     277      and also used in some tests.
    276278    </para>
    277279
Note: See TracChangeset for help on using the changeset viewer.