Changeset 89e6d61


Ignore:
Timestamp:
10/07/2014 02:27:15 AM (7 years ago)
Author:
Bruce Dubbs <bdubbs@…>
Branches:
10.0, 10.1, 11.0, 7.10, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, ken/refactor-virt, krejzi/svn, lazarus, nosym, perl-modules, qt5new, trunk, upgradedb, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
a772d7e
Parents:
ae5ad236
Message:

Update to libreoffice-4.3.1.2.

Clarify meaning of Required, Recommended, and Optional dependecies
by adding the definitions used. Added to 'Conventions Used in this Book'.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@14518 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
4 edited

Legend:

Unmodified
Added
Removed
  • introduction/welcome/changelog.xml

    rae5ad236 r89e6d61  
    4949      <itemizedlist>
    5050        <listitem>
     51          <para>[bdubbs] - Update to libreoffice-4.3.1.2.  Fixes
     52          <ulink url="&blfs-ticket-root;5580">#5580</ulink>.</para>
     53        </listitem>
     54        <listitem>
     55          <para>[bdubbs] - Clarify meaning of Required, Recommended,
     56          and Optional dependecies by adding the definitions used.
     57          Added to 'Conventions Used in this Book'.  Fixes
     58          <ulink url="&blfs-ticket-root;5624">#5624</ulink>.</para>
     59        </listitem>
     60        <listitem>
    5161          <para>[fernando] - Update to lxsession-0.5.0.  Fixes
    5262          <ulink url="&blfs-ticket-root;5627">#5627</ulink>.</para>
  • introduction/welcome/conventions.xml

    rae5ad236 r89e6d61  
    1616  <title>Conventions Used in this Book</title>
    1717
     18  <sect2>
     19  <title>Typographical Conventions</title>
    1820  <para>To make things easy to follow, there are a number of conventions used
    1921  throughout the book.  Following are some examples:</para>
     
    8890  </blockquote>
    8991
     92  </sect2>
     93
     94  <sect2>
     95  <title>Conventions Used for Package Dependencies</title>
     96
     97    <para>When packages are created, the authors depend on prior work.  In
     98    order to build a package in BLFS, these dependencies must be built prior to
     99    the desired package.  For each package, any prerequsite packages are listed
     100    in one or more separate sections:  Required, Recommended, and Optional.</para>
     101
     102    <bridgehead renderas="sect3">Required Dependencies</bridgehead>
     103
     104    <para>These dependencies are the minimum prerequsite packages required to
     105    build the package.  Omitted from the list are packages in LFS and required
     106    dependencies of other required packages.</para>
     107
     108    <bridgehead renderas="sect3">Recommended Dependencies</bridgehead>
     109   
     110    <para>These dependencies are those that the BLFS editors have determined
     111    are important to give the package reasonable capabilities.  Ppackage
     112    installation instructions assume thay are installed.  If a recommended
     113    package is not desired, the instructions may need to be modified to
     114    accomodate the missing package.</para>
     115   
     116    <bridgehead renderas="sect3">Optional Dependencies</bridgehead>
     117
     118    <para>These dependencies are those that the package may use.  Integration
     119    of optional dependencies may be automatic by the package or may need
     120    additional instructions not presented by BLFS.  Optional packages may be
     121    listed without corresponding BLFS instructions.  In this case it is up to
     122    the user to determine appropriate installation instructions. </para>
     123
     124  </sect2>
     125
    90126</sect1>
  • packages.ent

    rae5ad236 r89e6d61  
    580580<!ENTITY gnucash-version              "2.4.11">
    581581
    582 <!ENTITY libreoffice-version          "4.3.1">
     582<!ENTITY libreoffice-version          "4.3.2">
    583583<!ENTITY libreoffice-patch            ".2">
    584584<!ENTITY libreoffice-dlversion        "&libreoffice-version;&libreoffice-patch;">
  • xsoft/office/libreoffice.xml

    rae5ad236 r89e6d61  
    88
    99  <!ENTITY libreoffice-core-download-http "&libreoffice-dl;/libreoffice-&libreoffice-dlversion;.tar.xz">
    10   <!ENTITY libreoffice-core-md5sum        "cf750c01b6cd0b5c6fdd1760672e67d4">
     10  <!ENTITY libreoffice-core-md5sum        "86aa9cad125fec16c5cd1d9d964e1d20">
    1111  <!ENTITY libreoffice-core-size          "146 MB">
    1212
    1313  <!ENTITY libreoffice-dict-download-http "&libreoffice-dl;/libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz">
    14   <!ENTITY libreoffice-dict-md5sum        "aae27f6c9db741c42acae48a1dfb0f5e">
     14  <!ENTITY libreoffice-dict-md5sum        "996ec400156194fe26d24ffbccbc5b7a">
    1515  <!ENTITY libreoffice-dict-size          "36 MB">
    1616
    1717  <!ENTITY libreoffice-help-download-http "&libreoffice-dl;/libreoffice-help-&libreoffice-dlversion;.tar.xz">
    18   <!ENTITY libreoffice-help-md5sum        "24692bf69bbe877ad2524653c991705a">
     18  <!ENTITY libreoffice-help-md5sum        "63a59a4c77a72856b47caf1871cfc48f">
    1919  <!ENTITY libreoffice-help-size          "1.8 MB">
    2020
    2121  <!ENTITY libreoffice-translations-download-http "&libreoffice-dl;/libreoffice-translations-&libreoffice-dlversion;.tar.xz">
    22   <!ENTITY libreoffice-translations-md5sum        "b8d3445100c10bb4f21f6c8f25c5c600">
     22  <!ENTITY libreoffice-translations-md5sum        "0236e56349006fc8fec8e7df749c13b1">
    2323  <!ENTITY libreoffice-translations-size          "121 MB">
    2424
     
    2828  dependencies (with-system... -->
    2929
    30   <!ENTITY libreoffice-buildsize          "8.1 GB (535 MB installed), with translations">
    31   <!ENTITY libreoffice-time               "200 SBU, with translations">
     30  <!ENTITY libreoffice-buildsize          "6.6 GB (570 MB installed), with translations">
     31  <!ENTITY libreoffice-time               "61 SBU (using parallelism=4), with translations">
     32
     33  <!-- [bdubbs]  For version 4.3.2.2 Built on x86_64 using -\-with-parallelism=4 -->
     34
    3235  <!-- [fo] For version 4.3.1.2 I've got, for i686, statistcs over the upper
    3336  boundaries for x86_64 of previous versions, thus, temporarily, decided to use
     
    198201      <xref linkend="npapi-sdk"/>,
    199202      <xref linkend="nss"/>,
    200       <xref linkend="openldap"/> (client only),
     203      <xref linkend="openldap"/>,
    201204      <xref linkend="openssl"/>,
    202205      <xref linkend="poppler"/>,
    203       <xref linkend="python3"/> (used to build the translations),
     206      <xref linkend="python3"/>,
    204207      <xref linkend="redland"/>, and
    205208      <xref linkend="unixodbc"/>
     
    289292    <note>
    290293      <para>
    291        It is recommended to build this package in a graphical environment,
    292        because there have been reports of build failures, when using
     294       Building this package in a graphical environment is recommended.
     295       There have been reports of build failures, when using
    293296       <command>chroot</command> or <command>ssh</command>.
    294297      </para>
    295298    </note>
    296299
    297     <note>
     300    <important>
    298301      <para>
    299302      Unlike the other packages, we suppose that you have not yet unpacked the
     
    302305      <systemitem class="username">root</systemitem> user.
    303306      </para>
    304     </note>
     307    </important>
    305308
    306309<screen><userinput>tar -xf libreoffice-&libreoffice-dlversion;.tar.xz --no-overwrite-dir &amp;&amp;
     
    309312    <para>
    310313      Unpack the dictionaries file and create symlinks to tarballs from the
    311       source directory so they won't get downloaded again (it is not necessary
    312       to unpack the help nor the translations tarballs):
     314      source directory so they won't get downloaded againi.  It is not necessary
     315      to unpack the help nor the translations tarballs:
    313316    </para>
    314317
     
    321324-->
    322325
    323 ln -sv ../../../libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz \
    324        external/tarballs/ &amp;&amp;
    325 ln -sv ../../../libreoffice-help-&libreoffice-dlversion;.tar.xz \
    326        external/tarballs/</userinput></screen>
     326ln -sv ../../../libreoffice-dictionaries-&libreoffice-dlversion;.tar.xz external/tarballs/ &amp;&amp;
     327ln -sv ../../../libreoffice-help-&libreoffice-dlversion;.tar.xz         external/tarballs/</userinput></screen>
    327328
    328329<!-- Not necessary for this version
     
    338339    </para>
    339340
    340 <screen><userinput>ln -sv ../../../libreoffice-translations-&libreoffice-dlversion;.tar.xz \
    341        external/tarballs/</userinput></screen>
     341<screen><userinput>ln -sv ../../../libreoffice-translations-&libreoffice-dlversion;.tar.xz external/tarballs/</userinput></screen>
    342342
    343343    <note>
     
    345345        During the build process, some packages will be downloaded (including
    346346        the ones listed as recommended and optional dependencies) if they are
    347         not present on the system. Doing so, build time may be different
    348         for everyone.
     347        not present on the system. Because of this, build time may vary from the
     348        published time more than usual.
    349349      </para>
    350350    </note>
     
    368368
    369369    <para>
    370      For i686 systems, fix a problem inroduced by
    371      <application>&gcc-490;</application>:
     370     For i686 systems, fix a problem inroduced by <application>&gcc-490;</application>:
    372371    </para>
    373372
     
    387386sed -e "/distro-install-file-lists/d" -i Makefile.in &amp;&amp;
    388387
    389 chmod -v +x bin/unpack-sources                     &amp;&amp;
     388chmod -v +x bin/unpack-sources                       &amp;&amp;
     389
    390390sed -e "s/target\.mk/langlist\.mk/"                \
    391391    -e "s/tar -xf/tar -x --strip-components=1 -f/" \
    392392    -e "/tar -x/s/lo_src_dir/start_dir/"           \
    393     -i bin/unpack-sources                          &amp;&amp;
     393    -i bin/unpack-sources                            &amp;&amp;
    394394
    395395./autogen.sh --prefix=$LO_PREFIX         \
     
    470470
    471471<screen role="root"><userinput>mkdir -pv /usr/share/pixmaps &amp;&amp;
     472
    472473for i in writer base calc draw impress math startcenter writer
    473474do
     
    483484
    484485    <para>
    485       <command>sed -e ...</command>: First sed prevents compression of the
    486       manual pages, the second one prevents a script that causes install to
    487       fail from running, the third one fixes the unpack script.
     486      <command>sed -e ...</command>: The first sed prevents compression of the
     487      manual pages, the second one prevents install from failing, and
     488      the third one fixes the unpack script.
    488489    </para>
    489490
     
    513514
    514515    <note><para>
    515       For a list of the available languages, you can uncompress the
    516       translations tarball, <command>tar -xf
    517       ../libreoffice-translations-&libreoffice-dlversion;.tar.xz
    518       --no-overwrite-dir -C /tmp</command>, and run <command>ls
    519       /tmp/libreoffice-&libreoffice-dlversion;/translations/source</command>.
     516      For a list of the 117 available languages, you can look at the
     517      translations tarball: <command>tar -tf
     518      ../libreoffice-translations-&libreoffice-dlversion;.tar.xz |
     519      grep translations/source| cut -d/ -f4 | uniq</command>.
    520520    </para></note>
    521521
     
    573573      <application>LibreOffice</application> to use installed
    574574      <application>Python 3</application> to build the translations
    575       instead of the bundled one. If you don't need to build any
    576       translations, you can use <option>--disable-python</option>
    577       instead.
     575      instead of the bundled one.
    578576    </para>
    579577
     
    598596    <para>
    599597      <option>--disable-dbus</option>: Use this switch if you've not
    600       installed D-Bus-1.8.0. It also disables Bluetooth support and
     598      installed D-Bus-1.8.0 or later. It also disables Bluetooth support and
    601599      font install via PackageKit.
    602600    </para>
     
    611609      use <xref linkend="gst10-plugins-base"/> instead of
    612610      <xref linkend="gst-plugins-base"/> for the avmedia module.
    613     </para>
    614 
    615     <para>
    616       <option>--enable-gtk3</option>: Use this switch if you want to
    617       build the <application>GTK+ 3</application> integration module.
    618611    </para>
    619612
Note: See TracChangeset for help on using the changeset viewer.