Changeset a937527b


Ignore:
Timestamp:
10/06/2021 06:18:00 PM (9 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
11.1, lazarus, qt5new, trunk, upgradedb, xry111/intltool, xry111/test-20220226
Children:
111de14
Parents:
1a54b92
Message:

js78: add python 3.10 patch

Python 3.10 is not in the book yet, but the issues fixed by the patch
are already DeprecatedWarning in 3.9. So we can add the patch earlier.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • general/genlib/js78.xml

    r1a54b92 ra937527b  
    7676      </listitem>
    7777    </itemizedlist>
    78 <!--   
     78
    7979    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    8080    <itemizedlist spacing="compact">
     
    8282        <para>
    8383          Required patch:
    84           <ulink url="&patch-root;/js78-code_coverage-1.patch"/>
     84          <ulink url="&patch-root;/js-&JS78-version;-python_3_10-1.patch"/>
    8585        </para>
    8686      </listitem>
    8787    </itemizedlist>
    88 -->
     88
    8989    <bridgehead renderas="sect3">JS78 Dependencies</bridgehead>
    9090
     
    142142    </note>
    143143
    144 <!-- It's merged in 78.2.0.
    145     <para>
    146       Apply a patch required by <xref linkend="gjs"/>:
    147     </para>
    148 
    149 <screen><userinput>patch -Np1 -i ../js78-code_coverage-1.patch</userinput></screen>
    150 -->
     144    <para>
     145      Apply a patch to allow building this package with Python-3.10 or
     146      later:
     147    </para>
     148
     149<screen><userinput>patch -Np1 -i ../js-&JS78-version;-python_3_10-1.patch</userinput></screen>
     150
    151151    <para>
    152152      Install <application>JS</application> by running the following
Note: See TracChangeset for help on using the changeset viewer.