Changeset c1b61c6


Ignore:
Timestamp:
08/24/2014 06:34:04 PM (8 years ago)
Author:
Krejzi <krejzi@…>
Branches:
systemd-11177
Children:
3b705263
Parents:
7857007
Message:

Some checks and updates for KDE core section.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/branches/systemd@14036 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
22 edited

Legend:

Unmodified
Added
Removed
  • general/genlib/libusb-compat.xml

    r7857007 rc1b61c6  
    3737    </para>
    3838
    39     &lfs75_checked;
     39    &lfs76_checked;
    4040
    4141    <bridgehead renderas="sect3">Package Information</bridgehead>
  • kde/core/akonadi.xml

    r7857007 rc1b61c6  
    3535    retrieval.</para>
    3636
    37     &lfs75_checked;
     37    &lfs76_checked;
    3838
    3939    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6363    <bridgehead renderas="sect4">Required</bridgehead>
    6464    <para role="required">
    65       <xref linkend="shared-mime-info"/>,
    66       <xref linkend="boost"/>, and one of:
     65      <xref linkend="boost"/>, one of:
    6766      <xref linkend="sqlite"/>,
    6867      <xref linkend="mariadb"/>, or
    69       <xref linkend="postgresql"/>
     68      <xref linkend="postgresql"/>, and
     69      <xref linkend="shared-mime-info"/>
    7070    </para>
    7171
  • kde/core/attica.xml

    r7857007 rc1b61c6  
    2424
    2525  <indexterm zone="attica">
    26     <primary sortas="a-attica">attica</primary>
     26    <primary sortas="a-Attica">Attica</primary>
    2727  </indexterm>
    2828
     
    3333    "Open Collaboration Service" providers.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
  • kde/core/automoc4.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="automoc4" xreflabel="automoc4-&automoc4-version;">
     15<sect1 id="automoc4" xreflabel="Automoc4-&automoc4-version;">
    1616  <?dbhtml filename="automoc4.html"?>
    1717
     
    2424
    2525  <indexterm zone="automoc4">
    26     <primary sortas="a-automoc4">automoc4</primary>
     26    <primary sortas="a-Automoc4">Automoc4</primary>
    2727  </indexterm>
    2828
     
    3434    <application>CMake</application> as the buildsystem.</para>
    3535
    36     &lfs75_checked;
     36    &lfs76_checked;
    3737
    3838    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5858    </itemizedlist>
    5959
    60 <!--
    61     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    62     <itemizedlist spacing='compact'>
    63       <listitem>
    64         <para>Required patch: <ulink
    65         url="&patch-root;/automoc4-&automoc4-version;-fixes-1.patch"/></para>
    66       </listitem>
    67     </itemizedlist>
    68 -->
    69 
    7060    <bridgehead renderas="sect3">Automoc4 Dependencies</bridgehead>
    7161
    7262    <bridgehead renderas="sect4">Required</bridgehead>
    7363    <para role="required">
    74     <xref linkend="cmake"/> and
    75     <xref linkend="qt4"/>
     64      <xref linkend="cmake"/> and
     65      <xref linkend="qt4"/>
    7666    </para>
    7767
     
    8474    <title>Installation of Automoc4</title>
    8575
    86     <para>Install <application>automoc4</application> by running the following
     76    <para>Install <application>Automoc4</application> by running the following
    8777    commands:</para>
    8878
  • kde/core/baloo-widgets.xml

    r7857007 rc1b61c6  
    3232    <para>Baloo-Widgets contains widgets for the Baloo search framework.</para>
    3333
    34     &lfs75_checked;
     34    &lfs76_checked;
    3535
    3636    <bridgehead renderas="sect3">Package Information</bridgehead>
  • kde/core/baloo.xml

    r7857007 rc1b61c6  
    3232    <para>Baloo is a framework for searching and managing metadata.</para>
    3333
    34     &lfs75_checked;
     34    &lfs76_checked;
    3535
    3636    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6161    <para role="required">
    6262      <xref linkend="kdepimlibs"/>,
    63       <xref linkend="kfilemetadata"/> and
     63      <xref linkend="kfilemetadata"/>, and
    6464      <xref linkend="xapian"/>
    6565    </para>
  • kde/core/kactivities.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="kactivities" xreflabel="Kactivities-&kactivities-version;">
     15<sect1 id="kactivities" xreflabel="KActivities-&kactivities-version;">
    1616  <?dbhtml filename="kactivities.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Kactivities-&kactivities-version;</title>
     23  <title>KActivities-&kactivities-version;</title>
    2424
    2525  <indexterm zone="kactivities">
    26     <primary sortas="a-kactivities">kactivities</primary>
     26    <primary sortas="a-KActivities">KActivities</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to Kactivities</title>
     30    <title>Introduction to KActivities</title>
    3131
    32     <para>This package provides the activitymanager for KDE.</para>
     32    <para>This package provides the activity manager for KDE.</para>
    3333
    34     &lfs75_checked;
     34    &lfs76_checked;
    3535
    3636    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5656    </itemizedlist>
    5757
    58 <!--
    59     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    60     <itemizedlist spacing='compact'>
    61       <listitem>
    62         <para>Required patch: <ulink
    63         url="&patch-root;/kactivities-&kdelibs-version;-fixes-1.patch"/></para>
    64       </listitem>
    65     </itemizedlist>
    66 -->
    67     <bridgehead renderas="sect3">Kactivities Dependencies</bridgehead>
     58    <bridgehead renderas="sect3">KActivities Dependencies</bridgehead>
    6859
    6960    <bridgehead renderas="sect4">Required</bridgehead>
     
    7465    <bridgehead renderas="sect4">Optional</bridgehead>
    7566    <para role="optional">
    76       <ulink url="&kde-download-http;&kde-version;/src">nepomuk-core</ulink>
     67      <ulink url="&kde-download-http;&kde-version;/src">Nepomuk-Core</ulink>
    7768    </para>
    7869
     
    8475
    8576  <sect2 role="installation">
    86     <title>Installation of Kactivities</title>
     77    <title>Installation of KActivities</title>
    8778
    88     <para>Install <application>Kactivities</application> by running the following
     79    <para>Install <application>KActivities</application> by running the following
    8980    commands:</para>
    9081
    91 <!-- Nothing in sysconfdir here, too -->
    9282<screen><userinput>mkdir build &amp;&amp;
    9383cd    build &amp;&amp;
  • kde/core/kde-base-artwork.xml

    r7857007 rc1b61c6  
    3232    <para>This package provides the default splash screen for KDE.</para>
    3333
    34     &lfs75_checked;
     34    &lfs76_checked;
    3535
    3636    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6060    <bridgehead renderas="sect4">Required</bridgehead>
    6161    <para role="required">
    62     <xref linkend="kdelibs"/>
     62      <xref linkend="kdelibs"/>
    6363    </para>
    6464
  • kde/core/kde-baseapps.xml

    r7857007 rc1b61c6  
    3434    libraries are also provided.</para>
    3535
    36     &lfs75_checked;
     36    &lfs76_checked;
    3737
    3838    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6262    <bridgehead renderas="sect4">Required</bridgehead>
    6363    <para role="required">
    64     <xref linkend="kdelibs"/>
     64      <xref linkend="kdelibs"/>
    6565    </para>
    6666
    6767    <bridgehead renderas="sect4">Recommended</bridgehead>
    6868    <para role="recommended">
    69     <xref linkend="kactivities"/>,
    70     <xref linkend="kfilemetadata"/>,
    71     <xref linkend="baloo"/> and
    72     <xref linkend="baloo-widgets"/>
     69      <xref linkend="baloo"/>,
     70      <xref linkend="baloo-widgets"/>,
     71      <xref linkend="kactivities"/>, and
     72      <xref linkend="kfilemetadata"/>
    7373    </para>
    7474
    7575    <bridgehead renderas="sect4">Optional</bridgehead>
    7676    <para role="optional">
    77     <xref linkend="html-tidy"/> and
    78     <xref linkend="glib2"/>
     77      <xref linkend="glib2"/> and
     78      <xref linkend="html-tidy"/>
    7979    </para>
    8080
  • kde/core/kde-runtime.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="kde-runtime" xreflabel="kde-runtime-&kde-version;">
     15<sect1 id="kde-runtime" xreflabel="KDE-Runtime-&kde-version;">
    1616  <?dbhtml filename="kde-runtime.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Kde-runtime-&kde-version;</title>
     23  <title>KDE-Runtime-&kde-version;</title>
    2424
    2525  <indexterm zone="kde-runtime">
     
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to Kde-runtime</title>
     30    <title>Introduction to KDE-Runtime</title>
    3131
    32     <para>Kde-runtime contains runtime applications and libraries essential
     32    <para>KDE-Runtime contains runtime applications and libraries essential
    3333    for <application>KDE</application>.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59     <bridgehead renderas="sect3">Kde-runtime Dependencies</bridgehead>
     59    <bridgehead renderas="sect3">KDE-Runtime Dependencies</bridgehead>
    6060
    6161    <bridgehead renderas="sect4">Required</bridgehead>
     
    6666    <bridgehead renderas="sect4">Recommended</bridgehead>
    6767      <para role="recommended">
    68       <xref linkend="kactivities"/>,
    69       <xref linkend="kdepimlibs"/>,
    7068      <xref linkend="alsa-lib"/>,
    71       <xref linkend="libjpeg"/> and
    72       <xref linkend="exiv2"/>
     69      <xref linkend="exiv2"/>,
     70      <xref linkend="kactivities"/>, and
     71      <xref linkend="kdepimlibs"/>
    7372    </para>
    7473
    7574    <bridgehead renderas="sect4">Optional</bridgehead>
    7675    <para role="optional">
     76      <xref linkend="libcanberra"/>,
     77      <xref linkend="NetworkManager"/>,
    7778      <xref linkend="pulseaudio"/>,
     79      <xref linkend="samba"/>,
    7880      <xref linkend="xine-lib"/>,
    79       <xref linkend="libcanberra"/>,
    80       <xref linkend="samba"/>,
    81       <xref linkend="NetworkManager"/>,
    82       <ulink url="&kde-download-http;&kde-version;/src/">nepomuk-core</ulink>,
    83       <ulink url="http://www.openslp.org/">OpenSLP</ulink>,
    84       <ulink url="http://launchpad.net/ntrack">QNtrack</ulink>,
    85       <ulink url="http://www.libssh.org/">LibSSH</ulink> and
    86       <ulink url="http://www.openexr.com/">OpenEXR</ulink>
     81      <ulink url="http://www.libssh.org/">LibSSH</ulink>,
     82      <ulink url="&kde-download-http;&kde-version;/src/">Nepomuk-Core</ulink>,
     83      <ulink url="http://www.openexr.com/">OpenEXR</ulink>,
     84      <ulink url="http://www.openslp.org/">OpenSLP</ulink>, and
     85      <ulink url="http://launchpad.net/ntrack">QNtrack</ulink>
    8786    </para>
    8887
     
    9493
    9594  <sect2 role="installation">
    96     <title>Installation of Kde-runtime</title>
     95    <title>Installation of KDE-Runtime</title>
    9796
    98     <para>Install <application>kde-runtime</application> by running the following
     97    <para>Install <application>KDE-Runtime</application> by running the following
    9998    commands:</para>
    10099
     
    103102
    104103cmake -DCMAKE_INSTALL_PREFIX=&kde-dir;         \
    105       -DSYSCONF_INSTALL_DIR=/etc                  \
    106       -DCMAKE_BUILD_TYPE=Release                  \
     104      -DSYSCONF_INSTALL_DIR=/etc                 \
     105      -DCMAKE_BUILD_TYPE=Release                 \
    107106      -DSAMBA_INCLUDE_DIR=/usr/include/samba-4.0 \
    108107      -Wno-dev .. &amp;&amp;
  • kde/core/kde-workspace-systemd.xml

    r7857007 rc1b61c6  
    1414]>
    1515
    16 <sect1 id="kde-workspace" xreflabel="kde-workspace-&kde-workspace-version;">
     16<sect1 id="kde-workspace" xreflabel="KDE-Workspace-&kde-workspace-version;">
    1717  <?dbhtml filename="kde-workspace.html"?>
    1818
     
    2222  </sect1info>
    2323
    24   <title>Kde-workspace-&kde-workspace-version;</title>
     24  <title>KDE-Workspace-&kde-workspace-version;</title>
    2525
    2626  <indexterm zone="kde-workspace">
    27     <primary sortas="a-kde-workspace">kde-workspace</primary>
     27    <primary sortas="a-KDE-Workspace">KDE-Workspace</primary>
    2828  </indexterm>
    2929
    3030  <sect2 role="package">
    31     <title>Introduction to Kde-workspace</title>
    32 
    33     <para>
    34       The Kde-workspace package contains components that are central to
     31    <title>Introduction to KDE-Workspace</title>
     32
     33    <para>
     34      The KDE-Workspace package contains components that are central to
    3535      providing the <application>KDE</application> desktop environment. Of
    3636      particular importance are KWin, the <application>KDE</application>
     
    3838    </para>
    3939
    40     &lfs75_checked;
     40    &lfs76_checked;
    4141
    4242    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6262    </itemizedlist>
    6363
    64 <!--
    65     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    66     <itemizedlist spacing='compact'>
    67       <listitem>
    68         <para>Required patch: <ulink
    69         url="&patch-root;/kde-workspace-&kde4-version;-fixes-1.patch"/></para>
    70       </listitem>
    71     </itemizedlist>
    72 -->
    73     <bridgehead renderas="sect3">Kde-workspace Dependencies</bridgehead>
     64    <bridgehead renderas="sect3">KDE-Workspace Dependencies</bridgehead>
    7465
    7566    <bridgehead renderas="sect4">Required</bridgehead>
     
    7869      <xref linkend="qimageblitz"/>,
    7970      <xref linkend="xcb-util-image"/>,
    80       <xref linkend="xcb-util-renderutil"/>,
    81       <xref linkend="xcb-util-keysyms"/> and
     71      <xref linkend="xcb-util-keysyms"/>,
     72      <xref linkend="xcb-util-renderutil"/>, and
    8273      <xref linkend="xcb-util-wm"/>     
    8374    </para>
     
    8576    <bridgehead renderas="sect4">Recommended</bridgehead>
    8677    <para role="recommended">
     78      <xref linkend="boost"/>,
    8779      <xref linkend="kdepimlibs"/>,
    88       <xref linkend="boost"/>,
    8980      <xref linkend="pciutils"/>, and
    9081      <xref linkend="systemd"/> (for Logind)
     
    9384    <bridgehead renderas="sect4">Optional</bridgehead>
    9485    <para role="optional">
     86      <xref linkend="libusb-compat"/>,
    9587      <xref linkend="linux-pam"/>,
    96       <xref linkend="libusb"/>,
     88      <xref linkend="lm_sensors"/>,
    9789      <xref linkend="NetworkManager"/>,
    98       <xref linkend="lm_sensors"/>,
    9990      <xref linkend="qjson"/>,
    10091      <xref linkend="wayland"/>,
    101       <ulink url="&kde-download-http;&kde-version;/src/">PyKDE4</ulink>,
    10292      <ulink url="http://code.google.com/p/google-gadgets-for-linux/">GoogleGadgets</ulink>,
    103       <ulink url="ftp://ftp.kde.org/pub/kde/stable/prison/1.0/src/">Prison</ulink>,
     93      <ulink url="http://www.catb.org/gpsd/">GPSD</ulink>,
     94      <ulink url="http://qalculate.sourceforge.net/">libqalculate</ulink>
     95      (wants <ulink url="http://www.ginac.de/CLN/">CLN</ulink>),
    10496      <ulink url="http://sourceforge.net/projects/libraw1394/">libraw1394</ulink>,
    105       <ulink url="http://www.catb.org/gpsd/">gpsd</ulink>,
    106       <ulink url="http://www.xmms.org/">XMMS</ulink> and
    107       <ulink url="http://qalculate.sourceforge.net/">libqalculate</ulink>
    108       (wants <ulink url="http://www.ginac.de/CLN/">CLN</ulink>)
     97      <ulink url="http://projects.kde.org/prison">Prison</ulink>,
     98      <ulink url="&kde-download-http;&kde-version;/src/">PyKDE4</ulink>, and
     99      <ulink url="http://www.xmms.org/">XMMS</ulink>
    109100    </para>
    110101
    111102    <note>
    112103      <para>
    113         Kde-workspace has a run-time dependency called
     104        KDE-Workspace has a run-time dependency called
    114105        <application>Application menu for Qt</application> that allows the
    115106        application menubar to be inserted as a single button in the titlebar.
     
    126117
    127118  <sect2 role="installation">
    128     <title>Installation of Kde-workspace</title>
     119    <title>Installation of KDE-Workspace</title>
    129120
    130121    <para>
     
    141132
    142133    <para>
    143       Install <application>Kde-workspace</application> by running the following
     134      Install <application>KDE-Workspace</application> by running the following
    144135      commands:
    145136    </para>
  • kde/core/kdelibs.xml

    r7857007 rc1b61c6  
    3333    are central to development and execution of KDE programs.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59 <!--
    60     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    61     <itemizedlist spacing='compact'>
    62       <listitem>
    63         <para>Required patch: <ulink
    64         url="&patch-root;/kde4libs-&kde-version;-fixes-1.patch"/></para>
    65       </listitem>
    66     </itemizedlist>
    67 -->
    6859    <bridgehead renderas="sect3">KDELibs Dependencies</bridgehead>
    6960
    7061    <bridgehead renderas="sect4">Required</bridgehead>
    7162    <para role="required">
     63      <xref linkend="attica"/>,
     64      <xref linkend="DocBook"/>,
     65      <xref linkend="docbook-xsl"/>,
     66      <xref linkend="giflib"/>,
     67      <xref linkend="libdbusmenu-qt"/>,
     68      <xref linkend="libjpeg"/>,
     69      <xref linkend="libpng"/>,
    7270      <xref linkend="phonon"/>,
    73       <xref linkend="attica"/>,
    74       <xref linkend="strigi"/>,
    75       <xref linkend="libdbusmenu-qt"/>,
    76       <xref linkend="DocBook"/>,
    77       <xref linkend="docbook-xsl"/>, and
    78       <xref linkend="shared-mime-info"/>
     71      <xref linkend="shared-mime-info"/>, and
     72      <xref linkend="strigi"/>
    7973    </para>
    8074
    8175    <bridgehead renderas="sect4">Recommended</bridgehead>
    8276    <para role="recommended">
     77      <xref linkend="openssl"/>,
    8378      <xref linkend="polkit-qt"/>,
    84       <xref linkend="libpng"/>,
    85       <xref linkend="libjpeg"/>,
    86       <xref linkend="giflib"/>,
    87       <xref linkend="openssl"/>,
    8879      <xref linkend="qca"/>,
    89       <xref linkend="upower"/>, and
    90       <xref linkend="udisks"/> or <xref linkend="udisks2"/>
     80      <xref linkend="udisks"/> or
     81      <xref linkend="udisks2"/>, and
     82      <xref linkend="upower"/>
    9183    </para>
    9284
    9385    <bridgehead renderas="sect4">Optional</bridgehead>
    9486    <para role="optional">
    95       <xref linkend="jasper"/>,
    96       <xref linkend="pcre"/>,
     87      <xref linkend="aspell"/>,
    9788      <xref linkend="avahi"/>,
    98       <xref linkend="aspell"/>,
    9989      <xref linkend="enchant"/>,
    10090      <xref linkend="grantlee"/>,
     91      <xref linkend="jasper"/>,
    10192      <xref linkend="mitkrb"/>,
    102       <ulink url="&sourceforge-repo;/soprano">soprano</ulink>,
    103       <ulink url="&sourceforge-repo;/oscaf/">shared-desktop-ontologies</ulink>,
     93      <xref linkend="pcre"/>,
     94      <ulink url="http://oss.sgi.com/projects/fam/">FAM</ulink>,
    10495      <ulink url="http://hspell.ivrix.org.il/">Hspell</ulink>,
    105       <ulink url="http://oss.sgi.com/projects/fam/">FAM</ulink>,
    10696      <ulink url="http://www.herqq.org/">HUPnP</ulink>,
    107       <ulink url="http://www.openexr.com/">OpenEXR</ulink>, and
    108       <ulink url="http://www.freedesktop.org/wiki/Software/media-player-info">media-player-info</ulink>
     97      <ulink url="http://www.freedesktop.org/wiki/Software/media-player-info">media-player-info</ulink>,
     98      <ulink url="http://www.openexr.com/">OpenEXR</ulink>,
     99      <ulink url="&sourceforge-repo;/oscaf/">Shared-Desktop-Ontologies</ulink>, and
     100      <ulink url="&sourceforge-repo;/soprano/">Soprano</ulink>
    109101    </para>
    110102
     
    118110    <title>Installation of KDELibs</title>
    119111
    120     <para>Fix file conflicts with <application>GNOME Menus</application> by running
    121     the following commands:</para>
    122 
    123 <screen><userinput>sed -i "s@{SYSCONF_INSTALL_DIR}/xdg/menus@&amp; RENAME kde-applications.menu@" \
    124         kded/CMakeLists.txt &amp;&amp;
    125 
    126 sed -i "s@applications.menu@kde-&amp;@" \
    127         kded/kbuildsycoca.cpp</userinput></screen>
    128 
    129112    <para>
    130        Fix building with <xref linkend="giflib"/>:
    131     </para>
    132 
    133 <screen><userinput>sed -i "/DGifCloseFile/s:file:&amp;, NULL:g" \
    134        khtml/imload/decoders/gifloader.cpp</userinput></screen>
    135 
    136 <!--
    137     <para>Cmake looks for <application>Xorg</application> libraries in a set of
    138     hard coded directories instead of using
    139     <application>pkg-config</application>.  If <application>Xorg</application>
    140     has not been installed in <filename class="directory">/usr</filename>, add
    141     the location to the list:</para>
    142 
    143 <screen><userinput>sed -e "/SET(X11_LIB_SEARCH_PATH/ a $XORG_PREFIX/lib"     \
    144     -e "/SET(X11_INC_SEARCH_PATH/ a $XORG_PREFIX/include" \
    145     -i cmake/modules/FindX11.cmake</userinput></screen>
    146 -->
     113      First, silence a lot of warnings caused by using the latest toolchain
     114      by running the following command:
     115    </para>
     116
     117<screen><userinput>sed -i "s:BSD_SOURCE:DEFAULT_SOURCE:g"      \
     118                          cmake/modules/FindKDE4Internal.cmake \
     119                          kjsembed/qtonly/FindQJSInternal.cmake</userinput></screen>
     120
    147121    <para>Install <application>KDELibs</application> by running the following
    148122    commands:</para>
  • kde/core/kdepimlibs.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="kdepimlibs" xreflabel="kdepimlibs-&kde-version;">
     15<sect1 id="kdepimlibs" xreflabel="Kdepimlibs-&kde-version;">
    1616  <?dbhtml filename="kdepimlibs.html"?>
    1717
     
    2424
    2525  <indexterm zone="kdepimlibs">
    26     <primary sortas="a-kdepimlibs">kdepimlibs</primary>
     26    <primary sortas="a-Kdepimlibs">Kdepimlibs</primary>
    2727  </indexterm>
    2828
     
    3434    <command>kmail</command>, <command>kalarm</command>, etc.</para>
    3535
    36     &lfs75_checked;
     36    &lfs76_checked;
    3737
    3838    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5858    </itemizedlist>
    5959
    60 <!--
    61     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    62     <itemizedlist spacing='compact'>
    63       <listitem>
    64         <para>Required patch: <ulink
    65         url="&patch-root;/kdepimlibs-&kde-version;-fixes-1.patch"/></para>
    66       </listitem>
    67     </itemizedlist>
    68 -->
    6960    <bridgehead renderas="sect3">Kdepimlibs Dependencies</bridgehead>
    7061
    7162    <bridgehead renderas="sect4">Required</bridgehead>
    7263    <para role="required">
     64      <xref linkend="akonadi"/>,
     65      <xref linkend="boost"/>,
     66      <xref linkend="cyrus-sasl"/>,
     67      <xref linkend="gpgme"/>,
    7368      <xref linkend="kdelibs"/>,
    74       <xref linkend="libxslt"/>,
    75       <xref linkend="gpgme"/>,
    7669      <xref linkend="libical"/>,
    77       <xref linkend="akonadi"/>,
    78       <xref linkend="cyrus-sasl"/>,
    79       <xref linkend="boost"/> and
     70      <xref linkend="libxslt"/>, and
    8071      <xref linkend="qjson"/>
    8172    </para>
     
    8879    <bridgehead renderas="sect4">Optional</bridgehead>
    8980    <para role="optional">
    90       <xref linkend="openssl"/>
    91       <ulink url="http://projects.kde.org/prison">prison</ulink>
     81      <xref linkend="openssl"/> and
     82      <ulink url="http://projects.kde.org/prison">Prison</ulink>
    9283    </para>
    9384
     
    10495    commands:</para>
    10596
    106 <!-- Again, nothing in sysconfdir -->
    10797<screen><userinput>mkdir build &amp;&amp;
    10898cd    build &amp;&amp;
  • kde/core/kfilemetadata.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="kfilemetadata" xreflabel="kfilemetadata-&kde-version;">
     15<sect1 id="kfilemetadata" xreflabel="KFileMetaData-&kde-version;">
    1616  <?dbhtml filename="kfilemetadata.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Kfilemetadata-&kde-version;</title>
     23  <title>KFileMetaData-&kde-version;</title>
    2424
    2525  <indexterm zone="kfilemetadata">
    26     <primary sortas="a-kfilemetadata">kfilemetadata</primary>
     26    <primary sortas="a-KFileMetaData">KFileMetaData</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to Kfilemetadata</title>
     30    <title>Introduction to KFileMetaData</title>
    3131
    32     <para>Kfilemetadata is a framework for searching and managing metadata.</para>
     32    <para>KFileMetaData is a framework for searching and managing metadata.</para>
    3333
    34     &lfs75_checked;
     34    &lfs76_checked;
    3535
    3636    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5656    </itemizedlist>
    5757
    58     <bridgehead renderas="sect3">Kfilemetadata Dependencies</bridgehead>
     58    <bridgehead renderas="sect3">KFileMetaData Dependencies</bridgehead>
    5959
    6060    <bridgehead renderas="sect4">Required</bridgehead>
    6161    <para role="required">
    62     <xref linkend="kdelibs"/>
     62      <xref linkend="kdelibs"/>
    6363    </para>
    6464   
    6565    <bridgehead renderas="sect4">Optional</bridgehead>
    6666    <para role="optional">
    67     <xref linkend="taglib"/>,
    68     <xref linkend="poppler"/>,
    69     <xref linkend="exiv2"/>,
    70     <xref linkend="ffmpeg"/>,
    71     <ulink url="http://sourceforge.net/projects/ebook-tools">libepub</ulink> and
    72     <ulink url="https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-mobipocket">Mobipocket</ulink>
     67      <xref linkend="exiv2"/>,
     68      <xref linkend="ffmpeg"/>,
     69      <xref linkend="poppler"/>,
     70      <xref linkend="taglib"/>,
     71      <ulink url="http://sourceforge.net/projects/ebook-tools">libepub</ulink>, and
     72      <ulink url="https://projects.kde.org/projects/kde/kdegraphics/kdegraphics-mobipocket">Mobipocket</ulink>
    7373    </para>
    7474
     
    8080
    8181  <sect2 role="installation">
    82     <title>Installation of Kfilemetadata</title>
     82    <title>Installation of KFileMetaData</title>
    8383
    84     <para>Install <application>kfilemetadata</application> by running the following
     84    <para>Install <application>KFileMetaData</application> by running the following
    8585    commands:</para>
    8686
  • kde/core/oxygen-icons.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="oxygen-icons" xreflabel="oxygen-icons-&kde-version;">
     15<sect1 id="oxygen-icons" xreflabel="Oxygen-Icons-&kde-version;">
    1616  <?dbhtml filename="oxygen-icons.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Oxygen-icons-&kde-version;</title>
     23  <title>Oxygen-Icons-&kde-version;</title>
    2424
    2525  <indexterm zone="oxygen-icons">
    26     <primary sortas="a-oxygen-icons">oxygen-icons</primary>
     26    <primary sortas="a-Oxygen-Icons">Oxygen-Icons</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to Oxygen-icons</title>
     30    <title>Introduction to Oxygen-Icons</title>
    3131
    3232    <para>The Oxygen theme is a photo-realistic icon style, with a
    3333    high standard of graphics quality.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59     <bridgehead renderas="sect3">Oxygen-icons Dependencies</bridgehead>
     59    <bridgehead renderas="sect3">Oxygen-Icons Dependencies</bridgehead>
    6060
    6161    <bridgehead renderas="sect4">Required</bridgehead>
    6262    <para role="required">
    63     <xref linkend="cmake"/>
     63      <xref linkend="cmake"/>
    6464    </para>
    6565
     
    7070
    7171  <sect2 role="installation">
    72     <title>Installation of Oxygen-icons</title>
     72    <title>Installation of Oxygen-Icons</title>
    7373
    74     <para>Install <application>Oxygen-icons</application> by running
     74    <para>Install <application>Oxygen-Icons</application> by running
    7575    the following commands:</para>
    7676
  • kde/core/phonon-backend-gstreamer.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="phonon-backend-gstreamer" xreflabel="phonon-backend-gstreamer-&phonon-backend-gstreamer-version;">
     15<sect1 id="phonon-backend-gstreamer" xreflabel="Phonon-Backend-GStreamer-&phonon-backend-gstreamer-version;">
    1616  <?dbhtml filename="phonon-backend-gstreamer.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Phonon-backend-gstreamer-&phonon-backend-gstreamer-version;</title>
     23  <title>Phonon-Backend-GStreamer-&phonon-backend-gstreamer-version;</title>
    2424
    2525  <indexterm zone="phonon-backend-gstreamer">
    26     <primary sortas="a-phonon-backend-gstreamer">phonon-backend-gstreamer</primary>
     26    <primary sortas="a-Phonon-Backend-GStreamer">Phonon-Backend-GStreamer</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to the Phonon-backend-gstreamer</title>
     30    <title>Introduction to the Phonon-Backend-GStreamer</title>
    3131
    3232    <para>This package provides a <application>Phonon</application> backend which
    3333    utilizes the <application>GStreamer</application> media framework.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59     <bridgehead renderas="sect3">Phonon-backend-gstreamer Dependencies</bridgehead>
     59    <bridgehead renderas="sect3">Phonon-Backend-GStreamer Dependencies</bridgehead>
    6060
    6161    <bridgehead renderas="sect4">Required</bridgehead>
    6262    <para role="required">
    63     <xref linkend="phonon"/> and
    64     <xref linkend="gstreamer"/>
     63      <xref linkend="gstreamer"/> and
     64      <xref linkend="phonon"/>
    6565    </para>
    6666
    6767    <bridgehead renderas="sect4">Recommended</bridgehead>
    6868    <para role="recommended">
    69     <xref linkend="gst-plugins-base"/> (needed for output to ALSA),
    70     <xref linkend="gst-plugins-good"/> (needed for output to PulseAudio),
    71     <xref linkend="gst-plugins-bad"/> (needed for AAC/M4A support) and
    72     <xref linkend="gst-plugins-ugly"/> (needed for MP3 support)
     69      <xref linkend="gst-plugins-base"/> (needed for output to ALSA),
     70      <xref linkend="gst-plugins-good"/> (needed for output to PulseAudio),
     71      <xref linkend="gst-plugins-bad"/> (needed for AAC/M4A support) and
     72      <xref linkend="gst-plugins-ugly"/> (needed for MP3 support)
    7373    </para>
    7474
     
    7979
    8080  <sect2 role="installation">
    81     <title>Installation of Phonon-backend-gstreamer</title>
     81    <title>Installation of Phonon-Backend-GStreamer</title>
    8282
    83     <para>Install <application>Phonon-backend-gstreamer</application> by running the following
     83    <para>Install <application>Phonon-Backend-GStreamer</application> by running the following
    8484    commands:</para>
    8585
  • kde/core/phonon-backend-vlc.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="phonon-backend-vlc" xreflabel="phonon-backend-vlc-&phonon-backend-vlc-version;">
     15<sect1 id="phonon-backend-vlc" xreflabel="Phonon-Backend-VLC-&phonon-backend-vlc-version;">
    1616  <?dbhtml filename="phonon-backend-vlc.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Phonon-backend-vlc-&phonon-backend-vlc-version;</title>
     23  <title>Phonon-Backend-VLC-&phonon-backend-vlc-version;</title>
    2424
    2525  <indexterm zone="phonon-backend-vlc">
    26     <primary sortas="a-phonon-backend-vlc">phonon-backend-vlc</primary>
     26    <primary sortas="a-Phonon-Backend-VLC">Phonon-Backend-VLC</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to the Phonon-backend-vlc</title>
     30    <title>Introduction to the Phonon-Backend-VLC</title>
    3131
    3232    <para>This package provides a <application>Phonon</application> backend which
    3333    utilizes the <application>VLC</application> media framework.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59     <bridgehead renderas="sect3">Phonon-backend-vlc Dependencies</bridgehead>
     59    <bridgehead renderas="sect3">Phonon-Backend-VLC Dependencies</bridgehead>
    6060
    6161    <bridgehead renderas="sect4">Required</bridgehead>
    6262    <para role="required">
    63     <xref linkend="phonon"/> and
    64     <xref linkend="vlc"/>
     63      <xref linkend="phonon"/> and
     64      <xref linkend="vlc"/>
    6565    </para>
    6666
     
    7171
    7272  <sect2 role="installation">
    73     <title>Installation of Phonon-backend-vlc</title>
     73    <title>Installation of Phonon-Backend-VLC</title>
    7474
    75     <para>Install <application>Phonon-backend-vlc</application> by running the following
     75    <para>Install <application>Phonon-Backend-VLC</application> by running the following
    7676    commands:</para>
    7777
  • kde/core/phonon.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="phonon" xreflabel="phonon-&phonon-version;">
     15<sect1 id="phonon" xreflabel="Phonon-&phonon-version;">
    1616  <?dbhtml filename="phonon.html"?>
    1717
     
    2424
    2525  <indexterm zone="phonon">
    26     <primary sortas="a-phonon">phonon</primary>
     26    <primary sortas="a-Phonon">Phonon</primary>
    2727  </indexterm>
    2828
     
    3434    supported by KDE. Phonon needs either the GStreamer or VLC backend.</para>
    3535
    36     &lfs75_checked;
     36    &lfs76_checked;
    3737
    3838    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6969    <para role="optional">
    7070      <xref linkend="pulseaudio"/>,
    71       <xref linkend="qt5"/> and
     71      <xref linkend="qt5"/>, and
    7272      <ulink url="http://projects.kde.org/projects/kdesupport/libqzeitgeist/">QZeitgeist</ulink>
    7373    </para>
     
    8585    a better implementation.</para>
    8686
     87    <para>
     88      First, silence a lot of warnings caused by using the latest toolchain
     89      by running the following command:
     90    </para>
     91
     92<screen><userinput>sed -i "s:BSD_SOURCE:DEFAULT_SOURCE:g" cmake/FindPhononInternal.cmake</userinput></screen>
     93
    8794    <para>Install <application>Phonon</application> by running the following
    8895    commands:</para>
     
    96103      -DCMAKE_INSTALL_LIBDIR=lib \
    97104      -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=FALSE \
    98       -DDBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces \
    99105      -Wno-dev .. &amp;&amp;
    100106make</userinput></screen>
     
    118124      This switch ensures that the plugins and mkspecs files get installed in
    119125      the correct location.
    120     </para>
    121 
    122     <para>
    123      <parameter>-DDBUS_INTERFACES_INSTALL_DIR=/usr/share/dbus-1/interfaces</parameter>:
    124       This switch sets the correct installation path for the
    125       <application>D-Bus</application> interfaces file.
    126126    </para>
    127127
  • kde/core/polkit-kde-agent.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="polkit-kde-agent" xreflabel="polkit-kde-agent-&polkit-kde-agent-version;">
     15<sect1 id="polkit-kde-agent" xreflabel="Polkit-KDE-Agent-&polkit-kde-agent-version;">
    1616  <?dbhtml filename="polkit-kde-agent.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>Polkit-kde-agent-&polkit-kde-agent-version;</title>
     23  <title>Polkit-KDE-Agent-&polkit-kde-agent-version;</title>
    2424
    2525  <indexterm zone="polkit-kde-agent">
    26     <primary sortas="a-polkit-kde-agent">polkit-kde-agent</primary>
     26    <primary sortas="a-Polkit-KDE-Agent">Polkit-KDE-Agent</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to Polkit-kde-agent</title>
     30    <title>Introduction to Polkit-KDE-Agent</title>
    3131
    32     <para><application>Polkit-kde-agent</application> provides a graphical
     32    <para><application>Polkit-KDE-Agent</application> provides a graphical
    3333    authentication prompt so non-priviledged users can authenticate themselves
    3434    for performing administrative tasks in KDE.</para>
    3535
    36     &lfs75_checked;
     36    &lfs76_checked;
    3737
    3838    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5858    </itemizedlist>
    5959
    60 
    6160    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    6261    <itemizedlist spacing='compact'>
     
    6766    </itemizedlist>
    6867
    69     <bridgehead renderas="sect3">Polkit-kde-agent Dependencies</bridgehead>
     68    <bridgehead renderas="sect3">Polkit-KDE-Agent Dependencies</bridgehead>
    7069
    7170    <bridgehead renderas="sect4">Required</bridgehead>
    7271    <para role="required">
    73     <xref linkend="polkit-qt"/> and
    74     <xref linkend="kdelibs"/>
     72      <xref linkend="kdelibs"/> and
     73      <xref linkend="polkit-qt"/>
    7574    </para>
    7675
     
    8180
    8281  <sect2 role="installation">
    83     <title>Installation of Polkit-kde-agent</title>
     82    <title>Installation of Polkit-KDE-Agent</title>
    8483
    85     <para>Install <application>polkit-kde-agent</application> by running the following
     84    <para>Install <application>Polkit-KDE-Agent</application> by running the following
    8685    commands:</para>
    8786
     
    116115      </seglistitem>
    117116    </segmentedlist>
    118 <!--
    119     <variablelist>
    120       <bridgehead renderas="sect3">Short Descriptions</bridgehead>
    121       <?dbfo list-presentation="list"?>
    122       <?dbhtml list-presentation="table"?>
    123117
    124       <varlistentry id="a-polkit-kde-agent">
    125         <term><command>polkit-kde-agent</command></term>
    126         <listitem>
    127           <para>is a testing utility for polkit-kde-agent-generated build trees.</para>
    128           <indexterm zone="a-polkit-kde-agent polkit-kde-agent">
    129             <primary sortas="b-polkit-kde-agent">polkit-kde-agent</primary>
    130           </indexterm>
    131         </listitem>
    132       </varlistentry>
    133 
    134     </variablelist>
    135 -->
    136118  </sect2>
    137119
  • kde/core/polkit-qt.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="polkit-qt" xreflabel="polkit-qt-&polkit-qt-version;">
     15<sect1 id="polkit-qt" xreflabel="Polkit-Qt-&polkit-qt-version;">
    1616  <?dbhtml filename="polkit-qt.html"?>
    1717
     
    2424
    2525  <indexterm zone="polkit-qt">
    26     <primary sortas="a-polkit-qt">polkit-qt</primary>
     26    <primary sortas="a-Polkit-Qt">Polkit-Qt</primary>
    2727  </indexterm>
    2828
     
    3333    <application>polkit</application> in the Qt environment.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59 <!--
    60     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    61     <itemizedlist spacing='compact'>
    62       <listitem>
    63         <para>Required patch: <ulink
    64         url="&patch-root;/polkit-qt-&polkit-qt-version;-fixes-1.patch"/></para>
    65       </listitem>
    66     </itemizedlist>
    67 -->
    6859    <bridgehead renderas="sect3">Polkit-Qt Dependencies</bridgehead>
    6960
    7061    <bridgehead renderas="sect4">Required</bridgehead>
    7162    <para role="required">
    72     <xref linkend="automoc4"/> and
    73     <xref linkend="polkit"/>
     63      <xref linkend="automoc4"/> and
     64      <xref linkend="polkit"/>
    7465    </para>
    7566
     
    142133      </seglistitem>
    143134    </segmentedlist>
    144 <!--
    145     <variablelist>
    146       <bridgehead renderas="sect3">Short Descriptions</bridgehead>
    147       <?dbfo list-presentation="list"?>
    148       <?dbhtml list-presentation="table"?>
    149135
    150       <varlistentry id="a-polkit-qt">
    151         <term><command>polkit-qt</command></term>
    152         <listitem>
    153           <para>is a testing utility for polkit-qt-generated build trees.</para>
    154           <indexterm zone="a-polkit-qt polkit-qt">
    155             <primary sortas="b-polkit-qt">polkit-qt</primary>
    156           </indexterm>
    157         </listitem>
    158       </varlistentry>
    159 
    160     </variablelist>
    161 -->
    162136  </sect2>
    163137
  • kde/core/qimageblitz.xml

    r7857007 rc1b61c6  
    1313]>
    1414
    15 <sect1 id="qimageblitz" xreflabel="qimageblitz-&qimageblitz-version;">
     15<sect1 id="qimageblitz" xreflabel="QImageBlitz-&qimageblitz-version;">
    1616  <?dbhtml filename="qimageblitz.html"?>
    1717
     
    2121  </sect1info>
    2222
    23   <title>QImageblitz-&qimageblitz-version;</title>
     23  <title>QImageBlitz-&qimageblitz-version;</title>
    2424
    2525  <indexterm zone="qimageblitz">
    26     <primary sortas="a-qimageblitz">qimageblitz</primary>
     26    <primary sortas="a-QImageBlitz">QImageBlitz</primary>
    2727  </indexterm>
    2828
    2929  <sect2 role="package">
    30     <title>Introduction to QImageblitz</title>
     30    <title>Introduction to QImageBlitz</title>
    3131
    32     <para><application>QImageblitz</application> is a graphical effect and
     32    <para><application>QImageBlitz</application> is a graphical effect and
    3333    filter library for <application>KDE</application>.</para>
    3434
    35     &lfs75_checked;
     35    &lfs76_checked;
    3636
    3737    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    5757    </itemizedlist>
    5858
    59 <!--
    60     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    61     <itemizedlist spacing='compact'>
    62       <listitem>
    63         <para>Required patch: <ulink
    64         url="&patch-root;/qimageblitz-&qimageblitz-version;-fixes-1.patch"/></para>
    65       </listitem>
    66     </itemizedlist>
    67 -->
    68 
    69     <bridgehead renderas="sect3">QImageblitz Dependencies</bridgehead>
     59    <bridgehead renderas="sect3">QImageBlitz Dependencies</bridgehead>
    7060
    7161    <bridgehead renderas="sect4">Required</bridgehead>
    7262    <para role="required">
    73     <xref linkend="qt4"/> and
    74     <xref linkend="cmake"/>
     63      <xref linkend="cmake"/> and
     64      <xref linkend="qt4"/>
    7565    </para>
    7666
     
    8171
    8272  <sect2 role="installation">
    83     <title>Installation of QImageblitz</title>
     73    <title>Installation of QImageBlitz</title>
    8474
    85     <para>Install <application>QImageblitz</application> by running the following
     75    <para>Install <application>QImageBlitz</application> by running the following
    8676    commands:</para>
    8777
  • kde/intro/pre-install-config.xml

    r7857007 rc1b61c6  
    6363
    6464# End /etc/profile.d/kde.sh</literal>
    65 EOF
    66 </userinput></screen>
     65EOF</userinput></screen>
    6766
    6867    <para>Add to your <filename>/etc/ld.so.conf</filename>:</para>
Note: See TracChangeset for help on using the changeset viewer.