Changeset c7f6a7e1


Ignore:
Timestamp:
03/28/2021 05:43:13 PM (4 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
03eca7f9
Parents:
6b2a913
Message:

update to samba-4.14.2

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@24411 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
3 edited

Legend:

Unmodified
Added
Removed
  • introduction/welcome/changelog.xml

    r6b2a913 rc7f6a7e1  
    4646      <itemizedlist>
    4747        <listitem>
     48          <para>[xry111] - Update to samba-4.14.2.  Fixes
     49          <ulink url="&blfs-ticket-root;14819">#14819</ulink>.</para>
     50        </listitem>
     51        <listitem>
    4852          <para>[renodr] - Adapted the instructions for backgrounds in Fluxbox
    4953          to be able to copy themes that are stored in directories.</para>
  • networking/netprogs/samba.xml

    r6b2a913 rc7f6a7e1  
    77  <!ENTITY samba-download-http "https://www.samba.org/ftp/samba/stable/samba-&samba-version;.tar.gz">
    88  <!ENTITY samba-download-ftp  " ">
    9   <!ENTITY samba-md5sum        "b1001900f542116e509b514e7e639875">
     9  <!ENTITY samba-md5sum        "2c726e392a7d36743ae0517e48db36eb">
    1010  <!ENTITY samba-size          "18 MB">
    1111  <!ENTITY samba-buildsize     "620 MB (add 380 MB for quicktest)">
     
    9696      <xref linkend="libxslt"/> (for documentation),
    9797      <xref linkend="linux-pam"/>,
    98       <xref linkend="perl-parse-yapp"/>,
    99       <xref linkend="pycryptodome"/>, and
     98      <xref linkend="perl-parse-yapp"/>, and
    10099      <xref linkend="openldap"/>
    101100    </para>
     
    179178
    180179    <para>
    181       If you wish to run the test suite, install some python modules first:
    182     </para>
    183 
    184 <screen role="root"><userinput remap="pre">pip3 install cryptography pyasn1 iso8601</userinput></screen>
     180      To support the test suite, set up a Python virtual environment
     181      for some Python modules out of the scope of BLFS:
     182    </para>
     183
     184<screen><userinput remap="pre">python3 -m venv pyvenv &amp;&amp;
     185./pyvenv/bin/pip3 install cryptography pyasn1 iso8601</userinput></screen>
    185186
    186187    <para>
     
    195196    </para>
    196197
    197 <screen revision="sysv"><userinput>CPPFLAGS="-I/usr/include/tirpc"        \
     198<screen revision="sysv"><userinput>PYTHON=$PWD/pyvenv/bin/python3         \
     199CPPFLAGS="-I/usr/include/tirpc"        \
    198200LDFLAGS="-ltirpc"                      \
    199201./configure                            \
     
    209211make</userinput></screen>
    210212
    211 <screen revision="systemd"><userinput>CPPFLAGS="-I/usr/include/tirpc"        \
     213<screen revision="systemd"><userinput>PYTHON=$PWD/pyvenv/bin/python3         \
     214CPPFLAGS="-I/usr/include/tirpc"        \
    212215LDFLAGS="-ltirpc"                      \
    213216./configure                            \
     
    247250      <para>
    248251        Additionally, developer test suites are available. If you've installed
    249         the optional python modules above, you can run these tests with
     252        the optional python modules above in the Python virtual environment
     253        for building this package, you can run these tests with
    250254        <command>make test</command>. It is not recommended for the average
    251255        builder at around 290 SBU and over a gigabyte of disk space, and you
     
    255259
    256260    <para>
    257       Now, as the <systemitem class="username">root</systemitem> user:
     261      Fix a hard coded path to Python 3 interpreter:
     262    </para>
     263
     264<screen><userinput>sed '1s@^.*$@#!/usr/bin/python3@' \
     265    -i ./bin/default/source4/scripting/bin/samba-gpupdate.inst</userinput></screen>
     266
     267    <para>
     268      If upgrading from an old version of samba, as the
     269      <systemitem class="username">root</systemitem> user, remove the old
     270      Python support files to prevent some issue:
     271    </para>
     272
     273<screen role="root"><userinput>rm -rf /usr/lib/python&python3-majorver;/site-packages/samba</userinput></screen>
     274
     275    <para>
     276      Still as the <systemitem class="username">root</systemitem> user,
     277      install the package:
    258278    </para>
    259279
  • packages.ent

    r6b2a913 rc7f6a7e1  
    597597<!ENTITY rpcbind-version              "1.2.5">
    598598<!ENTITY rsync-version                "3.2.3">
    599 <!ENTITY samba-version                "4.14.0">
     599<!ENTITY samba-version                "4.14.2">
    600600<!ENTITY wget-version                 "1.21.1">
    601601<!ENTITY wireless-tools-version       "29">
Note: See TracChangeset for help on using the changeset viewer.