Changeset d2c16a45


Ignore:
Timestamp:
10/06/2022 11:50:55 AM (2 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
plabs/python-mods, trunk
Children:
1f1f2230
Parents:
58f6a7b
Message:

cmake: demote libuv to recommended, and add <option> for building cmake w/o recommended dependencies

Tested on a fresh LFS system.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • general/prog/cmake.xml

    r58f6a7b rd2c16a45  
    8888    <bridgehead renderas="sect3">CMake Dependencies</bridgehead>
    8989
    90     <bridgehead renderas="sect4">Required</bridgehead>
    91     <para role="required">
    92       <xref linkend="libuv"/>
    93     </para>
    94 
    9590    <bridgehead renderas="sect4">Recommended</bridgehead>
    9691    <para role="recommended">
    9792      <xref linkend="curl"/>,
    98       <xref linkend="libarchive"/>, and
     93      <xref linkend="libarchive"/>,
     94      <xref linkend="libuv"/>, and
    9995      <xref linkend="nghttp2"/>
    10096    </para>
     
    201197      <application>librhash</application> library from the list of system
    202198      libraries used. A bundled version of that library is used instead.
     199    </para>
     200
     201    <para>
     202      <option>--no-system-{curl,libarchive,libuv,nghttp2}</option>: Use
     203      the corresponding option in the list for the
     204      <command>bootstrap</command> if one recommended dependency is not
     205      installed.  A bundled version of the dependency will be used instead.
    203206    </para>
    204207
Note: See TracChangeset for help on using the changeset viewer.