Changeset d57804d


Ignore:
Timestamp:
12/12/2011 01:12:28 PM (10 years ago)
Author:
Andrew Benton <andy@…>
Branches:
10.0, 10.1, 11.0, 11.1, 7.10, 7.4, 7.5, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, krejzi/svn, lazarus, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, upgradedb, xry111/intltool, xry111/test-20220226
Children:
caddc9ff
Parents:
e08a501
Message:

webkit-1.6.1

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@9101 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
3 edited

Legend:

Unmodified
Added
Removed
  • general.ent

    re08a501 rd57804d  
    44-->
    55
    6 <!ENTITY day          "11">                   <!-- Always 2 digits -->
     6<!ENTITY day          "12">                   <!-- Always 2 digits -->
    77<!ENTITY month        "12">                   <!-- Always 2 digits -->
    88<!ENTITY year         "2011">
     
    1010<!ENTITY copyholder   "The BLFS Development Team">
    1111<!ENTITY version      "&year;-&month;-&day;">
    12 <!ENTITY releasedate  "December 11th, &year;">
     12<!ENTITY releasedate  "December 12th, &year;">
    1313<!-- <!ENTITY releasedate  "November &day;st, &year;"> -->
    1414<!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
     
    208208<!ENTITY ptlib-version                "2.6.7">
    209209<!ENTITY libatasmart-version          "0.17">
    210 <!ENTITY talloc-version               "2.0.7">
     210<!ENTITY talloc-version               "2.0.1">
    211211<!ENTITY telepathy-glib-version       "0.9.2">
    212212<!ENTITY wv-version                   "1.2.9">
     
    229229<!ENTITY libjpeg-version              "8c">
    230230<!ENTITY libpng-version               "1.5.5">
    231 <!ENTITY libtiff-version              "3.9.5">
     231<!ENTITY libtiff-version              "3.9.4">
    232232<!ENTITY giflib-version               "4.1.6">
    233233<!ENTITY lcms-version                 "1.19">
    234234<!ENTITY libmng-version               "1.0.10">
    235 <!ENTITY freetype2-version            "2.4.8">
     235<!ENTITY freetype2-version            "2.4.4">
    236236<!ENTITY fontconfig-version           "2.8.0">
    237237<!ENTITY libart_lgpl-version          "2.3.21">
     
    244244<!ENTITY poppler-version              "0.14.4">
    245245<!ENTITY jasper-version               "1.900.1">
    246 <!ENTITY pixman-version               "0.24.0">
     246<!ENTITY pixman-version               "0.15.20">
    247247<!ENTITY clutter-version              "1.2.10">
    248248<!ENTITY clutter-gtk-version          "0.10.4">
    249 <!ENTITY babl-version                 "0.1.6">
    250 <!ENTITY gegl-version                 "0.1.8">
     249<!ENTITY babl-version                 "0.1.2">
     250<!ENTITY gegl-version                 "0.1.2">
    251251
    252252<!-- Obsolete
     
    257257<!-- Chapter 10 -->
    258258<!ENTITY bc-version                   "1.06.95">
    259 <!ENTITY rep-gtk-version              "0.90.2">
     259<!ENTITY rep-gtk-version              "0.18">
    260260<!ENTITY sharutils-version            "4.11.1">
    261261<!ENTITY compface-version             "1.5.2">
     
    264264<!ENTITY gtk-doc-version              "1.14">
    265265<!ENTITY scrollkeeper-version         "0.3.14">
    266 <!ENTITY intltool-version             "0.50.0">
     266<!ENTITY intltool-version             "0.41.1">
    267267<!ENTITY screen-version               "4.0.3">
    268268<!ENTITY tidy-version                 "cvs_20101110">
     
    331331<!ENTITY jdk-version                  "6 Update 18">
    332332<!ENTITY junit-version                "4.8.1">
    333 <!ENTITY librep-version               "0.90.5">
    334 <!ENTITY llvm-version                 "3.0">
     333<!ENTITY librep-version               "0.17">
    335334<!ENTITY NASM-version                 "2.09.10">
    336335<!ENTITY yasm-version                 "1.2.0">
     
    573572<!ENTITY mesalib-version              "7.9">
    574573<!ENTITY xulrunner-version            "8.0.1">
    575 <!ENTITY webkitgtk-version            "1.2.5">
     574<!ENTITY webkitgtk-version            "1.6.1">
    576575<!ENTITY libsexy-version              "0.1.11">
    577576<!ENTITY libnotify-version            "0.4.5">
     
    776775<!ENTITY gnumeric-version             "1.10.11">
    777776<!ENTITY gnucash-version              "2.2.4">
    778 <!ENTITY gimp-version                 "2.6.11">
     777<!ENTITY gimp-version                 "2.6.8">
    779778<!ENTITY evolution-version            "2.30.2">
    780779<!ENTITY icedtea-web-version          "1.0.1">
  • introduction/welcome/changelog.xml

    re08a501 rd57804d  
    4343-->
    4444    <listitem>
     45      <para>December 12th, 2011</para>
     46      <itemizedlist>
     47        <listitem>
     48          <para>[abenton] - Updated Webkitgtk to 1.6.1.</para>
     49        </listitem>
     50      </itemizedlist>
     51    </listitem>
     52
     53    <listitem>
    4554      <para>December 11th, 2011</para>
    4655      <itemizedlist>
  • x/lib/webkitgtk.xml

    re08a501 rd57804d  
    77  <!ENTITY webkitgtk-download-http "http://webkitgtk.org/webkit-&webkitgtk-version;.tar.gz">
    88  <!ENTITY webkitgtk-download-ftp  " ">
    9   <!ENTITY webkitgtk-md5sum        "09f04985665b9abf6f0d9956f86a6a31">
    10   <!ENTITY webkitgtk-size          "6.5 MB">
    11   <!ENTITY webkitgtk-buildsize     "300 MB">
    12   <!ENTITY webkitgtk-time          "18 SBU">
     9  <!ENTITY webkitgtk-md5sum        "c11743694b1b71dad287b2e7a9e73b05">
     10  <!ENTITY webkitgtk-size          "9.7 MB">
     11  <!ENTITY webkitgtk-buildsize     "500 MB (38 MB installed)">
     12  <!ENTITY webkitgtk-time          "28 SBU">
    1313]>
    1414
     
    3434    <application>GTK+</application> platform.</para>
    3535
    36     &lfs67_checked;
     36    &lfs70_checked;
    3737
    3838    <bridgehead renderas="sect3">Package Information</bridgehead>
     
    6161
    6262    <bridgehead renderas="sect4">Required</bridgehead>
    63     <para role="required"><xref linkend="enchant"/>,
    64     <xref linkend="gperf"/>,
    65     <xref linkend="gst-plugins-base"/>,
    66     <xref linkend="gtk2"/>,
    67     <xref linkend="icu"/>,
    68     <xref linkend="libjpeg"/>,
    69     <xref linkend="libsoup"/>,
    70     <xref linkend="libxslt"/>,
    71     <xref linkend="pcre"/>,
    72     <xref linkend="sqlite"/>, and
    73     <xref linkend="which"/></para>
    74 
    75     <bridgehead renderas="sect4">Recommended</bridgehead>
    76     <para role="recommended"><xref linkend="gobject-introspection"/> (Required
    77     if building <application>epiphany</application>)</para>
    78 
    79 
     63    <para role="required"><xref linkend="gperf"/>, <xref linkend="libjpeg"/>,
     64    <xref linkend="libpng"/>, <xref linkend="icu"/>, <xref linkend="libxslt"/>,
     65    <xref linkend="gtk2"/> or <xref linkend="gtk3"/> (if both are installed
     66    configure defaults to using gtk+-3), <xref linkend="libsoup"/>,
     67    <xref linkend="gst-plugins-base"/>, <xref linkend="which"/>
     68    and <xref linkend="sqlite"/></para>
    8069
    8170    <bridgehead renderas="sect4">Optional</bridgehead>
    82     <para role="optional"><xref linkend="curl"/>,
    83     <ulink url="http://www.freedesktop.org/wiki/Software/GeoClue">GeoClue</ulink>,
    84     <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>, and
    85     <xref linkend="gtk-doc"/></para>
     71    <para role="optional"><xref linkend="curl"/>, <xref linkend="enchant"/>,
     72    <ulink
     73    url="http://www.freedesktop.org/wiki/Software/GeoClue">GeoClue</ulink>,
     74    <xref linkend="gobject-introspection"/> (required if building
     75    <application>epiphany</application>), <xref linkend="gtk-doc"/> and
     76    <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>.</para>
    8677
    8778    <para condition="html" role="usernotes">User Notes:
     
    9384    <title>Installation of WebKitGTK+</title>
    9485
    95     <para>Install <application>WebKitGTK+</application> by running the following
    96     commands:</para>
    97 
    98 <screen><userinput>./configure --prefix=/usr --enable-introspection &amp;&amp;
     86    <para>Install <application>WebKitGTK+</application> by running the
     87    following commands:</para>
     88
     89<screen><userinput>./configure --prefix=/usr --with-gtk=2.0 &amp;&amp;
    9990make</userinput></screen>
    10091
     
    10293    in an xterm or similar to do this, because it launches some windows).</para>
    10394
    104     <para>Now, as the <systemitem class="username">root</systemitem> user:</para>
     95    <para>Now, as the <systemitem class="username">root</systemitem>
     96    user:</para>
    10597
    10698<screen role="root"><userinput>make install</userinput></screen>
     
    111103    <title>Command Explanations</title>
    112104
     105    <para><option>--with-gtk=2.0</option>: This option forces
     106    <application>Webkit</application> to compile against
     107    <application>Gtk+-2</application>, even if
     108    <application>Gtk+-3</application> is also installed. With
     109    <application>Gtk+-2</application>, everything
     110    <application>Webkit</application> installs is suffixed with 1.0. When it is
     111    compiled against <application>Gtk+-3</application> everything it installs
     112    is suffixed with 3.0. Both versions can be installed alongside one another
     113    with no namespace conflicts.</para>
     114
    113115    <para><option>--enable-introspection</option>: This option enables support
    114116    for gobject-introspection.</para>
    115 
    116     <para><option>--enable-3D-transforms</option>: This option enables support
    117     for 3D transforms.</para>
    118 
    119     <para><option>--enable-geolocation</option>: This option enables support for
    120     geolocation.</para>
    121 
    122     <para><option>--enable-mathml</option>: This option enables support for
    123     MathML.</para>
    124 
    125     <para><option>--enable-wml</option>: This option enables support for
    126     WML.</para>
    127 
    128     <para><option>--enable-web-sockets</option>: This option enables support for
    129     Web Sockets.</para>
    130117
    131118    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     
    143130
    144131      <seglistitem>
    145         <seg>jsc</seg>
    146         <seg>libwebkit-1.0.so</seg>
    147         <seg>/usr/{include/webkit-1.0/{JavaScriptCore,webkit},
    148         share/webkit-1.0/{images,resources,webinspector/Images}}</seg>
     132        <seg>jsc-1 or jsc-3 (depending on whether you installed the gtk+-2 or
     133        gtk+-3 version of webkit)</seg>
     134        <seg>libwebkit-1.0.so and libjavascriptcoregtk-1.0.so or
     135        libwebkit-3.0.so and libjavascriptcoregtk-3.0.so (depending on whether
     136        you installed the gtk+-2 or gtk+-3 version of webkit)</seg>
     137        <seg>/usr/include/webkit-1.0 and /usr/share/webkit-1.0 or
     138        /usr/include/webkit-3.0 and /usr/share/webkit-3.0 (depending on whether
     139        you installed the gtk+-2 or gtk+-3 version of webkit)</seg>
    149140      </seglistitem>
    150141    </segmentedlist>
     
    156147
    157148      <varlistentry id="jsc">
    158         <term><command>jsc</command></term>
     149        <term><command>jsc-1</command> or <command>jsc-3</command></term>
    159150        <listitem>
    160151          <para>is a command-line utility that allows you to run JavaScript
     
    167158
    168159      <varlistentry id="libwebkit-1.0">
    169         <term><filename class='libraryfile'>libwebkit-1.0.so</filename></term>
     160        <term><filename class="libraryfile">libwebkit-1.0.so</filename></term>
    170161        <listitem>
    171162          <para>contains the <application>WebKitGTK+</application> API
    172           functions.</para>
     163          functions for <application>gtk+-2</application>.</para>
    173164          <indexterm zone="webkitgtk libwebkit-1.0">
    174165            <primary sortas="c-libwebkit-1.0">libwebkit-1.0.so</primary>
     
    177168      </varlistentry>
    178169
     170      <varlistentry id="libwebkit-3.0">
     171        <term><filename class="libraryfile">libwebkit-3.0.so</filename></term>
     172        <listitem>
     173          <para>contains the <application>WebKitGTK+</application> API
     174          functions for <application>gtk+-3</application>.</para>
     175          <indexterm zone="webkitgtk libwebkit-3.0">
     176            <primary sortas="c-libwebkit-3.0">libwebkit-3.0.so</primary>
     177          </indexterm>
     178        </listitem>
     179      </varlistentry>
     180
     181      <varlistentry id="libjavascriptcoregtk-1.0">
     182        <term><filename
     183        class="libraryfile">libjavascriptcoregtk-1.0.so</filename></term>
     184        <listitem>
     185          <para>contains functions that are used by
     186          <command>jsc-1</command></para>
     187          <indexterm zone="webkitgtk libjavascriptcoregtk-1.0">
     188            <primary
     189            sortas="c-libjavascriptcoregtk-1.0">libjavascriptcoregtk-1.0.so</primary>
     190          </indexterm>
     191        </listitem>
     192      </varlistentry>
     193
     194      <varlistentry id="libjavascriptcoregtk-3.0">
     195        <term><filename
     196        class="libraryfile">libjavascriptcoregtk-3.0.so</filename></term>
     197        <listitem>
     198          <para>contains functions that are used by
     199          <command>jsc-3</command></para>
     200          <indexterm zone="webkitgtk libjavascriptcoregtk-3.0">
     201            <primary
     202            sortas="c-libjavascriptcoregtk-3.0">libjavascriptcoregtk-3.0.so</primary>
     203          </indexterm>
     204        </listitem>
     205      </varlistentry>
    179206    </variablelist>
    180207
Note: See TracChangeset for help on using the changeset viewer.