Ignore:
Timestamp:
09/15/2020 02:50:44 PM (12 months ago)
Author:
Pierre Labastie <pieere@…>
Branches:
10.1, 11.0, lazarus, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
374ffc0
Parents:
005af62
Message:

Fix building kf5 with qt-5.15.1

In the "purpose" package, there is a line, which is only compiled
if Qt5 version is less or equal to 5.15.0. The reason is that it
uses an obsolete function. The problem is that the replacement
function has not been implemented yet even in 5.15.1. This generates
an error:
‘class QLocalSocket’ has no member named ‘socketError’
So change the test so that the line is compiled if version is
less than 5.16.0 (using a sed)...

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@23714 af4574ff-66df-0310-9fd7-8a98e5e911e0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • kde/kf5/kf5-frameworks.xml

    r005af62 rdbde43b  
    357357        kwayland*) sed -i '/&lt;wayland-xdg-output-server-proto/a #include &lt;QHash&gt;' \
    358358          src/server/xdgoutput_interface.cpp ;;
     359        purpose*) sed -i 's/15,/16,/' \
     360          src/externalprocess/purposeprocess_main.cpp ;;
    359361      esac 
    360362
Note: See TracChangeset for help on using the changeset viewer.