Changeset e394bda


Ignore:
Timestamp:
08/08/2019 08:32:11 PM (2 years ago)
Author:
Ken Moffat <ken@…>
Branches:
10.0, 10.1, 11.0, 9.0, 9.1, ken/refactor-virt, lazarus, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
d3930a7
Parents:
134224d2
Message:

Fix biber tests for perl-5.30.0.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@21916 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • introduction/welcome/changelog.xml

    r134224d2 re394bda  
    4545      <para>August 8th, 2019</para>
    4646      <itemizedlist>
     47        <listitem>
     48          <para>[ken] - Patch biber-2.12 for failing tests from perl-5.30. Fixes
     49          <ulink url="&blfs-ticket-root;12368">#12368</ulink>.</para>
     50        </listitem>
    4751        <listitem revision="systemd">
    4852          <para>[renodr] - Fix systemd to allow networkd to function on systems
  • pst/typesetting/biber.xml

    r134224d2 re394bda  
    6464      </listitem>
    6565    </itemizedlist>
     66
    6667
    6768    <note>
     
    8889    </note>
    8990
    90     <bridgehead renderas="sect3">Required Additional Download</bridgehead>
     91    <bridgehead renderas="sect3">Required Additional Downloads</bridgehead>
    9192
    9293    <itemizedlist spacing="compact">
     
    102103      <listitem>
    103104        <para>Download size: &biblatex-size;</para>
     105      </listitem>
     106      <listitem>
     107        <para>
     108          Patch to make the tests work correctly with perl-5.30.0.
     109          <ulink url="&patch-root;/biber-&biber-version;-upstream_fixes-1.patch"/>
     110        </para>
    104111      </listitem>
    105112    </itemizedlist>
     
    166173      <application>perl-5.26.0</application>. If you are using an older version
    167174      of <command>perl</command> you may prefer to install v2.7 - for that see
    168       the BLFS-8.1 book.</para>
     175      the BLFS-8.1 book. If you are using perl 5.26 or 5.28, please omit the
     176      patch (or follow the BLFS-8.4 book for this package).</para>
    169177    </note>
    170178
     
    199207    commands:</para>
    200208
    201 <screen><userinput>perl ./Build.PL &amp;&amp;
     209<screen><userinput>patch -Np1 -i ../biber-&biber-version;-upstream_fixes-1.patch &amp;&amp;
     210perl ./Build.PL &amp;&amp;
    202211./Build</userinput></screen>
    203212
     
    214223  <sect2 role="commands">
    215224    <title>Command Explanations</title>
     225
     226    <para>
     227      <command>patch -Np1 -i ../biber-&biber-version;-upstream_fixes-1.patch</command>:
     228      Perl version 5.30.0 shipped a new version of core module Unicode::Collate which
     229      changed sortinit hashes. That broke many tests, the patch fixes them.
     230    </para>
    216231
    217232    <para>
Note: See TracChangeset for help on using the changeset viewer.