Changeset f914d6b


Ignore:
Timestamp:
06/09/2019 11:34:33 AM (2 years ago)
Author:
DJ Lucas <dj@…>
Branches:
elogind
Children:
22b8124
Parents:
fb7ec07
Message:

Add polkit patch for elogind and update to elogind-241.3.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/branches/BOOK-elogind@21664 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
5 edited

Legend:

Unmodified
Added
Removed
  • general.ent

    rfb7ec07 rf914d6b  
    11<!-- $LastChangedBy$ $Date$ -->
    22
    3 <!ENTITY day          "07">                   <!-- Always 2 digits -->
     3<!ENTITY day          "09">                   <!-- Always 2 digits -->
    44<!ENTITY month        "06">                   <!-- Always 2 digits -->
    55<!ENTITY year         "2019">
     
    77<!ENTITY copyholder   "The BLFS Development Team">
    88<!ENTITY version      "&year;-&month;-&day;">
    9 <!ENTITY releasedate  "June 7th, &year;">
     9<!ENTITY releasedate  "June 9th, &year;">
    1010<!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
    1111<!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
  • general/sysutils/elogind.xml

    rfb7ec07 rf914d6b  
    77  <!ENTITY elogind-download-http "https://github.com/elogind/elogind/archive/v&elogind-version;/elogind-&elogind-version;.tar.gz">
    88  <!ENTITY elogind-download-ftp  " ">
    9   <!ENTITY elogind-md5sum        "31da1e136d0c39b2af610a55c0c51354">
     9  <!ENTITY elogind-md5sum        "dbfebba271609fb5ea63073e2999466e">
    1010  <!ENTITY elogind-size          "1.3 MB">
    1111  <!ENTITY elogind-buildsize     "47 MB">
  • introduction/welcome/changelog.xml

    rfb7ec07 rf914d6b  
    2929    <title>Changelog Entries:</title>
    3030
     31<!-- Changelog template
     32    <listitem>
     33      <para>MMMM DD{nd,st,th}, YYYY</para>
     34      <itemizedlist>
     35        <listitem>
     36          <para>[name] - Changelog entry.</para>
     37        </listitem>
     38        <listitem>
     39          <para>[name] - Another changelog entry.</para>
     40        </listitem>
     41      </itemizedlist>
     42    </listitem>
     43    -->
     44
    3145    <listitem revision="sysv">
    32       <para>Ongoing elogind integration - add to current date when commited to
    33       trunk</para>
    34       <itemizedlist>
    35         <listitem revision="sysv">
    36           <para>[dj] - add with-libsystemd-login=no parameter to polkit
    37           instructions.</para>
    38         </listitem>
    39         <listitem revision="sysv">
    40           <para>[dj] - Remove SysV specific instructions for clutter, cogl,
    41           gtk+3, gvfs and xorg-server.</para>
    42         </listitem>
     46      <para>June 9th, 2019</para>
     47      <itemizedlist>
    4348        <listitem revision="sysv">
    4449          <para>[dj] - Install the gdm bootscript and change initdefault to
     
    4651        </listitem>
    4752        <listitem revision="sysv">
    48           <para>[dj] - Fix accountsservice build with elogind.</para>
     53          <para>[dj] - Bring back all Gnome Desktop packages.</para>
    4954        </listitem>
    5055        <listitem revision="sysv">
    51           <para>[dj] - Remove NetworkManager dependency on ConsoleKit.</para>
     56          <para>[dj] - Remove NetworkManager required dependency on ConsoleKit
     57          in favor of elogind.</para>
    5258        </listitem>
    5359        <listitem revision="sysv">
    54           <para>[dj] - Add --withsystemd{user,system}unitdir= switches to
    55           prevent installation of systemd unit files in several packages.</para>
    56         </listitem>
    57         <listitem revision="sysv">
    58           <para>[dj] - Add elogind-241.1. Adjust several packages to utilize
    59           elogind, and use systemd symlinks to provide libsystemd compatibility.          This will be incomplete until journald->syslog support is added in
    60           241.1. Will update temporary changelog at that time.</para>
    61         </listitem>
    62       </itemizedlist>
    63     </listitem>
    64 
    65 <!-- Changelog template
    66     <listitem>
    67       <para>MMMM DD{nd,st,th}, YYYY</para>
    68       <itemizedlist>
    69         <listitem>
    70           <para>[name] - Changelog entry.</para>
    71         </listitem>
    72         <listitem>
    73           <para>[name] - Another changelog entry.</para>
    74         </listitem>
    75       </itemizedlist>
    76     </listitem>
    77     -->
     60          <para>[dj] - Add elogind-241.3 and adjust several packages to
     61          utilize it.</para>
     62        </listitem>
     63      </itemizedlist>
     64    </listitem>
     65
    7866    <listitem>
    7967      <para>June 7th, 2019</para>
  • packages.ent

    rfb7ec07 rf914d6b  
    273273<!ENTITY cups-pk-helper-version       "0.2.6">
    274274<!ENTITY dbus-version                 "1.12.12">   <!-- Even minors only -->
    275 <!ENTITY elogind-version              "241.1">
     275<!ENTITY elogind-version              "241.3">
    276276<!ENTITY eudev-version                "1.7">
    277277<!ENTITY fcron-version                "3.2.1">
  • postlfs/security/polkit.xml

    rfb7ec07 rf914d6b  
    7272      </listitem>
    7373    </itemizedlist>
    74 <!--
    75     <bridgehead renderas="sect3">Additional Downloads</bridgehead>
    76     <itemizedlist spacing="compact">
    77       <listitem>
    78         <para>
    79           Required patch:
    80           <ulink url="&patch-root;/polkit-&polkit-version;-security_patch-3.patch"/>
     74
     75    <bridgehead renderas="sect3" revision="sysv">Additional Downloads</bridgehead>
     76    <itemizedlist spacing="compact" revision="sysv">
     77      <listitem>
     78        <para>
     79          Recommended patch:
     80          <ulink url="&patch-root;/polkit-&polkit-version;-fix_elogind_detection-1.patch"/>
    8181        </para>
    8282      </listitem>
    8383    </itemizedlist>
    84 -->
     84
    8585    <bridgehead renderas="sect3">Polkit Dependencies</bridgehead>
    8686
     
    123123    </para>
    124124
    125     <bridgehead renderas="sect4">Required Runtime Dependencies</bridgehead>
    126     <para role="required">
    127       <phrase revision="sysv"><xref role="runtime" linkend="elogind"/></phrase>
    128       <phrase revision="systemd"><xref role="runtime" linkend="systemd"/></phrase>
     125    <bridgehead renderas="sect4" revision="systemd">Required Runtime Dependencies</bridgehead>
     126    <para role="required" revision="systemd">
     127      <xref role="runtime" linkend="systemd"/>
    129128    </para>
    130129
     
    174173    </note>
    175174
     175    <para revision="sysv">
     176      Fix an issue introduced in recent <application>Polkit</application>
     177      realeases with elogind:
     178    </para>
     179
     180<screen revision="sysv"><userinput>patch -Np1 -i ../polkit-&polkit-version;-fix_elogind_detection-1.patch &amp;&amp;
     181autoreconf -fi</userinput></screen>
    176182    <para>
    177183      Install <application>Polkit</application> by running the following
     
    226232    <para revision="sysv">
    227233      <parameter>--enable-libsystemd-login=no</parameter>: This switch forces
    228       polkit to build with elogind support rather than systemd.
     234      polkit to build with elogind support (if available) rather than systemd.
    229235    </para>
    230236
Note: See TracChangeset for help on using the changeset viewer.