Changeset fb940713


Ignore:
Timestamp:
09/22/2018 09:46:42 PM (4 years ago)
Author:
Ken Moffat <ken@…>
Branches:
10.0, 10.1, 11.0, 11.1, 11.2, 8.4, 9.0, 9.1, bdubbs/svn, elogind, lazarus, plabs/python-mods, qt5new, trunk, upgradedb, xry111/intltool, xry111/soup3, xry111/test-20220226
Children:
4291c1e
Parents:
8dc8ced
Message:

Rustc - during install, tell it to use pkgconfig to find libssh2.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@20523 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
2 edited

Legend:

Unmodified
Added
Removed
  • general/prog/rust.xml

    r8dc8ced rfb940713  
    260260    </para>
    261261
    262 <screen><userinput>DESTDIR=${PWD}/install ./x.py install</userinput></screen>
     262<screen><userinput>export LIBSSH2_SYS_USE_PKG_CONFIG=1 &amp;&amp;
     263DESTDIR=${PWD}/install ./x.py install &amp;&amp;
     264unset LIBSSH2_SYS_USE_PKG_CONFIG</userinput></screen>
    263265
    264266    <para>
     
    325327      <command>--no-fail-fast</command>: this switch ensures that the testsuite
    326328      will not stop at the first error.
     329    </para>
     330
     331    <para>
     332      <command>export LIBSSH2_SYS_USE_PKG_CONFIG=1</command>: On some systems,
     333      cairo fails to link during the install because it cannot find libssh2.
     334      This seems to fix it, but again the reason why the problem occurs is not
     335      understood.
    327336    </para>
    328337
  • introduction/welcome/changelog.xml

    r8dc8ced rfb940713  
    4646      <itemizedlist>
    4747        <listitem>
     48          <para>[ken] - Tell rustc to use pkgconfig to find libssh2. Fixes
     49          <ulink url="&blfs-ticket-root;11176">#11176</ulink>.</para>
     50        </listitem>
     51        <listitem>
    4852          <para>[ken] - Upgrade to qtwebengine-5.11.2 (security fixes) and
    4953          qt-5.11.2. Fixes
Note: See TracChangeset for help on using the changeset viewer.