Opened 3 years ago

Closed 3 years ago

#10550 closed enhancement (fixed)

cmake-3.10.3

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Bruce Dubbs, 3 years ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 3 years ago

3.10.3

CMake 3.10.1 added a TIMEOUT option to gtest_discover_tests() from the GoogleTest module. That keyword clashed with the TIMEOUT test property, which is one of the common properties that would be set with the command’s PROPERTIES keyword, usually leading to legal but unintended behavior. The keyword was changed to DISCOVERY_TIMEOUT in CMake 3.10.3 to address this problem. The ambiguous behavior of the gtest_discover_tests() command’s TIMEOUT keyword in 3.10.1 and 3.10.2 has not been preserved.

comment:3 by Bruce Dubbs, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 20001.

Note: See TracTickets for help on using tickets.