Opened 3 years ago

Closed 3 years ago

#10678 closed enhancement (fixed)

gpgme 1.11.1

Reported by: Pierre Labastie Owned by: Bruce Dubbs
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

new minor version. According to upstream mailing list, there is a bug in this version, which should be fixed in a version coming tomorrow: so wait and see...

Change History (6)

comment:2 by Bruce Dubbs, 3 years ago

Summary: gpgme 1.11.0gpgme 1.11.0 (wait for next version)

comment:3 by Bruce Dubbs, 3 years ago

Summary: gpgme 1.11.0 (wait for next version)gpgme 1.11.1

Now at version 1.11.1.

comment:4 by Bruce Dubbs, 3 years ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:5 by Bruce Dubbs, 3 years ago

Noteworthy changes in version 1.11.1 (2018-04-20)

  • Fixed build problems in the 1.11.0 release.
  • Added C++ interfaces which were planned for 1.11.0.
  • Interface changes relative to the 1.10.0 release:
    • cpp: Key::origin NEW.
    • cpp: Key::lastUpdate NEW.
    • cpp: UserID::origin NEW.
    • cpp: UserID::lastUpdate NEW.

Noteworthy changes in version 1.11.0 (2018-04-18)

  • New encryption API to support direct key specification including hidden recipients option and taking keys from a file. This also allows to enforce the use of a subkey.
  • New encryption flag for the new API to enforce the use of plain mail addresses
  • The import API can now tell whether v3 keys are skipped. These old and basically broken keys are not anymore supported by GnuPG 2.1.
  • The decrypt and verify API will now return the MIME flag as specified by RFC-4880bis.
  • The offline mode now has an effect on gpg by disabling all network access.
  • A failed OpenPGP verification how returns the fingerprint of the intended key if a recent gpg version was used for signature creation.
  • New tool gpgme-json as native messaging server for web browsers. As of now public key encryption and decryption is supported. Requires Libgpg-error 1.29.
  • New context flag "request-origin" which has an effect when used with GnuPG 2.2.6 or later.
  • New context flag "no-symkey-cache" which has an effect when used with GnuPG 2.2.7 or later.
  • New convenience constant GPGME_KEYLIST_MODE_LOCATE.
  • Improved the Python documentation.
  • Fixed a potential regression with GnuPG 2.2.6 or later.
  • Fixed a crash in the Python bindings on 32 bit platforms.
  • Various minor fixes.

comment:6 by Bruce Dubbs, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 20101.

Note: See TracTickets for help on using tickets.