Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10876 closed enhancement (fixed)

NetworkManager-1.12.2

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (5)

comment:1 by Douglas R. Reno, 3 years ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

comment:2 by Douglas R. Reno, 3 years ago

Summary: NetworkManager-1.10.10NetworkManager-1.12.2

New version is 1.12.2

===============================================
NetworkManager-1.10.10
Overview of changes since NetworkManager-1.10.8
===============================================

This is a new stable release of NetworkManager.  Notable changes include:

* Fix crash during reapply of connection settings
* Minor bugfixes
=============================================
NetworkManager-1.12.2
Overview of changes since NetworkManager-1.12
=============================================

This is a new stable release of NetworkManager.  Notable changes include:

* Fix missing symbols in libnm ABI for settings.
* Fix a regression that disallowed activations of VPN connections with a
  device specified.
* Robustness fixes to connectivity checking.

=============================================
NetworkManager-1.12
Overview of changes since NetworkManager-1.10
=============================================

This is a new stable release of NetworkManager.  Notable changes include:

* Improved support for configuration checkpoint, including support in libnm.
* Added capability to set IP Tunnel configuration flags.
* The systemd-resolved DNS plugins now supports MDNS.
* systemd-resolved and dnsmasq DNS plugins now honor the DNS priority setting.
* Wi-Fi devices now support FILS for speedier roaming support.
* Drop dependency on libnl3 library.
* Add support for "onlink" routes.
* More robust connectivity checking.
* Dropped the obsolete "ifnet" settings plugin,
* Try harder to generate reasonable human-readable names for devices even if
  the hwdb contains garbage.
* Add an "overview" option to hide default values in nmcli, resulting in more
  concise output.
* Reworked the inner workings of D-Bus interface for better resource efficiency.
* Add support for configuring nmcli coloring via terminal-colors.d(5).
* Added experimental support for Meson build system,
* Added initial IWD Wi-Fi daemon support.
* A non-hexadecimal DHCPv4 client-id is now properly passed to
  dhclient with the first byte (type) set to zero, as stated in the
  documentation. This represents a change in behavior since previous
  versions where the first character of the string was used as
  type. The internal client is not affected by the change.
* DNS setting rc-manager=file now always follows dangling symlinks
  instead of replacing /etc/resolv.conf with a plain file.
* Added wake_on_wlan connection setting to configure
  wake-on-wireless-lan (WoWLAN).
* The libnm-glib library, deprecated in favor of libnm since NetworkManager 1.0,
  is now not built by default. While it can still be enabled, the distributions
  should have a good plan for removing it if they need to keep shipping it at
  this point.
* nmcli now scans for Wi-Fi networks before displaying them, if the last scan
  was too long ago.
* Added the ipv6.dhcp-duid property to allow configuring the DHCPv6 DUID
* Extended ipv6.dhcp-client-id property to support DHCP client identifers
  depending on the MAC address and the stable ID.
* Set NM_DISPATCHER_ACTION environment variable in dispatcher scripts.

The following features were backported to 1.10.x releases from 1.10.0 to
1.10.10 are also present in NetworkManager-1.12:

* Fix crash during reapply of connection settings
* Fix connectivity timeout handling (bgo #794464),
* Retry activating devices when the parent becomes managed (rh #1553595),
* Correctly set the rp_filter value (rh #1565529).
* A fix to ensure teamd is respawned after daemon restart (rh #1551958).
* Better handle DHCP expiry (bgo #783391).
* Fix configuration of IPv6 over master interfaces (rh #1575944).
* ovs: fix compilation issue of OVS plugin and various fixes.
* team: add support for team runner "random".
* core: cleanup activation of device (rh #1537160).
* dhcp: retry indefinitely to renew the lease (rh #1503587).
* core: fix blocking autoconnect for no-secrets (rh #794014).
* libnm: mark async results as cancelled (bgo #794088).
* Load jansson at runtime. This solves a clash with json-glib that caused
    a gnome-control-center crash, but also gets rid of a hard dependency.
* Correct nmcli exit values after receiving a signal.
* Fix libnm secret agent asynchronous initialization.
* Add a default route for a modem even if it didn't sent a gateway.
* Improve communication of DAD failures.
* Remember device default metrics across daemon restarts.
* Various bug fixes including possible crashes.
* Added support for 'onlink' IPv4 routes attribute.
* Wait longer for the carrier to come up after a MTU change.
* Implemented abstraction for team connections that exposes team
    configuration items as distinct properties.
* Added basic support for tc queueing disciplines and filters.
* Introduced an Update2() D-Bus method to update connection settings
  with more flexibility.
* Many bug fixes and improvements.

comment:3 by Douglas R. Reno, 3 years ago

I can see this release causing problems. Of course, it'll have the validation of GNOME through Caribou (that's when my first commit will be, containing at least 8 updates), but something seems fishy. The only library (including headers) available now is libnm.so, which means libnm-glib, libnm-vpn, and libnm-util are removed. I can see this directly affecting the API of other applications. There are also more checks for specific systemd versions in configure.

Bruce (or anyone that uses sysv) - please let me know if this doesn't work on the sysv end of things.

comment:4 by Douglas R. Reno, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r20236

comment:5 by Douglas R. Reno, 3 years ago

Fixed at r20326 (TYPO)

Note: See TracTickets for help on using tickets.