Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#11932 closed enhancement (fixed)

Firefox-66.0.5 (was 66.0.3, 66.0.4)

Reported by: Douglas R. Reno Owned by: Douglas R. Reno
Priority: normal Milestone: 9.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (18)

comment:1 by Douglas R. Reno, 2 years ago

To whoever updates this, I can confirm that it builds fine with the current instructions in the book.

comment:2 by ken@…, 2 years ago

I am not aware of anything in this version which is likely to be important to us. My practice for point releases is to look at the diff, check it builds and runs, and then update the tarball size and md5sum. For the minutiae of SBU measurements, I usually wait for a new release (I see big variations across different machines).

I haven't run this, so I'm not taking it, but the diff shows nothing interesting (in terms of building on linux) so as Doug noted, it should just drop in. Might be important for people whose search engine is baidu (changed xml for the plugin), and updates to the xml blocklist.

comment:3 by Douglas R. Reno, 2 years ago

There is a bug introduced in the extensions/addons framework that will be fixed in 66.0.4. This is due to an expired certificate, requiring all addons to be resigned.

This breaks 3/4s of the websites that I need to get to. I'd like to take the update to 66.0.4 when it becomes available, barring any objections. This is a priority problem for me.

comment:4 by ken@…, 2 years ago

Summary: Firefox-66.0.3Firefox-66.0.4 (was 66.0.3)

It's there now, I suppose it's the changes in services/settings/dumps/blocklists/addons.json which affect this (I just diffed to 66.0.3, other minor one-liners and additions to browser/app/blocklist.xml which always gets extended.

So, the patch for system graphite2 and harfbuzz should just roll forward.

I'll note that I haven't experienced the problem. One comment suggested that restarting firefox might trigger it, but after restarting 66.0.2 on my laptop today (a kernel problem, it lost the wifi) both ublock-origin and ghostery were working. On this recent system where I installed 66.0.2 on Friday night and have not restarted, Privacy Badger and Adblock Plus seem fine.

Please feel free to take it - if I was doing it, I'd only alter the version, tarball size, and md5sum.

comment:5 by Douglas R. Reno, 2 years ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

I got this once I'm home from PT tomorrow. I'll work overnight tomorrow to get it done if I have to.

One of the addons I have to use for college is impacted (our SSO extension), so I've had to go on-campus to deal with it the past two days.

comment:6 by Bruce Dubbs, 2 years ago

Builds and fine for me using previous script/mozconfig/patch. I don't have any addons to test that part of it.

I use -j10 so the time is not good for the book.

1409.6 Elapsed Time -  firefox-66.0.4.source
SBU=14.995
276380 /usr/src/firefox/firefox-66.0.4.source.tar.xz SIZE (269.902 MB)
9508548 kilobytes BUILD SIZE (9285.691 MB)
md5sum : 4706b33fa62ca14a675b38fba8be3467  /usr/src/firefox/firefox-66.0.4.source.tar.xz

comment:7 by Tim Tassonis, 2 years ago

I also was able to just apply the the 66.0.1 graphite patch and build without problems.

Also had issues with add-ons (uBlock Origin and VideoDownloader) since Sunday, which are gone now with 66.0.4

comment:8 by Douglas R. Reno, 2 years ago

We seem to have Firefox 66.0.5 coming out ASAP for more issues related to this. I'm going to update to Firefox 66.0.4 irregardless, and if 66.0.5 turns out to be important enough, I'll update it again. Seeing as 66.0.4 fixes the main problem, I'm not that concerned, but the existing fix seems to only work on 50% of installations, and is related to not being able to add the certificate to the user's NSSDB.

comment:9 by Douglas R. Reno, 2 years ago

https://bugzilla.mozilla.org/show_bug.cgi?id=1549249

As reference for the above statement. There's already a -rc1 tagged, but seeing as the last version has three -rcS, I'm going to update it anyway.

comment:10 by Douglas R. Reno, 2 years ago

Summary: Firefox-66.0.4 (was 66.0.3)Firefox-66.0.5 (was 66.0.3, 66.0.4)

Time to restart the process!

Now 66.0.5, with further fixes, a day later than the original release.

Further improvements to re-enable web extensions which had been disabled for users with a master password set (Bug 1549249). More support information

comment:11 by Tim Tassonis, 2 years ago

Built it last night, with the usual patch, these are my stats:

SRCSIZE: 270M

SRCHASH: a3d00fb4e950558135f08a5155745d4e

BLDSIZE: 9.1G

BINSIZE: 149.48 M

runs fine, afaikt

Last edited 2 years ago by Tim Tassonis (previous) (diff)

comment:12 by Douglas R. Reno, 2 years ago

I noticed a small oddity while working on building Firefox. For some reason, audioipc_client's rust crate will fail to compile, but if I run the build again, it will build and continue without hassle.

For this reason, I have the following in my script:

./mach build --verbose
# The above build will fail due to a problem with audioipc_client
./mach build --verbose &&

After this, it takes about half an hour to complete. Not too bad at -j4.

After this lands in SVN, I'm going to update my laptop to Firefox 66.0.5 and update my 8.4 system as well. Assuming all goes well with the standard 8.4 system, I'll modify the errata and do a post to the lists regarding the Addons issue.

NOTE: For anyone who uses Firefox-66.0.3 and earlier, the "Study" that Mozilla sent out via "normandy" (their automated hotfix framework which somehow is enabled on our builds!), the certificate bundle/hotfix that was sent out as "Study" on Saturday/Sunday will expire soon, necessitating an upgrade to Firefox-66.0.5 or higher if you want to use your addons. That's the primary reason why I will write a note to the lists.

comment:13 by Douglas R. Reno, 2 years ago

For future reference, I had to set DESTDIR separately for mach to use it, similar to how we have to do things for Meson.

comment:14 by Douglas R. Reno, 2 years ago

Here's more information on this: https://hacks.mozilla.org/2019/05/technical-details-on-the-recent-firefox-add-on-outage/

We're also going to disable telemetry with this, because installing applications or features without a user's consent is not something that we agree with. This has to be done by UNSETting a variable in the mozconfig file.

comment:15 by Douglas R. Reno, 2 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r21574

comment:16 by Douglas R. Reno, 2 years ago

I will write a detailed errata entry and a note to the lists either tonight or tomorrow.

comment:17 by ken@…, 2 years ago

Many thanks for your hard work on this (and to Bruce for initial analysis 'about:studies'). I now understand why my add-ons continued to work.

comment:18 by Bruce Dubbs, 2 years ago

Milestone: 8.59.0

Milestone renamed

Note: See TracTickets for help on using tickets.