Opened 19 months ago

Closed 18 months ago

Last modified 14 months ago

#13230 closed enhancement (fixed)

librsvg-2.48.0

Reported by: Douglas R. Reno Owned by: ken@…
Priority: normal Milestone: 10.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version

NOTE: This needs a newer version of rustc (minimum of 1.39)

Change History (7)

comment:1 by ken@…, 19 months ago

With rustc-1.39.0, both firefox-68.6.0 and thunderbird-68.5.0 build ok. But seamonkey-2.53.1 does not:

/usr/bin/g++ -o SandboxBroker.o -c -I/scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/dist/stl_wrappers -I/scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/dist/system_wrappers -include /scratch/ken/seamonkey-2.53.1/mozilla/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/scratch/ken/seamonkey-2.53.1/mozilla/security/sandbox/linux/broker -I/scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/security/sandbox/linux/broker -I/scratch/ken/seamonkey-2.53.1/mozilla/security/sandbox/linux -I/scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/ipc/ipdl/_ipdlheaders -I/scratch/ken/seamonkey-2.53.1/mozilla/ipc/chromium/src -I/scratch/ken/seamonkey-2.53.1/mozilla/ipc/glue -I/scratch/ken/seamonkey-2.53.1/mozilla/security/sandbox/chromium -I/scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/dist/include -I/usr/include/nspr -I/usr/include/nss -I/scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/dist/include/nss -I/usr/include/pixman-1 -fPIC -DMOZILLA_CLIENT -include /scratch/ken/seamonkey-2.53.1/obj-x86_64-pc-linux-gnu/mozilla-config.h -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wc++1z-compat -Wimplicit-fallthrough -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=free-nonheap-object -Wformat -Wformat-overflow=2 -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -O2 -fomit-frame-pointer  -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -MD -MP -MF .deps/SandboxBroker.o.pp   /scratch/ken/seamonkey-2.53.1/mozilla/security/sandbox/linux/broker/SandboxBroker.cpp
error: use of deprecated item 'try': use the `?` operator instead
   --> /scratch/ken/seamonkey-2.53.1/mozilla/xpcom/rust/nsstring/src/lib.rs:138:5
    |
138 | /     bitflags! {
139 | |         // While this has the same layout as u16, it cannot be passed
140 | |         // over FFI safely as a u16.
141 | |         #[repr(C)]
...   |
149 | |         }
150 | |     }
    | |_____^

comment:2 by ken@…, 19 months ago

An additional point, when we get to a place where we can think about building this version, is that the release notes suggest some existing svg files might need to be edited. From the Release announcement:

- Librsvg's XML parser now supports namespaces (xmlns), and is
stricter than before about it. Files may fail to parse if there are
attributes or elements with namespace prefixes (e.g. foo:bar instead
of plain bar), but without a corresponding namespace declaration
(e.g. xmlns:foo="http://example.com/foo").

This may happen especially with incorrectly-written SVGs that use
xlink:href or xi:include attributes without the corresponding
namespace declarations. If you run into this, just add the
following to your toplevel SVG element:

<svg xmlns="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:xi="http://www.w3.org/2001/XInclude">
^^^^^^^^^ these ones

comment:3 by ken@…, 19 months ago

Owner: changed from blfs-book to ken@…
Status: newassigned

I've been testing this (i.e. opening existing files) in my normal build. I _think_ that firefox picks up librsvg via gtk, and ImageMagick7 ('display') definitely picks up librsvg.

Tests with both of those were ok.

With gimp (librsvg probably pulled in via babl and gegl) tests mostly ok, but one file from the firefox source which I tried, firefox-68.5.0-c1/third_party/python/Click/artwork/logo.svg, reported 'unsupported file format' (other files I tried worked ok.

That file displays ok in 'display', firefox and indeed in inkview (it was created in inkscape).

I also used asymptote to create an svg via dvisvgm, again that opened fine in 'display'.

To me, this looks as if only seamonkey is stopping us from updating to rustc-1.39.0 and then using this version of librsvg.

However, I have not yet managed to build libreoffice (and no useful error messages from that), so I suppose I need to get that built and working before confirming this version of librsvg is ok.

comment:4 by ken@…, 19 months ago

For seamonkey, both fedora and slackware (or maybe it was slackbuilds) are using a set of patches, and I got lucky via a link at AUR discussing how to update to 2.53.1 which posted links to patches.

The upstream bug (still at mozilla!) is https://bugzilla.mozilla.org/show_bug.cgi?id=1617782

Will create a ticket for seamonkey.

comment:5 by ken@…, 18 months ago

Resolution: fixed
Status: assignedclosed

comment:6 by Bruce Dubbs, 14 months ago

Milestone: 9.210,0

Milestone renamed

comment:7 by Bruce Dubbs, 14 months ago

Milestone: 10,010.0

Milestone renamed

Note: See TracTickets for help on using tickets.