Opened 18 months ago

Closed 18 months ago

Last modified 14 months ago

#13268 closed enhancement (fixed)

dvisvgm-2.9.1

Reported by: Bruce Dubbs Owned by: ken@…
Priority: normal Milestone: 10.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description (last modified by ken@…)

New minor version (2.9). Now a point release.

Change History (6)

comment:1 by ken@…, 18 months ago

13 March 2020: dvisvgm 2.9 has been released

The main new feature of this release is the conversion of bitmap images present in PostScript and PDF data. All bitmaps are embedded into the generated SVG files encoded as Base64 strings. The default format used for this is JPEG because it allows for high compression rates and therefore moderate impact on the SVG file size. If you prefer a lossless format, you can switch to one of the supported PNG variants by using the new command-line option --bitmap-format. Further information about the available formats and the usage of this option can be found on the manual page.

Summary of additions and fixes:

Added the processing of PostScript operators image and colorimage which now allows dvisvgm to embed bitmap images present in PS/PDF files into the generated SVG files.

Added command-line option --bitmap-format to set the format used to embed bitmaps present in EPS/PDF files.

Added a fallback method to retrieve the resolution of GF files if stdout of the Metafont subprocess can’t be read through a pipe for some reason (issue #129).

Fixed the broken conversion of PostScript tiling patterns.

Fixed the functionality of PostScript operators xshow, yshow, and xyshow for multibyte characters.

Fixed a PostScript error that was triggered by yet unsupported shading types < 4.

Prevent negative height and width attributes created by optimizer module simplify-transform.

Fixed a potential segfault caused by deep recursion in huge SVG trees.

Look for Ghostscript library name libgs.dylib.N additionally to libgs.N.dylib (Mac only).

Ensure that make install installs the bundled manual page if it can’t be rebuilt due to missing build tools.

Updated the bundled xxHash library to version 0.7.3.

comment:2 by ken@…, 18 months ago

Description: modified (diff)
Owner: changed from blfs-book to ken@…
Status: newassigned
Summary: dvisvgm-2.9dvisvgm-2.9,1

For 2.9.1:

Added macro {?(expr)} to enable the evaluation of math expressions in raw SVG fragments (issue #130).

Multiplication operator * preceding an opening parentheses can now be omitted in math expressions.

Fixed the evaluation of transformation command scale(c) which is now correctly treated as scale(c,c) (issue #131).

Minor layout optimizations of the PDF version of the manual page.

comment:3 by ken@…, 18 months ago

Summary: dvisvgm-2.9,1dvisvgm-2.9.1

comment:4 by ken@…, 18 months ago

Resolution: fixed
Status: assignedclosed

comment:5 by Bruce Dubbs, 14 months ago

Milestone: 9.210,0

Milestone renamed

comment:6 by Bruce Dubbs, 14 months ago

Milestone: 10,010.0

Milestone renamed

Note: See TracTickets for help on using tickets.