#13837 closed enhancement (fixed)

sudo-1.9.2

Reported by: Bruce Dubbs Owned by: thomas
Priority: normal Milestone: 10.0
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by thomas, 14 months ago

Owner: changed from blfs-book to thomas
Status: newassigned

comment:2 by thomas, 14 months ago

Major changes between version 1.9.2 and 1.9.1:

Fixed package builds on RedHat Enterprise Linux 8.

The configure script now uses pkg-config to find the openssl cflags and libs where possible.

The contents of the log.json I/O log file is now documented in the sudoers manual.

The sudoers plugin now properly exports the sudoers_audit symbol on systems where the compiler lacks symbol visibility controls. This caused a regression in 1.9.1 where a successful sudo command was not logged due to the missing audit plugin. Bug #931.

Fixed a regression introduced in 1.9.1 that can result in crash when there is a syntax error in the sudoers file. Bug #934.

comment:3 by thomas, 14 months ago

Resolution: fixed
Status: assignedclosed

cvtsudoers: 35/35 tests passed; 0/35 tests failed

Fixed in r23414

Note: See TracTickets for help on using tickets.