﻿id	summary	reporter	owner	description	type	status	priority	milestone	component	version	severity	resolution	keywords	cc
1809	blfs bootscript error in netfs, 'IGTERM unknown signal'	ken@…	blfs-book@…	" When shutting down, the netfs bootscript provokes this error message, but since we don't really expect SIGTERM to do a lot, the script carries on successfully.  Looking at this, there seem to be several issues here:

(i) in the grep to find NETMOUNTS, '|\' for '\|'

(ii) the cause of the error message, fuser -m -SIGTERM $NETMOUNTS : this doesn't report an error if I change it to --SIGTERM so probably the psutils manpage is wrong, or perhaps it's an error in the fuser code.

(iii) the sed to format NETMOUNTS is probably not doing what is intended - I have nfs mounts on /sources and /mnt/av, NETMOUNTS contains
/sources
/mnt/av

 I've fixed the first two, patch at http://www.linuxfromscratch.org/~ken/misc/bootscripts-netfs-fix-patch
 but the third item eludes me (I tried using a do loop while I was trying to work out what was wrong with the second point, but I'm not convinced that the later reference to $? will be correct after a loop).  So, all I can say for certain is that my patch removes the error message.

/me pines for bug-tracking software that makes it easy to attach patches."	defect	closed	normal	6.2.0	Bootscripts	SVN	low	fixed		
