Opened 10 years ago

Closed 9 years ago

#4500 closed enhancement (fixed)

Add new package Mozilla JS-24.2.0

Reported by: thomas Owned by: Fernando de Oliveira
Priority: normal Milestone: 7.6
Component: BOOK Version: SVN
Severity: normal Keywords:


Is that a successor of the currently used mozjs17.0.0 ?

Change History (20)

comment:1 by Fernando de Oliveira, 10 years ago

Yes, it seems to be a successor. But it is clearly stated that there are API differences. I am studying that since today.

comment:2 by Fernando de Oliveira, 10 years ago

They have no common file or directory. Installed it, then DEST installed the two packages in BLFS linked to mozjs and their libraries are still linked to version 17.0.0, if linked at all to mozjs (thanks again for scanelf, Igor).

Have the tendency to say that having the two versions installed is not a problem for the system, but newer is useless for BLFS, at this stage.

Will wait for more opinions, but I am thinking of closing this ticket as invalid.

comment:3 by thomas, 10 years ago

Do the packages fail to compile/link when only 24.2.0 is on the system? Btw, I know polkit is using JS, which is the other one?

comment:4 by Fernando de Oliveira, 10 years ago

Packages: polkit and Gjs.

Today, tested only polkit. Configured with 24.2.0, "make" fails.

comment:5 by Fernando de Oliveira, 10 years ago

Resolution: invalid
Status: newclosed

comment:6 by Armin K, 10 years ago

Ticket is perfectly valid in the same way as BlueZ-5.x and OpenJPEG-2.0.0

You just have to wait for software to get ported to use it.

According to gjs git log, it has been alredy ported to use MozJS-24.0.0 and it will be default in next Gjs stable release (1.40.x or whatever)

As for Polkit, no sign of MozJS-24.0.0 support yet but I guess it will be available with next GNOME release.

comment:7 by Fernando de Oliveira, 10 years ago

Resolution: invalid
Status: closedreopened

comment:8 by Fernando de Oliveira, 10 years ago

Thanks finally for some comment, Armin.

comment:9 by Fernando de Oliveira, 10 years ago

Priority: normallow

comment:10 by bdubbs@…, 10 years ago

Milestone: currentfuture

comment:11 by Fernando de Oliveira, 10 years ago

Milestone: future7.6
Priority: lownormal

Now, we have a problem. Polkit is still the same, but gjs-1.40.0 needs mozjs-24.2.0.

Is this a case when two versions of a package need to coexist in the book?

comment:12 by Fernando de Oliveira, 10 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: reopenednew
Summary: Mozilla JS-24.2.0Add new package Mozilla JS-24.2.0

Adding as a new package JS-24.2.0 (/trunk/BOOK/general/genlib/js2.xml) seems to be the only solution. Polkit-gnome is still at 0.105, as is polkit, and this needs js-17.0.0.

comment:13 by Wayne Blaszczyk, 10 years ago

Word of warning, I cannot build libpeas with js24 installed. Both js17 and js24 are installed. I've searched far and wide for a solution to no avail. This is the only reference I could find

To save you a bit of time if you haven't started already. With js24 I needed to set 'SHELL=/bin/bash' (in chroot) and the following at the end:

find /usr/include/mozjs-24/            \
     /usr/lib/libmozjs-24.a         \
     /usr/lib/pkgconfig/mozjs-24.pc \
     -type f -exec chmod -v 644 {} \;

comment:14 by Fernando de Oliveira, 10 years ago

Thank you very much, Wayne.

It is really a problem. We cannot update GNOME without js24. So, I think that all agree with that. But we cannot update with it, because libpeas is necessary.

I cannot use the dev machine at the moment, so later will see that new problem (and probably ne ticket!).

Will search a bit more.

comment:15 by Wayne Blaszczyk, 10 years ago

Apologies for hijacking the ticket but it looks like libpeas 1.10.0 has just been released.

Overview of Changes in libpeas 1.10.0 ====================================

  • Remove support for gjs-based Javascript plugins
  • Misc bugfixes

Will let you know how I go.

comment:16 by Wayne Blaszczyk, 10 years ago

Raised Ticket 4882. Confirmed that libpeas 1.10.0 fixes issue with JS24.

comment:17 by Fernando de Oliveira, 10 years ago


comment:18 by Fernando de Oliveira, 10 years ago

Before I forget:

many xml variables are named js2 or JS2 or libmozjs2, as well as the xml file: js2.xml

tried to keep in the readable text JS, instead of JS2

svn copied from js.xml (almost un update), so I believe setting props is not necessary, please tell me if it is

Please, tell me if I need to modify anything.

I would like to thank to all that contributed to this ticket resolution:

Thomas, Armin and Wayne.

Sorry, Thomas for having closed by mistake, thankfully corrected by Armin.

Wayne, particularly has done a big part of the page. I forgot to add two things: Remember the user that it can be installed alongside version 17.0.0, and 'SHELL=/bin/bash' (in chroot)'.

comment:19 by Fernando de Oliveira, 10 years ago

I think it is fixed at r12921.

Will close tomorrow, if there are no comments/suggestions/fixes.

comment:20 by Fernando de Oliveira, 9 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.