Opened 6 years ago

Closed 6 years ago

#9045 closed enhancement (fixed)

Add libidn2 to the book

Reported by: Richard Melville Owned by: Douglas R. Reno
Priority: normal Milestone: 8.2
Component: BOOK Version: SVN
Severity: normal Keywords: Suggestion

Description (last modified by Armin K)

Download (HTTP): Download (FTP) :

Build - this worked for me:-

./configure --prefix=/usr --disable-static --docdir=/usr/share/doc/libidn2-2.0.3

Change History (16)

comment:1 by bdubbs@…, 6 years ago

I'm not sure what this adds. It can optionally be used in gnutls, but libidn (not libidn2) is used in the following:

general/sysutils/systemd.xml:     <xref linkend="libidn"/>,
networking/netprogs/wget.xml:     <xref linkend="libidn"/>,
networking/mailnews/mutt.xml:     <xref linkend="libidn"/>,
networking/netutils/whois.xml:    <xref linkend="libidn"/>
postlfs/security/gnutls.xml:      <xref linkend="libidn"/>,
pst/printing/gs.xml:              <xref linkend="libidn"/>,
server/mail/exim.xml:             <xref linkend="libidn"/>,
xsoft/other/pidgin.xml:           <xref linkend="libidn"/> 

What does libidn2 offer that we don't have?

comment:2 by Richard Melville, 6 years ago

From the libidn web page:-

"Please be aware that GNU libidn2 is the successor of GNU libidn. It comes with IDNA 2008 and TR46 implementation and also provides a compatibility layer for GNU libidn."

In addition, GnuTLS will build with libidn2 support but NOT with libidn support.

One caveat: For some reason my build of libidn2 did not provide a .pc file. I haven't had the opportunity yet to find out why that was the case.

Finally, we have pages for both NASM and Yasm which, IMO, is a similar situation.

comment:3 by bdubbs@…, 6 years ago

Have you tried to build all the packages in my previous comment? If we can get by with only one package, either the old or the new, then that's what I want to do. Right now we don't *need* libidn2.

We do have several places where we still have multiple versions in the book. ImageMagick for one. We had qt4 and qt5 before, but removed qt4 as soon as we could. I'd like to put back amarok, but it is still qt4 only. We also used to have two versions of webkitgtk, but are now down to one.

comment:4 by Richard Melville, 6 years ago

Packages in previous comment that can be built with libidn2 support:-

Systemd - not sure
Wget    - yes (from 1.19.1)
Mutt    - no
Whois   - yes
GnuTLS  - yes
Gs      - no
Exim    - yes
Pidgin  - not sure but Jabber supports libidn2
Last edited 6 years ago by bdubbs@… (previous) (diff)

comment:5 by Richard Melville, 6 years ago

Wget2 is an updated version of wget:

comment:6 by bdubbs@…, 6 years ago

Milestone: 8.1hold
Summary: Suggesting a new page entry in the book for libidn2Add libidn2 to the book (wait for systemd to suppor it)

Changing title and moving the ticket to hold until at least systemd supports it.

For mutt, gs, and pidgin, the dependencies are all optional and we can make the current libidn an external dependency. I do not want to have both libidn and libidn2 in the book at the same time.

comment:7 by Armin K, 6 years ago

So it begins. Oh yes, curl is missing from the list above. It, too, doesn't support old libidn anymore, only libidn2.

comment:8 by bdubbs@…, 6 years ago

Milestone: holdy-hold

Milestone renamed

comment:9 by Armin K, 6 years ago

Milestone: y-hold8.1

systemd-234 is out, with libidn2 support (which is marked experimental).

comment:11 by DJ Lucas, 6 years ago

This is fixed in libidn-2.0.3, bug is here: and fix is here:

Although systemd-resolvd should work with 2.0.3, they wrapped it in a test case here to make sure conversion to and from matchl (and if not, punt): This shouldn't be necessary, and shouldn't affect lookups if there are no extended chars, but I haven't tested libidn2 yet.

comment:12 by Armin K, 6 years ago

libidn2-2.0.3 is already out.

comment:13 by Douglas R. Reno, 6 years ago

Owner: changed from blfs-book@… to Douglas R. Reno
Status: newassigned

comment:14 by Armin K, 6 years ago

Description: modified (diff)
Summary: Add libidn2 to the book (wait for systemd to suppor it)Add libidn2 to the book

comment:15 by Douglas R. Reno, 6 years ago

Milestone: 8.18.2

comment:16 by Douglas R. Reno, 6 years ago

Resolution: fixed
Status: assignedclosed

Added libidn2 to the book at r19249

Note: See TracTickets for help on using tickets.