Changes between Version 101 and Version 102 of firefox


Ignore:
Timestamp:
09/07/2021 06:02:08 PM (13 months ago)
Author:
ken@…
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • firefox

    v101 v102  
    99You can also tell firefox to use a profile which it warns is old, either by invoking it from a term in xorg using 'MOZ_ALLOW_DOWNGRADE=1 firefox' or by invoking it as 'firefox --allow-downgrade'. The latter invocation has been troublesome in the past but appears to work since 68.2.0 and can be used from a desktop 'launcher'.
    1010
    11 For 92.0esr, firefox seems to want to create a new profile when coming from 78esr, but using 'firefox -P' allows it to use the existing profile. If you have created redundant profiles, or wish to rename profiles, 'about:profiles' will open the profile manager to permit this.
     11For 91.0esr, firefox seems to want to create a new profile when coming from 78esr, but using 'firefox -P' allows it to use the existing profile. If you have created redundant profiles, or wish to rename profiles, 'about:profiles' will open the profile manager to permit this.
    1212 
    1313== Which version should I use ? ==
     
    2424
    2525== Dependencies for 78-ESR series ==
     26
     27This information will be removed when legacy firefox-78 is removed from the books.
    2628
    2729Although the book is tested with its latest versions of the dependencies ''' it should be possible to use older versions of some packages''':
     
    6365
    6466Not a change to the build process, but in 90.0 the ability to use ftp links was removed.
    65 If this bothers you, consider using firefox-legacy (currently 78.13.0) as a short-term workaround until you find an alternative (current seamonkey and falkon permit this, but seamonkey tends to lag behind the firefox vulnerability fixes, while seamonkey requires qtwebengine which is a heavy overhead).
     67If this bothers you, consider using firefox-legacy (currently 78.14.0 - does not work on glibc-2.34) as a short-term workaround until you find an alternative (current seamonkey and falkon permit this, but seamonkey tends to lag behind the firefox vulnerability fixes, while seamonkey requires qtwebengine which is a heavy overhead).
    6668
    6769== Problems with 91.0 failing to build ==
    6870
    69 On a couple of systems (one fairly recent, one BLFS-10. with necessary updates) 91.0 fails to build - a python test on libgkrust.a reports
     71On a couple of systems (one fairly recent, one BLFS-10. with necessary updates) 91.0 failed to build - a python test on libgkrust.a reported
    7072{{{
    7173TEST-UNEXPECTED-FAIL | check_networking | libgkrust.a |
     
    7375}}}
    7476
    75 This happens with both clang and gcc.
    76 
    77 As a workaround until you can update those systems successfully, consider updating to firefox-legacy as a short-term workaround.
     77This happened with both clang and gcc.
    7878
    7979There is now a patch in BLFS which fixes that problem.
    8080
    81 == Dependencies for the latest release ==
    8281
    83 This is an attempt to help people who want to keep using the latest upstream release, and will be updated from time to time. It is also a store of important changes which will need to be addressed when the book moves to the next ESR version.
    84 
    85 Once 91.0esr is settled in the book, much of the information above will be removed.
    86 
    87 == Dependencies for 91.0 ==
     82== Dependencies for 91.0esr series ==
    8883
    8984cbindgen needs to be >= 0.19.0
     
    9186icu needs to be 69.1
    9287
    93 The node.js version now tests for v10.23.1, but node v10 is no longer maintained. Tested with v14.17.4
     88The node.js version now tests for v10.23.1, but node v10 is no longer maintained. Tested with the latest version of node.js in the book.
    9489
    9590nspr needs to be >= 4.32.0
     
    10095
    10196
    102 == Dependencies for 92.0beta ==
     97== Dependencies for the latest release ==
    10398
    104 nss now needs to be >= 3.69
     99This is an attempt to help people who want to keep using the latest upstream release, and will be updated from time to time. It is also a store for any changes which will need to be addressed when the book moves to the next ESR version.
    105100
    106 other minimum versions unchanged.
     101== Dependencies for 92.0 (latest upstream stable) ==
    107102
    108 Note: with 92.0b3 libstdc++.a was required. This appears to have been fixed by the time 92.0b7 was released.
     103nss now needs to be >= 3.69.1
    109104
    110 This version does compile on glibc-2.34, it has a slightly differnet fix from the patch BLFS uses for 91.0esr.
     105other minimum versions unchanged.
     106
     107
     108== Dependencies for 93.0beta ==
     109
     110nss now needs to be >= 3.70
     111
     112other minimum versions unchanged
    111113
    112114[wiki:GraphicalWebBrowsers Up][[br]]