Changes between Version 37 and Version 38 of firefox


Ignore:
Timestamp:
01/09/2020 01:54:52 AM (22 months ago)
Author:
ken@…
Comment:

Update now that 72.0 has been released.

Legend:

Unmodified
Added
Removed
Modified
  • firefox

    v37 v38  
    6868nss versions >= 3.44.3 should work, but using the latest is considered safer. 3.44.3 is a recent update to 3.44 released on 19th November 2019, '''Any versions released before that date should not be used, even if the configure tests pass'''
    6969
    70 rustc-1.35.0 works and has been tested. 
     70rustc-1.35.0 works and has been tested.
    7171
    7272sqlite >= 3.28.0 should work, but you are recommended to use the latest version.
    7373
    7474
    75 == Dependencies for the latest release (these details are for 71.0) ==
     75== Dependencies for the latest release (these details are for 72.0) ==
    7676
    77 This is an attempt to help people who want to keep using the latest upstream release, and will be updated from time to time.
     77This is an attempt to help people who want to keep using the latest upstream release, and will be updated from time to time. It is also a store of important changes which will need to be addressed when the book moves to the next ESR version which is expected to be the 78 series in June to August 2020 (depending on when thunderbird is ready!)
    7878
    7979''Importantly, after ff70 ./mach install no longer accepts '--verbose' and errors if it is used.''
    8080
    81 For firefox-71.0, the following need to be at least the specified versions:
     81For firefox-72.0, the following need to be at least the specified versions:
    8282
    8383cbindgen-0.9.1
    8484
    85 harfbuzz-2.6.2 (if using the patch, which is in the patches project)
     85The parts of the patch for system graphite2 have been dropepd, changes at mozilla mean that some of their new code only compiles if the shipped graphite2 is built.  If using the updated patch for system harfbuzz, harfbuzz needs to be >= 2.6.4.
    8686
    87 nspr-4.23
     87nspr-4.24
    8888
    89 nss-3.47.1
     89nss-3.48.0
    9090
    91 rustc-1.37.0 (newer releases should be ok for firefox)
     91rustc-1.37.0 (newer releases should be ok for firefox, tested with rustc-1.40.0)
    9292
    93 sqlite-3.29.0 (latest is preferred)
     93sqlite-3.30.1
    9494
    95 == Dependencies for 72.0beta ==
     95== Dependencies for 73.0beta ==
    9696
    9797A place to look at the next release.
    9898
    99 nss now needs to be >= 3.48.
    100 
    101 sqlite is now 3.30.1, so use >= 3.30.1 for the system version.
    102 
    103 The parts of the patch for system graphite2 have been dropepd, changes at mozilla mean that some of their new code only compiles if the shipped graphite2 is built.  If using the updated patch for system harfbuzz, harfbuzz needs to be >= 2.6.4.
    104 
    105 If you have upgraded to rustc-1.40.0, firefox-72b10 builds fine with that.
    106 
     99''To Be Advised''
    107100
    108101