Changes between Version 71 and Version 72 of firefox


Ignore:
Timestamp:
08/25/2020 08:58:10 PM (13 months ago)
Author:
ken@…
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • firefox

    v71 v72  
    6262This is an attempt to help people who want to keep using the latest upstream release, and will be updated from time to time. It is also a store of important changes which will need to be addressed when the book moves to the next ESR version.
    6363
    64 For firefox-79.0:
    65 
    66 == Dependencies for 79.0 ==
     64== Dependencies for 80.0 ==
    6765
    6866cbindgen needs to be >= 0.14.3
    69 nss needs to be >= 3.54
    70 nspr needs to match nss (i.e. 4.26 for nss-3.54)
    71 rustc needs to be >= 1.43, tested with 1.44.1 (using system llvm-10) and 1.45.0 through 1.45.2 (using gcc).
    72 There are reports that 1.45.0 fails to build if the default clang is used.
     67nss needs to be >= 3.55
     68nspr needs to match nss (i.e. 4.27 for nss-3.55)
     69rustc needs to be >= 1.43, tested with 1.45.2 (using gcc).
     70There are reports that 1.45-series fail to build if the default clang is used.
    7371
    74 == Dependencies for 80.0beta ==
     72== Dependencies for 81.0beta ==
    7573
    76 For 80.0beta1:
    77 
    78 nspr needs to be >= 4.27
    79 nss needs to be >= 3.55
    80 Tested with rustc-1.45.0 and gcc.
     74To be advised.
    8175
    8276