Changes between Version 83 and Version 84 of firefox


Ignore:
Timestamp:
01/29/2021 03:51:25 AM (8 months ago)
Author:
ken@…
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • firefox

    v83 v84  
    3333libwebp >= 1.1.0 should work
    3434
    35 node.js needs to be at least v10.19.0. The latest node-v10 is v10.21.0. On BLFS-9.0 and 8.4, this builds using
     35node.js needs to be at least v10.19.0. The latest node-v10 is v10.23.1. On BLFS-9.0 and 8.4, v10 built using
    3636{{{
    3737export CC=clang CXX=clang++ CFLAGS="$CFLAGS -std=c11" CXXFLAGS="$CXXFLAGS -std=c++14"
     
    4040'''On BLFS-8.3 I have not been able to build a suitable version of node-js (c++ issues)'''
    4141
    42 nss needs to be at least 3.53.1 with its corresponding version of nspr.
     42nss needs to be at least 3.53.1 with its corresponding version of nspr, but there have been various fixes since then, the latest version of nss continues to be recommended.
    4343
    4444The minimum rustc version remains at 1.41.0, which was buggy. Use 1.42.0. If your version of llvm is less than 10.0, build rustc using its shipped llvm (see [http://wiki.linuxfromscratch.org/blfs/wiki/rust]).
     
    6969}}}
    7070
    71 I do not want to try the system python option becasue that looks as if it will use pip to download required packages and perhaps try to install them on the system.
     71I do not want to try the system python option because that looks as if it will use pip to download required packages and perhaps try to install them on the system.
    7272
    73 Using './mach create-mach-environment' before running ./mach build (but after the exports) works.
     73Using './mach create-mach-environment' before running other mach commands (but after the exports) works.
     74
     75With 78.7.0 I have changed the './mach build' invocation to first run './mach configure' (just checking deps and creating the build files ("reticulating splines") to be more consistent with conventional packages, followed by './mach build' after noticing this in an AUR thunderbird build.
    7476
    7577
     
    9395== Dependencies for 86.0beta ==
    9496
    95 To be advised.
     97As of 86.0beta1:
     98
     99nss now needs to be >= 3.61.0
     100
     101The node.js version now tests for v10.23.1, update less-old systems to v12.20.1 or v14.15.4.
     102
     103cbindgen now needs to be >= 0.16.0.
    96104
    97105