Changes between Version 97 and Version 98 of firefox


Ignore:
Timestamp:
08/11/2021 01:04:13 AM (14 months ago)
Author:
ken@…
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • firefox

    v97 v98  
    8383
    8484Not a change to the build process, but in 90.0 the ability to use ftp links was removed.
     85If this bothers you, consider using firefox-legacy (currently 78.13.0) as a short-term workaround until you find an alternative.
     86
     87== Problems with 91.0 failing to build ==
     88
     89On a couple of systems (one fairly recent, one BLFS-10. with necessary updates) 91.0 fails to build - a python test on libgkrust.a reports
     90{{{
     91TEST-UNEXPECTED-FAIL | check_networking | libgkrust.a |
     92Identified 1 networking function(s) being imported in the rust static library (getsockname)
     93}}}
     94
     95This happens with both clang and gcc.
     96
     97As a workaround until you can update those systems successfully, consider updating to firefox-legacy as a short-term workaround.
    8598
    8699== Dependencies for the latest release ==
     
    88101This is an attempt to help people who want to keep using the latest upstream release, and will be updated from time to time. It is also a store of important changes which will need to be addressed when the book moves to the next ESR version.
    89102
     103Once 91.0esr is settled in the book, much of the information above will be removed.
    90104
    91 == Dependencies for 90.0 ==
     105== Dependencies for 91.0 ==
    92106
    93107cbindgen needs to be >= 0.19.0
    94108
    95 The node.js version now tests for v10.23.1, but node v10 is no longer maintained. Tested with v14.17.3.
     109icu needs to be 69.1
    96110
    97 nspr needs to be >= 4.30.0 (tested with 4.32.0)
     111The node.js version now tests for v10.23.1, but node v10 is no longer maintained. Tested with v14.17.4
    98112
    99 nss needs to be >= 3.66 (tested with 3.67.0)
     113nspr needs to be >= 4.32.0
     114
     115nss needs to be >= 3.68 (tested with 3.69.0)
    100116
    101117rustc needs to be >= 1.47 but you should use 1.52.0 to fix possible vulnerabilities.
     
    103119
    104120
    105 == Dependencies for 91.0beta ==
     121== Dependencies for 92.0beta ==
    106122
    107 icu now needs to be >= 69.1
    108 
    109 nspr now needs to be >= 4.32
    110 
    111 nss now needs to be >= 3.68
    112 
    113 rustc now needs to be >= 1.51.0
    114 
    115 If you wish to use gcc-11.1.0 to build this, you will need to patch gcc, see above.
     123TBA
    116124
    117125[wiki:GraphicalWebBrowsers Up][[br]]