wiki:webkitgtk

Webkitgtk

If you are using make-3.82, using "make -j1" is recommended becasue of possible dependency races.

If you are using gobkject-introspection-0.9.* you will need to apply the following sed to prevent the build failing at a very late stage:

sed -i -e 's,repository version="1.0",repository version="1.1",' \
    WebKit/gtk/JSCore-1.0.gir

Also note that the testsuite fails if you use --enable-introspection and use gobject-introspection-0.9.3. Despite this, it seems to run ok for me with epiphany and midori, but YMMV.

Up
Top

Last modified 11 years ago Last modified on 09/09/2010 10:56:39 PM
Note: See TracWiki for help on using the wiki.