source: chapter01/whatsnew.xml@ e1ebbef

11.1 11.1-rc1 arm multilib trunk xry111/clfs-ng xry111/lfs-next
Last change on this file since e1ebbef was e1ebbef, checked in by Bruce Dubbs <bdubbs@…>, 5 months ago

Package updates.
Update to vim-8.2.4236.
Update to zstd-1.5.2.
Update to util-linux-2.37.3 (security fix).
Update to Python-3.10.2.
Update to linux-5.16.2.
Update to libcap-2.63.
Update to iproute2-5.16.0.
Update to iana-etc-20220120.

  • Property mode set to 100644
File size: 8.3 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2
3<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
4 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
5 <!ENTITY % general-entities SYSTEM "../general.ent">
6 %general-entities;
7]>
8
9<sect1 id="ch-intro-whatsnew">
10 <?dbhtml filename="whatsnew.html"?>
11
12 <title>What's new since the last release</title>
13
14 <para>In this version of LFS, there has been a major reorganization
15 of the book using techniques that avoid changing the host system
16 and provides a more straight forward build process.</para>
17
18 <para>Below is a list of package updates made since the previous
19 release of the book.</para>
20
21 <!--
22 Every package in the book is listed in the "Upgraded to:" section.
23 Comment/uncomment as needed. DO NOT delete any of these lines unless that
24 package is removed from the book entirely.
25 -->
26
27 <itemizedlist>
28 <title>Upgraded to:</title>
29 <listitem><para></para></listitem> <!-- satisfy build -->
30 <!--<listitem>
31 <para>None</para>
32 </listitem>-->
33 <!--<listitem>
34 <para>Acl-&acl-version;</para>
35 </listitem>-->
36 <!--<listitem>
37 <para>Attr-&attr-version;</para>
38 </listitem>-->
39 <!--<listitem>
40 <para>Autoconf-&autoconf-version;</para>
41 </listitem>-->
42 <listitem>
43 <para>Automake-&automake-version;</para>
44 </listitem>
45 <listitem>
46 <para>Bash &bash-version;</para>
47 </listitem>
48 <listitem>
49 <para>Bc &bc-version;</para>
50 </listitem>
51 <!--<listitem>
52 <para>Binutils-&binutils-version;</para>
53 </listitem>-->
54 <listitem>
55 <para>Bison-&bison-version;</para>
56 </listitem>
57 <!--<listitem>
58 <para>Bzip2-&bzip2-version;</para>
59 </listitem>-->
60 <!--<listitem>
61 <para>Check-&check-version;</para>
62 </listitem>-->
63 <listitem>
64 <para>Coreutils-&coreutils-version;</para>
65 </listitem>
66 <!--<listitem>
67 <para>DejaGNU-&dejagnu-version;</para>
68 </listitem>-->
69 <!--<listitem revision="systemd">
70 <para>D-Bus-&dbus-version;</para>
71 </listitem>-->
72 <!--<listitem>
73 <para>Diffutils-&diffutils-version;</para>
74 </listitem>-->
75 <listitem>
76 <para>E2fsprogs-&e2fsprogs-version;</para>
77 </listitem>
78 <listitem revision="sysv">
79 <para>Eudev-&eudev-version;</para>
80 </listitem>
81 <listitem>
82 <para>Expat-&expat-version;</para>
83 </listitem>
84 <!--<listitem>
85 <para>Expect-&expect-version;</para>
86 </listitem>-->
87 <listitem>
88 <para>File-&file-version;</para>
89 </listitem>
90 <!--<listitem>
91 <para>Findutils-&findutils-version;</para>
92 </listitem>-->
93 <!--<listitem>
94 <para>Flex-&flex-version;</para>
95 </listitem>-->
96 <listitem>
97 <para>Gawk-&gawk-version;</para>
98 </listitem>
99 <!--<listitem>
100 <para>GCC-&gcc-version;</para>
101 </listitem>-->
102 <listitem>
103 <para>GDBM-&gdbm-version;</para>
104 </listitem>
105 <!--<listitem>
106 <para>Gettext-&gettext-version;</para>
107 </listitem>-->
108 <!--<listitem>
109 <para>Glibc-&glibc-version;</para>
110 </listitem>-->
111 <!--<listitem>
112 <para>GMP-&gmp-version;</para>
113 </listitem>-->
114 <!--<listitem>
115 <para>Gperf-&gperf-version;</para>
116 </listitem>-->
117 <!--<listitem>
118 <para>Grep-&grep-version;</para>
119 </listitem>-->
120 <!--<listitem>
121 <para>Groff-&groff-version;</para>
122 </listitem>-->
123 <!--<listitem>
124 <para>GRUB-&grub-version;</para>
125 </listitem>-->
126 <listitem>
127 <para>Gzip-&gzip-version;</para>
128 </listitem>
129 <listitem>
130 <para>IANA-Etc-&iana-etc-version;</para>
131 </listitem>
132 <listitem>
133 <para>Inetutils-&inetutils-version;</para>
134 </listitem>
135 <!--<listitem>
136 <para>Intltool-&intltool-version;</para>
137 </listitem>-->
138 <listitem>
139 <para>IPRoute2-&iproute2-version;</para>
140 </listitem>
141 <listitem revision="systemd">
142 <para>Jinja2-&jinja2-version;</para>
143 </listitem>
144 <!--<listitem>
145 <para>Kbd-&kbd-version;</para>
146 </listitem>-->
147 <!--<listitem>
148 <para>Kmod-&kmod-version;</para>
149 </listitem>-->
150 <!--<listitem>
151 <para>Less-&less-version;</para>
152 </listitem>-->
153 <!--<listitem>
154 <para>LFS-Bootscripts-&lfs-bootscripts-version;</para>
155 </listitem>-->
156 <listitem>
157 <para>Libcap-&libcap-version;</para>
158 </listitem>
159 <listitem>
160 <para>Libelf-&elfutils-version; (from elfutils)</para>
161 </listitem>
162 <!--<listitem>
163 <para>Libffi-&libffi-version;</para>
164 </listitem>-->
165 <listitem>
166 <para>Libpipeline-&libpipeline-version;</para>
167 </listitem>
168 <!--<listitem>
169 <para>Libtool-&libtool-version;</para>
170 </listitem>-->
171 <listitem>
172 <para>Linux-&linux-version;</para>
173 </listitem>
174 <!--<listitem>
175 <para>M4-&m4-version;</para>
176 </listitem>-->
177 <!--<listitem>
178 <para>Make-&make-version;</para>
179 </listitem>-->
180 <!--<listitem>
181 <para>Man-DB-&man-db-version;</para>
182 </listitem>-->
183 <!--<listitem>
184 <para>Man-pages-&man-pages-version;</para>
185 </listitem>-->
186 <!--<listitem revision="systemd">
187 <para>MarkupSafe-&markupsafe-version;</para>
188 </listitem>-->
189 <listitem>
190 <para>Meson-&meson-version;</para>
191 </listitem>
192 <!--<listitem>
193 <para>MPC-&mpc-version;</para>
194 </listitem>-->
195 <!--<listitem>
196 <para>MPFR-&mpfr-version;</para>
197 </listitem>-->
198 <listitem>
199 <para>Ncurses-&ncurses-version;</para>
200 </listitem>
201 <!--<listitem>
202 <para>Ninja-&ninja-version;</para>
203 </listitem>-->
204 <listitem>
205 <para>Openssl-&openssl-version;</para>
206 </listitem>
207 <!--<listitem>
208 <para>Patch-&patch-version;</para>
209 </listitem>-->
210 <!--<listitem>
211 <para>Perl-&perl-version;</para>
212 </listitem>-->
213 <!--<listitem>
214 <para>Pkg-config-&pkgconfig-version;</para>
215 </listitem>-->
216 <!--<listitem>
217 <para>Procps-ng-&procps-ng-version;</para>
218 </listitem>-->
219 <!--<listitem>
220 <para>Psmisc-&psmisc-version;</para>
221 </listitem>-->
222 <listitem>
223 <para>Python-&python-version;</para>
224 </listitem>
225 <listitem>
226 <para>Readline-&readline-version;</para>
227 </listitem>
228 <!--<listitem>
229 <para>Sed-&sed-version;</para>
230 </listitem>-->
231 <listitem>
232 <para>Shadow-&shadow-version;</para>
233 </listitem>
234 <!--<listitem revision="sysv">
235 <para>Sysklogd-&sysklogd-version;</para>
236 </listitem>-->
237 <listitem revision="systemd">
238 <para>Systemd-&systemd-version;</para>
239 </listitem>
240 <listitem revision="sysv">
241 <para>SysVinit-&sysvinit-version;</para>
242 </listitem>
243 <!--<listitem>
244 <para>Tar-&tar-version;</para>
245 </listitem>-->
246 <!--<listitem>
247 <para>Tcl-&tcl-version;</para>
248 </listitem>-->
249 <!--<listitem>
250 <para>Texinfo-&texinfo-version;</para>
251 </listitem>-->
252 <listitem>
253 <para>Tzdata-&tzdata-version;</para>
254 </listitem>
255 <listitem>
256 <para>Util-Linux-&util-linux-version;</para>
257 </listitem>
258 <listitem>
259 <para>Vim-&vim-version;</para>
260 </listitem>
261 <!--<listitem>
262 <para>XML-Parser-&xml-parser-version;</para>
263 </listitem>-->
264 <!--<listitem>
265 <para>XZ-Utils-&xz-version;</para>
266 </listitem>-->
267 <!--<listitem>
268 <para>Zlib-&zlib-version;</para>
269 </listitem>-->
270 <listitem>
271 <para>Zstd-&zstd-version;</para>
272 </listitem>
273 </itemizedlist>
274
275 <!--<itemizedlist>
276 <title>Downgraded to:</title>
277
278 <listitem>
279 <para>PLACEHOLDER</para>
280 </listitem>
281
282 </itemizedlist>-->
283
284 <itemizedlist>
285 <title>Added:</title>
286 <listitem><para></para></listitem> <!-- satisfy build -->
287 <listitem>
288 <para>file-5.40-upstream_fixes-1.patch</para>
289 </listitem>
290 <listitem>
291 <para>shadow-4.10-useradd_segfault-1.patch</para>
292 </listitem>
293 <listitem revision="sysv">
294 <para>sysvinit-3.01-consolidated-1.patch</para>
295 </listitem>
296 <listitem revision="systemd">
297 <para>systemd-250-upstream_fixes-1.patch</para>
298 </listitem>
299 <!--
300 <listitem revision="systemd">
301 <para>MarkupSafe-&markupsafe-version;</para>
302 </listitem>
303 <listitem revision="systemd">
304 <para>Jinja2-&jinja2-version;</para>
305 </listitem>
306 -->
307 </itemizedlist>
308
309 <itemizedlist>
310 <title>Removed:</title>
311 <listitem><para></para></listitem> <!-- satisfy build -->
312
313 <!--<listitem>
314 <para>bash-5.0-upstream_fixes-1.patch</para>
315 </listitem>-->
316
317 </itemizedlist>
318
319</sect1>
Note: See TracBrowser for help on using the repository browser.