source: chapter02/hostreqs.xml@ 1fa2099

multilib-10.1 multilib-before-cross
Last change on this file since 1fa2099 was 1fa2099, checked in by Thomas Trepl <thomas@…>, 3 years ago

Initial creation of multilib branch

git-svn-id: http://svn.linuxfromscratch.org/LFS/branches/multilib@11565 4aa44e1e-78dd-0310-a6d2-fbcd4c07a689

  • Property mode set to 100644
File size: 7.5 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../general.ent">
5 %general-entities;
6]>
7
8<sect1 id="pre-hostreqs" xreflabel="Host System Requirements">
9 <?dbhtml filename="hostreqs.html"?>
10
11 <title>Host System Requirements</title>
12
13 <para>Your host system should have the following software with the
14 minimum versions indicated. This should not be an issue for most
15 modern Linux distributions. Also note that many distributions will
16 place software headers into separate packages, often in the form of
17 <quote>&lt;package-name&gt;-devel</quote> or
18 <quote>&lt;package-name&gt;-dev</quote>. Be sure to install those if
19 your distribution provides them.</para>
20
21 <para>Earlier versions of the listed software packages may work, but have
22 not been tested.</para>
23
24 <itemizedlist spacing="compact">
25
26 <listitem>
27 <para><emphasis role="strong">Bash-3.2</emphasis> (/bin/sh
28 should be a symbolic or hard link to bash)</para>
29 </listitem>
30
31 <listitem>
32 <para><emphasis role="strong">Binutils-2.25</emphasis> (Versions
33 greater than &binutils-version; are not recommended as they have
34 not been tested)</para>
35 </listitem>
36
37 <listitem>
38 <para><emphasis role="strong">Bison-2.7</emphasis> (/usr/bin/yacc
39 should be a link to bison or small script that executes bison)</para>
40 </listitem>
41
42 <listitem>
43 <para><emphasis role="strong">Bzip2-1.0.4</emphasis></para>
44 </listitem>
45
46 <listitem>
47 <para><emphasis role="strong">Coreutils-6.9</emphasis></para>
48 </listitem>
49
50 <listitem>
51 <para><emphasis role="strong">Diffutils-2.8.1</emphasis></para>
52 </listitem>
53
54 <listitem>
55 <para><emphasis role="strong">Findutils-4.2.31</emphasis></para>
56 </listitem>
57
58 <listitem>
59 <para><emphasis role="strong">Gawk-4.0.1</emphasis> (/usr/bin/awk
60 should be a link to gawk)</para>
61 </listitem>
62
63 <listitem>
64 <para><emphasis role="strong">GCC-5.2</emphasis> including the C++
65 compiler, <command>g++</command> (Versions greater than &gcc-version; are
66 not recommended as they have not been tested)</para>
67 </listitem>
68
69 <listitem>
70 <para><emphasis role="strong">Glibc-2.11</emphasis> (Versions
71 greater than &glibc-version; are not recommended as they have
72 not been tested)</para>
73 </listitem>
74
75 <listitem>
76 <para><emphasis role="strong">Grep-2.5.1a</emphasis></para>
77 </listitem>
78
79 <listitem>
80 <para><emphasis role="strong">Gzip-1.3.12</emphasis></para>
81 </listitem>
82
83 <listitem>
84 <para><emphasis role="strong">Linux Kernel-&min-kernel;</emphasis></para>
85
86 <para>The reason for the kernel version requirement is that we specify
87 that version when building <application>glibc</application> in Chapter&nbsp;6
88 at the recommendation of the developers. It is also required by
89 udev.</para>
90
91 <para>If the host kernel is earlier than &min-kernel; you will need to replace
92 the kernel with a more up to date version. There are two ways
93 you can go about this. First, see if your Linux vendor provides a &min-kernel;
94 or later kernel package. If so, you may wish to install it. If your
95 vendor doesn't offer an acceptable kernel package, or you would prefer not to
96 install it, you can compile a kernel yourself. Instructions for
97 compiling the kernel and configuring the boot loader (assuming the host
98 uses GRUB) are located in <xref linkend="chapter-bootable"/>.</para>
99
100 </listitem>
101
102 <listitem>
103 <para><emphasis role="strong">M4-1.4.10</emphasis></para>
104 </listitem>
105
106 <listitem>
107 <para><emphasis role="strong">Make-4.0</emphasis></para>
108 </listitem>
109
110 <listitem>
111 <para><emphasis role="strong">Patch-2.5.4</emphasis></para>
112 </listitem>
113
114 <listitem>
115 <para><emphasis role="strong">Perl-5.8.8</emphasis></para>
116 </listitem>
117
118 <listitem>
119 <para><emphasis role="strong">Python-3.4</emphasis></para>
120 </listitem>
121
122 <listitem>
123 <para><emphasis role="strong">Sed-4.1.5</emphasis></para>
124 </listitem>
125
126 <listitem>
127 <para><emphasis role="strong">Tar-1.22</emphasis></para>
128 </listitem>
129
130 <listitem>
131 <para><emphasis role="strong">Texinfo-4.7</emphasis></para>
132 </listitem>
133
134 <listitem>
135 <para><emphasis role="strong">Xz-5.0.0</emphasis></para>
136 </listitem>
137
138 </itemizedlist>
139
140 <important>
141 <para>Note that the symlinks mentioned above are required to build an LFS
142 system using the instructions contained within this book. Symlinks that
143 point to other software (such as dash, mawk, etc.) may work, but are not
144 tested or supported by the LFS development team, and may require either
145 deviation from the instructions or additional patches to some
146 packages.</para>
147 </important>
148
149 <!-- Use an empty sect2 element to prevent a pdf warning. -->
150 <bridgehead renderas="sect2"
151 id="version-check"
152 xreflabel="Host System Requirements">
153 </bridgehead>
154 <!--<title> </title>-->
155
156 <para >To see whether your host system has all the appropriate versions, and
157 the ability to compile programs, run the following:</para>
158
159<!-- ANY additional lines in the script cause a pdf rendering problem-->
160<screen role="nodump"><userinput>cat &gt; version-check.sh &lt;&lt; "EOF"
161<literal>#!/bin/bash
162# Simple script to list version numbers of critical development tools
163export LC_ALL=C
164bash --version | head -n1 | cut -d" " -f2-4
165MYSH=$(readlink -f /bin/sh)
166echo "/bin/sh -&gt; $MYSH"
167echo $MYSH | grep -q bash || echo "ERROR: /bin/sh does not point to bash"
168unset MYSH
169
170echo -n "Binutils: "; ld --version | head -n1 | cut -d" " -f3-
171bison --version | head -n1
172
173if [ -h /usr/bin/yacc ]; then
174 echo "/usr/bin/yacc -> `readlink -f /usr/bin/yacc`";
175elif [ -x /usr/bin/yacc ]; then
176 echo yacc is `/usr/bin/yacc --version | head -n1`
177else
178 echo "yacc not found"
179fi
180
181bzip2 --version 2&gt;&amp;1 &lt; /dev/null | head -n1 | cut -d" " -f1,6-
182echo -n "Coreutils: "; chown --version | head -n1 | cut -d")" -f2
183diff --version | head -n1
184find --version | head -n1
185gawk --version | head -n1
186
187if [ -h /usr/bin/awk ]; then
188 echo "/usr/bin/awk -&gt; `readlink -f /usr/bin/awk`";
189elif [ -x /usr/bin/awk ]; then
190 echo awk is `/usr/bin/awk --version | head -n1`
191else
192 echo "awk not found"
193fi
194
195gcc --version | head -n1
196g++ --version | head -n1
197ldd --version | head -n1 | cut -d" " -f2- # glibc version
198grep --version | head -n1
199gzip --version | head -n1
200cat /proc/version
201m4 --version | head -n1
202make --version | head -n1
203patch --version | head -n1
204echo Perl `perl -V:version`
205python3 --version
206sed --version | head -n1
207tar --version | head -n1
208makeinfo --version | head -n1 # texinfo version
209xz --version | head -n1
210<?hard-pagebreak?>
211echo 'int main(){}' &gt; dummy.c &amp;&amp; g++ -o dummy dummy.c
212if [ -x dummy ]
213 then echo "g++ compilation OK";
214 else echo "g++ compilation failed"; fi
215rm -f dummy.c dummy</literal>
216EOF
217
218bash version-check.sh</userinput></screen>
219<!--
220 <para>Also check for some library consistency:</para>
221
222<screen role="nodump"><userinput>cat &gt; library-check.sh &lt;&lt; "EOF"
223<literal>#!/bin/bash
224for lib in lib{gmp,mpfr,mpc}.la; do
225 echo $lib: $(if find /usr/lib* -name $lib|
226 grep -q $lib;then :;else echo not;fi) found
227done
228unset lib</literal>
229EOF
230
231bash library-check.sh</userinput></screen>
232
233<para>The files identified by this script should be all present
234or all absent, but not only one or two present.</para>
235-->
236
237</sect1>
Note: See TracBrowser for help on using the repository browser.