source: chapter05/glibc.xml

trunk
Last change on this file was c6c1a06, checked in by Xi Ruoyao <xry111@…>, 40 hours ago

glibc: Remove a sed useless for 2.37

  • Property mode set to 100644
File size: 8.9 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../general.ent">
5 %general-entities;
6]>
7
8<sect1 id="ch-tools-glibc" role="wrap">
9 <?dbhtml filename="glibc.html"?>
10
11 <sect1info condition="script">
12 <productname>glibc</productname>
13 <productnumber>&glibc-version;</productnumber>
14 <address>&glibc-url;</address>
15 </sect1info>
16
17 <title>Glibc-&glibc-version;</title>
18
19 <indexterm zone="ch-tools-glibc">
20 <primary sortas="a-Glibc">Glibc</primary>
21 <secondary>tools</secondary>
22 </indexterm>
23
24 <sect2 role="package">
25 <title/>
26
27 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
28 href="../chapter08/glibc.xml"
29 xpointer="xpointer(/sect1/sect2[1]/para[1])"/>
30
31 <segmentedlist>
32 <segtitle>&buildtime;</segtitle>
33 <segtitle>&diskspace;</segtitle>
34
35 <seglistitem>
36 <seg>&glibc-tmp-sbu;</seg>
37 <seg>&glibc-tmp-du;</seg>
38 </seglistitem>
39 </segmentedlist>
40
41 </sect2>
42
43 <sect2 role="installation">
44 <title>Installation of Glibc</title>
45
46 <para>First, create a symbolic link for LSB compliance. Additionally,
47 for x86_64, create a compatibility symbolic link required for proper
48 operation of the dynamic library loader:</para>
49
50<screen><userinput remap="pre">case $(uname -m) in
51 i?86) ln -sfv ld-linux.so.2 $LFS/lib/ld-lsb.so.3
52 ;;
53 x86_64) ln -sfv ../lib/ld-linux-x86-64.so.2 $LFS/lib64
54 ln -sfv ../lib/ld-linux-x86-64.so.2 $LFS/lib64/ld-lsb-x86-64.so.3
55 ;;
56esac</userinput></screen>
57
58 <note>
59 <para>
60 The above command is correct. The <command>ln</command> command has
61 several syntactic versions, so be sure to check
62 <command>info coreutils ln</command> and <filename>ln(1)</filename>
63 before reporting what may appear to be an error.
64 </para>
65 </note>
66
67 <para>Some of the Glibc programs use the non-FHS-compliant
68 <filename class="directory">/var/db</filename> directory to store their
69 runtime data. Apply the following patch to make such programs store their
70 runtime data in the FHS-compliant locations:</para>
71
72<screen><userinput remap="pre">patch -Np1 -i ../glibc-&glibc-version;-fhs-1.patch</userinput></screen>
73
74 <para>The Glibc documentation recommends building Glibc
75 in a dedicated build directory:</para>
76
77<screen><userinput remap="pre">mkdir -v build
78cd build</userinput></screen>
79
80 <para>Ensure that the <command>ldconfig</command> and <command>sln</command>
81 utilities are installed into
82 <filename class="directory">/usr/sbin</filename>:</para>
83
84<screen><userinput remap="pre">echo "rootsbindir=/usr/sbin" &gt; configparms</userinput></screen>
85
86 <para>Next, prepare Glibc for compilation:</para>
87
88<screen><userinput remap="configure">../configure \
89 --prefix=/usr \
90 --host=$LFS_TGT \
91 --build=$(../scripts/config.guess) \
92 --enable-kernel=&min-kernel; \
93 --with-headers=$LFS/usr/include \
94 libc_cv_slibdir=/usr/lib</userinput></screen>
95
96 <variablelist>
97 <title>The meaning of the configure options:</title>
98
99 <varlistentry>
100 <term><parameter>--host=$LFS_TGT, --build=$(../scripts/config.guess)</parameter></term>
101 <listitem>
102 <para>The combined effect of these switches is that Glibc's build system
103 configures itself to be cross-compiled, using the cross-linker and
104 cross-compiler in <filename class="directory">$LFS/tools</filename>.</para>
105 </listitem>
106 </varlistentry>
107
108 <varlistentry>
109 <term><parameter>--enable-kernel=&min-kernel;</parameter></term>
110 <listitem>
111 <para>This tells Glibc to compile the library with support
112 for &min-kernel; and later Linux kernels. Workarounds for older
113 kernels are not enabled.</para>
114 </listitem>
115 </varlistentry>
116
117 <varlistentry>
118 <term><parameter>--with-headers=$LFS/usr/include</parameter></term>
119 <listitem>
120 <para>This tells Glibc to compile itself against the headers
121 recently installed to the $LFS/usr/include directory, so that
122 it knows exactly what features the kernel has and can optimize
123 itself accordingly.</para>
124 </listitem>
125 </varlistentry>
126
127 <varlistentry>
128 <term><parameter>libc_cv_slibdir=/usr/lib</parameter></term>
129 <listitem>
130 <para>This ensures that the library is installed in /usr/lib instead
131 of the default /lib64 on 64-bit machines.</para>
132 </listitem>
133 </varlistentry>
134
135 </variablelist>
136
137 <para>During this stage the following warning might appear:</para>
138
139 <blockquote>
140<screen><computeroutput>configure: WARNING:
141*** These auxiliary programs are missing or
142*** incompatible versions: msgfmt
143*** some features will be disabled.
144*** Check the INSTALL file for required versions.</computeroutput></screen>
145 </blockquote>
146
147 <para>The missing or incompatible <command>msgfmt</command> program is
148 generally harmless. This <command>msgfmt</command> program is part of the
149 Gettext package, which the host distribution should provide.</para>
150
151 <note><para>There have been reports that this package may fail when
152 building as a "parallel make". If that occurs, rerun the make command
153 with the "-j1" option.</para></note>
154
155 <para>Compile the package:</para>
156
157<screen><userinput remap="make">make</userinput></screen>
158
159 <para>Install the package:</para>
160
161 <warning><para>If <envar>LFS</envar> is not properly set, and despite the
162 recommendations, you are building as
163 <systemitem class="username">root</systemitem>, the next command will
164 install the newly built Glibc to your host system, which will almost
165 certainly render it unusable. So double-check that the environment is
166 correctly set, and that you are not &root;, before running the following command.</para></warning>
167
168<screen><userinput remap="install">make DESTDIR=$LFS install</userinput></screen>
169
170 <variablelist>
171 <title>The meaning of the <command>make install</command> option:</title>
172
173 <varlistentry>
174 <term><parameter>DESTDIR=$LFS</parameter></term>
175 <listitem>
176 <para>The <envar>DESTDIR</envar> make variable is used by almost all
177 packages to define the location where the package should be
178 installed. If it is not set, it defaults to the root (<filename
179 class="directory">/</filename>) directory. Here we specify that
180 the package is installed in <filename class="directory">$LFS
181 </filename>, which will become the root directory in <xref linkend=
182 "ch-tools-chroot"/>.</para>
183 </listitem>
184 </varlistentry>
185
186 </variablelist>
187
188 <para>Fix a hard coded path to the executable loader in the
189 <command>ldd</command> script:</para>
190
191<screen><userinput remap="install">sed '/RTLDLIST=/s@/usr@@g' -i $LFS/usr/bin/ldd</userinput></screen>
192
193 <caution>
194 <para>At this point, it is imperative to stop and ensure that the basic
195 functions (compiling and linking) of the new toolchain are working as
196 expected. To perform a sanity check, run the following commands:</para>
197
198<screen><userinput>echo 'int main(){}' | $LFS_TGT-gcc -xc -
199readelf -l a.out | grep ld-linux</userinput></screen>
200
201 <para>If everything is working correctly, there should be no errors,
202 and the output of the last command will be of the form:</para>
203
204<screen><computeroutput>[Requesting program interpreter: /lib64/ld-linux-x86-64.so.2]</computeroutput></screen>
205
206 <para>Note that for 32-bit machines, the interpreter name will be
207 <filename>/lib/ld-linux.so.2</filename>.</para>
208
209 <para>If the output is not as shown above, or there is no output at all,
210 then something is wrong. Investigate and retrace the steps to find out
211 where the problem is and correct it. This issue must be resolved before
212 continuing.</para>
213
214 <para>Once all is well, clean up the test file:</para>
215
216<screen><userinput>rm -v a.out</userinput></screen>
217
218 </caution>
219
220 <note><para>Building the packages in the next chapter will serve as an
221 additional check that the toolchain has been built properly. If some
222 package, especially Binutils-pass2 or GCC-pass2, fails to build, it is
223 an indication that something has gone wrong with the
224 preceding Binutils, GCC, or Glibc installations.</para></note>
225
226 <para>Now that our cross-toolchain is complete, finalize the installation
227 of the limits.h header. To do this, run a utility provided by the GCC
228 developers:</para>
229
230<screen><userinput>$LFS/tools/libexec/gcc/$LFS_TGT/&gcc-version;/install-tools/mkheaders</userinput></screen>
231
232 </sect2>
233
234 <sect2 role="content">
235 <title/>
236
237 <para>Details on this package are located in
238 <xref linkend="contents-glibc" role="."/></para>
239
240 </sect2>
241
242</sect1>
Note: See TracBrowser for help on using the repository browser.