Changeset 00abb8f


Ignore:
Timestamp:
05/18/2017 11:32:21 PM (5 years ago)
Author:
Bruce Dubbs <bdubbs@…>
Branches:
10.0, 10.0-rc1, 10.1, 10.1-rc1, 11.0, 11.0-rc1, 11.0-rc2, 11.0-rc3, 8.1, 8.1-rc1, 8.1-rc2, 8.2, 8.2-rc1, 8.3, 8.3-rc1, 8.3-rc2, 8.4, 8.4-rc1, 9.0, 9.0-rc1, 9.1, 9.1-rc1, cross-chap5, ml-11.0, multilib, old-trunk, trunk, xry111/git-transition, xry111/glibc-2.34, xry111/tester-nohack, xry111/usr-move
Children:
9e326ab
Parents:
1af5572
Message:

Move library versions for presevation of debugging symbols
to packages.ent.

Update to linux-4.11.1.
Update to shadow-4.5.

git-svn-id: http://svn.linuxfromscratch.org/LFS/trunk/BOOK@11253 4aa44e1e-78dd-0310-a6d2-fbcd4c07a689

Files:
6 edited

Legend:

Unmodified
Added
Removed
  • chapter01/changelog.xml

    r1af5572 r00abb8f  
    4444-->
    4545    <listitem>
     46      <para>2017-05-19</para>
     47      <itemizedlist>
     48        <listitem>
     49          <para>[bdubbs] - Move library versions for presevation
     50          of debugging symbols to packages.ent. Fixes
     51          <ulink url="&lfs-ticket-root;4085">#4085</ulink>.</para>
     52        </listitem>
     53        <listitem>
     54          <para>[bdubbs] - Update to linux-4.11.1. Fixes
     55          <ulink url="&lfs-ticket-root;4086">#4086</ulink>.</para>
     56        </listitem>
     57        <listitem>
     58          <para>[bdubbs] - Update to shadow-4.5. Fixes
     59          <ulink url="&lfs-ticket-root;4087">#4087</ulink>.</para>
     60        </listitem>
     61      </itemizedlist>
     62    </listitem>
     63
     64    <listitem>
    4665      <para>2017-05-13</para>
    4766      <itemizedlist>
  • chapter01/whatsnew.xml

    r1af5572 r00abb8f  
    201201      <para>Sed &sed-version;</para>
    202202    </listitem>-->
    203     <!--<listitem>
     203    <listitem>
    204204      <para>Shadow &shadow-version;</para>
    205     </listitem>-->
     205    </listitem>
    206206    <!--<listitem revision="sysv">
    207207      <para>Sysklogd &sysklogd-version;</para>
  • chapter06/shadow.xml

    r1af5572 r00abb8f  
    7171       -e 's@/var/spool/mail@/var/mail@' etc/login.defs</userinput></screen>
    7272
    73     <para>Now fix a bug that prevents <command>useradd</command> from
    74     setting the shell entry in the /etc/passwd file.  In this case we need a
    75     short patch, but can include it directly here without the need for a
    76     separate file:</para>
    77 
    78 <screen><userinput remap="pre">echo '--- src/useradd.c   (old)
    79 +++ src/useradd.c   (new)
    80 @@ -2027,6 +2027,8 @@
    81         is_shadow_grp = sgr_file_present ();
    82  #endif
    83  
    84 +       get_defaults ();
    85 +
    86         process_flags (argc, argv);
    87  
    88  #ifdef ENABLE_SUBIDS
    89 @@ -2036,8 +2038,6 @@
    90             (!user_id || (user_id &lt;= uid_max &amp;&amp; user_id >= uid_min));
    91  #endif                         /* ENABLE_SUBIDS */
    92  
    93 -       get_defaults ();
    94 -
    95  #ifdef ACCT_TOOLS_SETUID
    96  #ifdef USE_PAM
    97         {' | patch -p0 -l</userinput></screen>
    98 
    9973    <note>
    10074      <para>If you chose to build Shadow with Cracklib support, run the following:</para>
     
    10781
    10882<screen><userinput remap="pre">sed -i 's/1000/999/' etc/useradd</userinput></screen>
    109 
    110     <para>Fix a security issue identified upstream:</para>
    111 
    112 <screen><userinput remap="pre">sed -i -e '47 d' -e '60,65 d' libmisc/myname.c</userinput></screen>
    11383
    11484    <para>Prepare Shadow for compilation:</para>
  • chapter06/strippingagain.xml

    r1af5572 r00abb8f  
    3333<!-- also of interest are libgfortan, libgo, libgomp, and libobjc from gcc -->
    3434
    35 <screen><userinput>save_lib="ld-2.25.so libc-2.25.so libpthread-2.25.so libthread_db-1.0.so"
     35<!--<screen><userinput>save_lib="ld-2.25.so libc-2.25.so libpthread-2.25.so libthread_db-1.0.so"-->
     36<screen><userinput>save_lib="ld-&glibc-version;.so libc-&glibc-version;.so libpthread-&glibc-version;.so libthread_db-&libthread_db-version;.so"
    3637
    3738cd /lib
     
    4344done   
    4445
    45 save_usrlib="libquadmath.so.0.0.0 libstdc++.so.6.0.23
    46              libmpx.so.2.0.1 libmpxwrappers.so.2.0.1 libitm.so.1.0.0
    47              libcilkrts.so.5.0.0 libatomic.so.1.2.0"
     46save_usrlib="libquadmath.so.&libquadmath-version; libstdc++.so.&libstdcpp-version;
     47             libmpx.so.&libmpx-version; libmpxwrappers.so.&libmpxwrap-version; libitm.so.&libitm-version;
     48             libcilkrts.so.&libcilkrts-version; libatomic.so.&libatomic-version;"
    4849
    4950cd /usr/lib
  • general.ent

    r1af5572 r00abb8f  
    1 <!ENTITY version         "SVN-20170513">
     1<!ENTITY version         "SVN-20170518">
    22<!ENTITY short-version   "svn">  <!-- Used below in &blfs-book;
    33                                      Change to x.y for release but not -rc releases -->
    44<!ENTITY generic-version "development"> <!-- Use "development"  or "x.y[-pre{x}]" -->
    55
    6 <!ENTITY versiond        "20170513-systemd">
     6<!ENTITY versiond        "20170518-systemd">
    77<!ENTITY short-versiond  "systemd">
    88<!ENTITY generic-versiond "systemd">
    99
    10 <!ENTITY releasedate     "May 13, 2017">
     10<!ENTITY releasedate     "May 18, 2017">
    1111
    1212<!ENTITY copyrightdate   "1999-2017"><!-- jhalfs needs a literal dash, not &ndash; -->
  • packages.ent

    r1af5572 r00abb8f  
    219219<!ENTITY gcc-ch6-du "3.3 GB ">
    220220<!ENTITY gcc-ch6-sbu "82 SBU (with tests)">
     221<!ENTITY libquadmath-version "0.0.0">
     222<!ENTITY libstdcpp-version   "6.0.23">
     223<!ENTITY libitm-version      "1.0.0">
     224<!ENTITY libatomic-version   "1.2.0">
     225<!ENTITY libmpx-version      "2.0.1">
     226<!ENTITY libmpxwrap-version  "2.0.1">
     227<!ENTITY libcilkrts-version  "5.0.0">
    221228
    222229<!ENTITY libstdcpp-ch5-du "898 MB">
     
    250257<!ENTITY glibc-ch6-du "1.5 GB">
    251258<!ENTITY glibc-ch6-sbu "20 SBU">
     259<!ENTITY libthread_db-version "1.0">
    252260
    253261<!ENTITY gmp-version "6.1.2">
     
    393401<!ENTITY linux-major-version "4">
    394402<!ENTITY linux-minor-version "11">
    395 <!ENTITY linux-patch-version "0">
    396 <!ENTITY linux-version "&linux-major-version;.&linux-minor-version;">
    397 <!--<!ENTITY linux-version "&linux-major-version;.&linux-minor-version;.&linux-patch-version;">-->
    398 <!ENTITY linux-size "93,211 KB">
     403<!ENTITY linux-patch-version "1">
     404<!--<!ENTITY linux-version "&linux-major-version;.&linux-minor-version;">-->
     405<!ENTITY linux-version "&linux-major-version;.&linux-minor-version;.&linux-patch-version;">
     406<!ENTITY linux-size "93,285 KB">
    399407<!ENTITY linux-url "&kernel;linux/kernel/v&linux-major-version;.x/linux-&linux-version;.tar.xz">
    400 <!ENTITY linux-md5 "251a5deee0fa6daf3f356b1bbda9eab8">
     408<!ENTITY linux-md5 "9a75a70346aff3be6147e2478a581c18">
    401409<!ENTITY linux-home "http://www.kernel.org/">
    402410<!-- measured for 4.8.3 / gcc-6.2.0 on x86_64 : minimum is
     
    535543<!ENTITY sed-ch6-sbu "0.3 SBU">
    536544
    537 <!ENTITY shadow-version "4.4">
    538 <!ENTITY shadow-size "1,593 KB">
     545<!ENTITY shadow-version "4.5">
     546<!ENTITY shadow-size "1,589 KB">
    539547<!ENTITY shadow-url "https://github.com/shadow-maint/shadow/releases/download/&shadow-version;/shadow-&shadow-version;.tar.xz">
    540 <!ENTITY shadow-md5 "c06f8c2571b44899e60662f9ad259dd6">
     548<!ENTITY shadow-md5 "c350da50c2120de6bb29177699d89fe3">
    541549<!ENTITY shadow-home "http://pkg-shadow.alioth.debian.org/">
    542550<!ENTITY shadow-ch6-du "42 MB">
Note: See TracChangeset for help on using the changeset viewer.