Changeset 0f4ec34


Ignore:
Timestamp:
02/02/2023 09:48:31 PM (16 months ago)
Author:
Xi Ruoyao <xry111@…>
Branches:
11.3, 11.3-rc1, 12.0, 12.0-rc1, 12.1, 12.1-rc1, bdubbs/gcc13, multilib, renodr/libudev-from-systemd, trunk, xry111/arm64, xry111/arm64-12.0, xry111/clfs-ng, xry111/loongarch, xry111/loongarch-12.0, xry111/loongarch-12.1, xry111/mips64el, xry111/update-glibc
Children:
fcadbf4
Parents:
f7b295d
git-author:
Xi Ruoyao <xry111@…> (02/02/2023 09:46:54 PM)
git-committer:
Xi Ruoyao <xry111@…> (02/02/2023 09:48:31 PM)
Message:

libffi: Remove --disable-exec-static-tramp

It's not needed now since gjs-1.74 supports static trampoline.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • chapter08/libffi.xml

    rf7b295d r0f4ec34  
    6363    <screen><userinput remap="configure">./configure --prefix=/usr          \
    6464            --disable-static       \
    65             --with-gcc-arch=native \
    66             --disable-exec-static-tramp</userinput></screen>
     65            --with-gcc-arch=native</userinput></screen>
    6766
    6867    <variablelist>
     
    8281        </listitem>
    8382      </varlistentry>
    84 
    85       <varlistentry>
    86         <!-- To editors: try to remove it once GJS fixed (at GNOME 43) -->
    87         <term><parameter>--disable-exec-static-tramp</parameter></term>
    88         <listitem>
    89           <para>Disable static trampoline support, a new security
    90           feature in Libffi. Some BLFS packages (notably
    91           <application>GJS</application>) have not been adapted for it.</para>
    92         </listitem>
    93       </varlistentry>
    94 
    9583    </variablelist>
    9684
Note: See TracChangeset for help on using the changeset viewer.