Changeset a77c2fb


Ignore:
Timestamp:
05/01/2014 07:36:12 AM (7 years ago)
Author:
Pierre Labastie <pieere@…>
Branches:
10.0, 10.1, 11.0, 7.10, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, ken/refactor-virt, krejzi/svn, lazarus, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
a572b170
Parents:
b176eea
Message:

Patch CUPS in order to remove the dependency on Avahi
+ typo

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@13013 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
4 edited

Legend:

Unmodified
Added
Removed
  • general.ent

    rb176eea ra77c2fb  
    11<!-- $LastChangedBy$ $Date$ -->
    22
    3 <!ENTITY day          "29">                   <!-- Always 2 digits -->
    4 <!ENTITY month        "04">                   <!-- Always 2 digits -->
     3<!ENTITY day          "01">                   <!-- Always 2 digits -->
     4<!ENTITY month        "05">                   <!-- Always 2 digits -->
    55<!ENTITY year         "2014">
    66<!ENTITY copyrightdate "2001-&year;">
    77<!ENTITY copyholder   "The BLFS Development Team">
    88<!ENTITY version      "&year;-&month;-&day;">
    9 <!ENTITY releasedate  "April 29th, &year;">
     9<!ENTITY releasedate  "May 1st, &year;">
    1010<!ENTITY pubdate      "&year;-&month;-&day;"> <!-- metadata req. by TLDP -->
    1111<!ENTITY blfs-version "svn">                  <!-- svn|[release #] -->
  • introduction/welcome/changelog.xml

    rb176eea ra77c2fb  
    4646
    4747    <listitem>
     48      <para>May 1st, 2014</para>
     49      <itemizedlist>
     50        <listitem>
     51          <para>[pierre] - Patch CUPS in order to remove dependency
     52          on Avahi.</para>
     53        </listitem>
     54      </itemizedlist>
     55    </listitem>
     56
     57    <listitem>
    4858      <para>April 29th, 2014</para>
    4959      <itemizedlist>
  • pst/printing/cups.xml

    rb176eea ra77c2fb  
    8383      <listitem>
    8484        <para>
     85          Required patch: <!-- should not be needed for 1.7.3 -->
     86          <ulink url="&patch-root;/cups-&cups-version;-avahi_optional-1.patch"/>
     87        </para>
     88      </listitem>
     89      <listitem>
     90        <para>
    8591          Optional patch:
    8692          <ulink url="&patch-root;/cups-&cups-version;-content_type-1.patch"/>
     
    9197    <bridgehead renderas="sect3">Cups Dependencies</bridgehead>
    9298
     99<!-- Not needed now, with the patch
    93100    <bridgehead renderas="sect4">Required</bridgehead>
    94101    <para role="required">
    95 <!-- Bug in 1.7.2 implies that cups cannot be built without avahi or dnssd.
    96      Check that this is still required for next versions -->
    97102      <xref linkend="avahi"/>
    98103    </para>
    99 
     104-->
    100105    <bridgehead renderas="sect4">Recommended</bridgehead>
    101106    <para role="recommended">
     
    234239    introduce some difficulties with packaging -->
    235240<screen><userinput>patch -Np1 -i ../cups-&cups-version;-blfs-1.patch &amp;&amp;
     241patch -Np1 -i ../cups-&cups-version;-avahi_optional-1.patch &amp;&amp;
    236242aclocal -I config-scripts &amp;&amp;
    237243autoconf -I config-scripts &amp;&amp;
  • xincludes/gtk-update-icon-cache.xml

    rb176eea ra77c2fb  
    88    <note>
    99      <para>
    10         This package installes icon files into the
     10        This package installs icon files into the
    1111        <filename class="directory">/usr/share/icons/hicolor</filename>
    1212        hierarchy and you can improve system performance and memory usage by
Note: See TracChangeset for help on using the changeset viewer.