Ignore:
Timestamp:
01/10/2020 09:52:01 PM (23 months ago)
Author:
Douglas R. Reno <renodr@…>
Branches:
10.0, 10.1, 11.0, 9.1, ken/refactor-virt, lazarus, qt5new, trunk, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
6b4fe743
Parents:
0515763
Message:

Adapt alsa-tools to changes in alsa-lib. Remove the ld10k1/sb16_csp utilities for the time being, re-examine and add back at freeze or once the next version of alsa-lib is released, whichever comes first. This isn't ideal because ld10k1 is used to control Creative cards through HD Audio.

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@22565 af4574ff-66df-0310-9fd7-8a98e5e911e0

File:
1 edited

Legend:

Unmodified
Added
Removed
  • multimedia/libdriv/alsa-tools.xml

    r0515763 rc70ab7e  
    110110    </para>
    111111
    112 <screen><userinput>rm -rf qlo10k1 Makefile gitcompile</userinput></screen>
     112    <!-- Re-evaluate this at the next alsa-lib release (or before freeze,
     113         whichever comes first. ld10k1 and sb16_csp should be with 9.1. -->
     114    <screen><userinput>rm -rf qlo10k1 Makefile gitcompile sb16_csp ld10k1</userinput></screen>
     115
     116    <para>
     117      Next, adapt some of the <application>ALSA Tools</application> to
     118      alsa-lib-1.2.1.2 and Linux-5.4+:
     119    </para>
     120
     121<screen><userinput>sed -i -e "/#include/i #define __user" \
     122                             hdspconf/src/*.cxx  \
     123                             hdspmixer/src/*.cxx \
     124                             hdsploader/hdsploader.c</userinput></screen>
    113125
    114126    <para>
Note: See TracChangeset for help on using the changeset viewer.