wiki:gimp

GIMP

I had to use the --enable-network option with configure to get gimp-help-2-0.10 to compile.

gimp-help files

(for versions before 2.6.0)

If you only wish to build the help files in a specific language(s), set 'ALL_LINGUAS' envar.

Example: 'ALL_LINGUAS=en' will build only the english help files.

Up
Top

Wacom tablet

For Gimp to recognize a Wacom tablet, GTK+ 2 must be configured --with-xinput=yes. Furthermore, if you install xf86-input-libinput (not in BLFS), you must also install Xorg Wacom driver.

GEGL warnings

Running Gimp 2.8.18 built on GEGL 0.3.8 will emit a bunch of warnings like

(gimp:232): GLib-GObject-WARNING **: g_object_set_valist: object class 'GeglConfig' has no property named 'cache-size'
(gimp:232): GEGL-gegl-operation.c-WARNING **: Cannot change name of operation class 0x14B2C00 from "gimp:point-layer-mode" to "gimp:dissolve-mode"
(gimp:232): GEGL-gegl-operation.c-WARNING **: Cannot change name of operation class 0x14B30D0 from "gimp:point-layer-mode" to "gimp:behind-mode"
...

Build Gimp against GEGL 0.2.0 to avoid these warnings.

Last modified 5 years ago Last modified on 10/03/2016 12:58:15 AM
Note: See TracWiki for help on using the wiki.