wiki:nss

NSS

For those who do not automatically update nspr before building nss

The BLFS patch to create a pkgconfig file adds a Makefile to extract the minimum required nspr version using code that translates to

head -n1 nss/automation/release/nspr-version.txt

Alternatively, you can look at current and past release notes at https://firefox-source-docs.mozilla.org/security/nss/releases/

The main page there always points to the latest version and may, or may not, mention a revised minimum nspr version. If it does not, and you need to know the current minimum without looking at the nss source, you can scroll down the left panel of that page in firefox or falkon to find the Release Notes for previous versions (or in links and lynx the links to releases come before the current text).

Last modified 2 months ago Last modified on 12/22/2023 02:07:32 PM
Note: See TracWiki for help on using the wiki.