Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3992 closed task (fixed)

iproute2-4.8.0

Reported by: bdubbs@… Owned by: ken@…
Priority: normal Milestone: 8.0
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (5)

comment:1 by ken@…, 5 years ago

Owner: changed from lfs-book@… to ken@…
Status: newassigned

comment:2 by ken@…, 5 years ago

The package works (i.e. the box booted and got a dhcp address using dhclient), but the tests do nothing useful. My impression is that $(IPVERS) is empty. It is defined in

IPVERS := $(filter-out iproute2/Makefile,$(wildcard iproute2/*))

and I've never come across filter-out before, so no idea what that is supposed to do.

The tests are supposed to run

        @mkdir -p $(RESULTS_DIR)

        @for d in $(TESTS_DIR); do \
            mkdir -p $(RESULTS_DIR)/$$d; \
        done

        @for i in $(IPVERS); do \
                o=`echo $$i | sed -e 's/iproute2\///'`; \
                echo -n "Running $@ [$$o/`uname -r`]: "; \
                TMP_ERR=`mktemp /tmp/tc_testsuite.XXXXXX`; \
                TMP_OUT=`mktemp /tmp/tc_testsuite.XXXXXX`; \
                STD_ERR="$$TMP_ERR" STD_OUT="$$TMP_OUT" \
                TC="$$i/tc/tc" IP="$$i/ip/ip" DEV="$(DEV)" IPVER="$@" SNAME="$$i" \
                ERRF="$(RESULTS_DIR)/$@.$$o.err" $(KENV) $(PREFIX) tests/$@ > $(RESULTS_DIR)/$@.$$o.out; \
                if [ "$$?" = "127" ]; then \
                        echo "SKIPPED"; \
                elif [ -e "$(RESULTS_DIR)/$@.$$o.err" ]; then \
                        echo "FAILED"; \
                else \
                        echo "PASS"; \
                fi; \
                rm "$$TMP_ERR" "$$TMP_OUT"; \
                dmesg > $(RESULTS_DIR)/$@.$$o.dmesg; \
        done

but all that happens is the directory creation. I'm out of my depth, and inclined to mark as "does not have a working testsuite".

comment:3 by bdubbs@…, 5 years ago

I agree that the test is not operative. The key is:

IPVERS := $(filter-out iproute2/Makefile,$(wildcard iproute2/*))

The problem is that the only thing in iproute2/* as Makefile and that is filtered out.

If you do 'make liattests' it does give some ascii scripts, but I can't figure out how to use them properly.

Go ahead and mark this as you suggest.

comment:4 by ken@…, 5 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r11135.

comment:5 by bdubbs@…, 5 years ago

Milestone: 7.118.0

Milestone renamed

Note: See TracTickets for help on using tickets.