Opened 4 years ago

Closed 4 years ago

#4045 closed task (fixed)

grep-3.0

Reported by: bdubbs@… Owned by: lfs-book@…
Priority: normal Milestone: 8.0
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

Expected later today.

Change History (5)

comment:1 by bdubbs@…, 4 years ago

Now released.

* Noteworthy changes in release 2.28 (2017-02-06) [stable]

** Bug fixes

  When grep -Fo finds matches of differing length, it could
  mistakenly print a shorter one.  Now it prints a longest one.
  [bug introduced in grep-2.26]

  When standard output is /dev/null, grep no longer fails when
  standard input is a file in the Linux /proc file system, or when
  standard input is a pipe and standard output is in append mode.
  [bugs introduced in grep-2.27]

  Fix performance regression with multiple patterns, e.g., for -Fi in
  a multi-byte locale, or for -Fw in a single-byte locale.
  [bugs introduced in grep-2.19, grep-2.22 and grep-2.26]

** Improvements

  Improve performance for -E or -G pattern lists that are easily
  converted to -F format.

comment:2 by bdubbs@…, 4 years ago

We may want to hold off on this:

https://bugs.gentoo.org/show_bug.cgi?id=608644

Bug title: grep-2.28 broken with multiple -e patterns

comment:3 by bdubbs@…, 4 years ago

Now there is a patch for the bug. I'm still going to hold offf to see if a bugfix is going to be released.

comment:4 by bdubbs@…, 4 years ago

Summary: grep-2.28grep-3.0

Now grep-3.0

This is to announce grep-3.0, a stable release.
Why so soon after 2.28?  Because 2.28 introduced a pretty serious bug.
Why call it 3.0?  Mostly because I felt like it.

There have been 4 commits by 2 people in the 3 days since 2.28.
Thanks to Paul Eggert for both of the nontrivial commits.

comment:5 by bdubbs@…, 4 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 11181.

Note: See TracTickets for help on using tickets.