Opened 6 months ago

Closed 6 months ago

#4797 closed task (fixed)

bc-3.2.5

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 10.1
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (2)

comment:1 by Bruce Dubbs, 6 months ago

# 3.2.5

This is a production release that fixes several bugs and adds a couple small things.

The two most important bugs were bugs that causes dc to access memory out-of-bounds (crash in debug builds). This was found by upgrading to afl++ from afl. Both were caused by a failure to distinguish between the same two cases.

Another bug was the failure to put all of the licenses in the LICENSE.md file.

Third, some warnings by scan-build were found and eliminated. This needed one big change: bc and dc now bail out as fast as possible on fatal errors instead of unwinding the stack.

Fourth, the pseudo-random number now attempts to seed itself with /dev/random if /dev/urandom fails.

Finally, this release has a few quality-of-life changes to the build system. The usage should not change at all; the only thing that changed was making sure the Makefile.in was written to rebuild properly when headers changed and to not rebuild when not necessary.

comment:2 by Bruce Dubbs, 6 months ago

Resolution: fixed
Status: newclosed

Fixed at revision 12105.

Note: See TracTickets for help on using tickets.