source: postlfs/security/polkit-gnome.xml@ e713e66c

11.0 ken/refactor-virt lazarus qt5new trunk
Last change on this file since e713e66c was e713e66c, checked in by Douglas R. Reno <renodr@…>, 5 months ago

Package updates and some tweaks.

Update to abiword-3.0.5
Make AsciiDoctor internal in Wireshark
Patch polkit-gnome to use the proper icon system again.
Patch cups-pk-helper to work with future versions of CUPS and GLib.

  • Property mode set to 100644
File size: 6.1 KB
Line 
1<?xml version="1.0" encoding="ISO-8859-1"?>
2<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
3 "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
4 <!ENTITY % general-entities SYSTEM "../../general.ent">
5 %general-entities;
6
7 <!ENTITY polkit-gnome-download-http
8 "&gnome-download-http;/polkit-gnome/&polkit-gnome-version;/polkit-gnome-&polkit-gnome-version;.tar.xz">
9 <!ENTITY polkit-gnome-download-ftp
10 "&gnome-download-ftp;/polkit-gnome/&polkit-gnome-version;/polkit-gnome-&polkit-gnome-version;.tar.xz">
11 <!ENTITY polkit-gnome-md5sum "50ecad37c8342fb4a52f590db7530621">
12 <!ENTITY polkit-gnome-size "305 KB">
13 <!ENTITY polkit-gnome-buildsize "5.0 MB">
14 <!ENTITY polkit-gnome-time "0.1 SBU">
15]>
16
17<sect1 id="polkit-gnome" xreflabel="polkit-gnome-&polkit-gnome-version;">
18 <?dbhtml filename="polkit-gnome.html"?>
19
20 <sect1info>
21 <date>$Date$</date>
22 </sect1info>
23
24 <title>polkit-gnome-&polkit-gnome-version;</title>
25
26 <indexterm zone="polkit-gnome">
27 <primary sortas="a-polkit-gnome">polkit-gnome</primary>
28 </indexterm>
29
30 <sect2 role="package">
31 <title>Introduction to Polkit GNOME</title>
32
33 <para>
34 The <application>Polkit GNOME</application> package provides an
35 Authentication Agent for <application>Polkit</application> that integrates
36 well with the <application>GNOME</application> Desktop environment.
37 </para>
38
39 &lfs101_checked;
40
41 <bridgehead renderas="sect3">Package Information</bridgehead>
42 <itemizedlist spacing="compact">
43 <listitem>
44 <para>
45 Download (HTTP): <ulink url="&polkit-gnome-download-http;"/>
46 </para>
47 </listitem>
48 <listitem>
49 <para>
50 Download (FTP): <ulink url="&polkit-gnome-download-ftp;"/>
51 </para>
52 </listitem>
53 <listitem>
54 <para>
55 Download MD5 sum: &polkit-gnome-md5sum;
56 </para>
57 </listitem>
58 <listitem>
59 <para>
60 Download size: &polkit-gnome-size;
61 </para>
62 </listitem>
63 <listitem>
64 <para>
65 Estimated disk space required: &polkit-gnome-buildsize;
66 </para>
67 </listitem>
68 <listitem>
69 <para>
70 Estimated build time: &polkit-gnome-time;
71 </para>
72 </listitem>
73 </itemizedlist>
74
75 <bridgehead renderas="sect3">Additional Downloads</bridgehead>
76 <itemizedlist spacing="compact">
77 <listitem>
78 <para>
79 Required patch:
80 <ulink url="&patch-root;/polkit-gnome-&polkit-gnome-version;-consolidated_fixes-1.patch"/>
81 </para>
82 </listitem>
83 </itemizedlist>
84
85 <bridgehead renderas="sect3">Polkit GNOME Dependencies</bridgehead>
86
87 <bridgehead renderas="sect4">Required</bridgehead>
88 <para role="required">
89 <!-- due to the patch -->
90 <xref linkend="accountsservice"/>,
91 <xref linkend="gtk3"/>, and
92 <xref linkend="polkit"/>
93 </para>
94
95 <para condition="html" role="usernotes">User Notes:
96 <ulink url="&blfs-wiki;/polkit-gnome"/>
97 </para>
98 </sect2>
99
100 <sect2 role="installation">
101 <title>Installation of Polkit GNOME</title>
102
103 <para>
104 First, apply some fixes that allow for the proper user icon to be used,
105 as well as some security fixes:
106 </para>
107
108<screen><userinput remap="pre">patch -Np1 -i ../polkit-gnome-&polkit-gnome-version;-consolidated_fixes-1.patch</userinput></screen>
109
110 <para>
111 Install <application>Polkit GNOME</application> by running the following
112 commands:
113 </para>
114
115<screen><userinput>./configure --prefix=/usr &amp;&amp;
116make</userinput></screen>
117
118 <para>
119 This package does not come with a test suite.
120 </para>
121
122 <para>
123 Now, as the <systemitem class="username">root</systemitem> user:
124 </para>
125
126<screen role="root"><userinput>make install</userinput></screen>
127
128 </sect2>
129
130 <sect2 role="configuration">
131 <title>Configuring Polkit GNOME</title>
132
133 <sect3>
134
135 <title>Automatic Startup</title>
136
137 <para>
138 For the authentification framework to work,
139 <command>polkit-gnome-authentification-agent-1</command> needs to be
140 started. However, <command>make install</command> did not
141 install a startup file for the <application>Polkit GNOME</application>
142 so you have to create it by yourself.
143 </para>
144
145 <para>
146 Issue the following commands as the
147 <systemitem class="username">root</systemitem> user to create
148 a startup file for <application>Polkit GNOME</application>:
149 </para>
150
151<screen role="root"><userinput>mkdir -p /etc/xdg/autostart &amp;&amp;
152cat &gt; /etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop &lt;&lt; "EOF"
153<literal>[Desktop Entry]
154Name=PolicyKit Authentication Agent
155Comment=PolicyKit Authentication Agent
156Exec=/usr/libexec/polkit-gnome-authentication-agent-1
157Terminal=false
158Type=Application
159Categories=
160NoDisplay=true
161OnlyShowIn=GNOME;XFCE;Unity;
162AutostartCondition=GNOME3 unless-session gnome</literal>
163EOF</userinput></screen>
164
165 </sect3>
166
167 </sect2>
168
169 <sect2 role="content">
170 <title>Contents</title>
171
172 <segmentedlist>
173 <segtitle>Installed Program</segtitle>
174 <segtitle>Installed Libraries</segtitle>
175 <segtitle>Installed Directory</segtitle>
176
177 <seglistitem>
178 <seg>
179 polkit-gnome-authentication-agent-1
180 </seg>
181 <seg>
182 None
183 </seg>
184 <seg>
185 None
186 </seg>
187 </seglistitem>
188 </segmentedlist>
189
190 <variablelist>
191 <bridgehead renderas="sect3">Short Descriptions</bridgehead>
192 <?dbfo list-presentation="list"?>
193 <?dbhtml list-presentation="table"?>
194
195 <varlistentry id="polkit-gnome-authentication-agent-1">
196 <term><command>polkit-gnome-authentication-agent-1</command></term>
197 <listitem>
198 <para>
199 is the <application>Polkit</application> authentication agent
200 </para>
201 <indexterm zone="polkit-gnome polkit-gnome-authentication-agent-1">
202 <primary sortas="b-polkit-gnome-authentication-agent-1">polkit-gnome-authentication-agent-1</primary>
203 </indexterm>
204 </listitem>
205 </varlistentry>
206
207 </variablelist>
208
209 </sect2>
210
211</sect1>
Note: See TracBrowser for help on using the repository browser.