Changeset e713e66c


Ignore:
Timestamp:
07/13/2021 03:17:55 AM (3 months ago)
Author:
Douglas R. Reno <renodr@…>
Branches:
11.0, ken/refactor-virt, lazarus, qt5new, trunk
Children:
216deae
Parents:
f3704c6
Message:

Package updates and some tweaks.

Update to abiword-3.0.5
Make AsciiDoctor internal in Wireshark
Patch polkit-gnome to use the proper icon system again.
Patch cups-pk-helper to work with future versions of CUPS and GLib.

Files:
6 edited

Legend:

Unmodified
Added
Removed
  • general/sysutils/cups-pk-helper.xml

    rf3704c6 re713e66c  
    7272    </itemizedlist>
    7373
     74    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     75    <itemizedlist spacing="compact">
     76      <listitem>
     77        <para>
     78          Required patch:
     79          <ulink url="&patch-root;/cups-pk-helper-&cups-pk-helper-version;-consolidated_fixes-1.patch"/>
     80        </para>
     81      </listitem>
     82    </itemizedlist>
     83
    7484    <bridgehead renderas="sect3">cups-pk-helper Dependencies</bridgehead>
    7585
     
    8797  <sect2 role="installation">
    8898    <title>Installation of cups-pk-helper</title>
     99
     100    <para>
     101      First, fix some deprecated syntax that will prevent cups-pk-helper from
     102      building on future versions of CUPS:
     103    </para>
     104
     105<screen><userinput remap="pre">patch -Np1 -i ../cups-pk-helper-&cups-pk-helper-version;-consolidated_fixes-1.patch</userinput></screen>
    89106
    90107    <para>
  • introduction/welcome/changelog.xml

    rf3704c6 re713e66c  
    4646      <itemizedlist>
    4747        <listitem>
     48          <para>[renodr] - Adjust cups-pk-helper to no longer use deprecated
     49          syntax that will cause issues with future versions of CUPS.</para>
     50        </listitem>
     51        <listitem>
     52          <para>[renodr] - Adjust polkit-gnome to be able to pull user icons
     53          again.</para>
     54        </listitem>
     55        <listitem>
     56          <para>[renodr] - Update to abiword-3.0.5. Fixes
     57          <ulink url="&blfs-ticket-root;15237">#15237</ulink>.</para>
     58        </listitem>
     59        <listitem>
    4860          <para>[renodr] - Update to WebKitGTK+-2.32.2. Fixes
    4961          <ulink url="&blfs-ticket-root;15258">#15258</ulink>.</para>
  • networking/netutils/wireshark.xml

    rf3704c6 re713e66c  
    116116    <bridgehead renderas="sect4">Optional</bridgehead>
    117117    <para role="optional">
     118      <xref linkend="asciidoctor"/>,
    118119      <xref linkend="brotli"/>,
    119120      <xref linkend="c-ares"/>,
     
    129130      <xref linkend="sbc"/>,
    130131      <xref linkend="speex"/>,
    131       <ulink url="https://asciidoctor.org/">Asciidoctor</ulink>,
     132      <!--<ulink url="https://asciidoctor.org/">Asciidoctor</ulink>,-->
    132133      <ulink url="https://www.linphone.org/technical-corner/bcg729">BCG729</ulink>,
    133134      <ulink url="https://github.com/TimothyGu/libilbc">libilbc</ulink>,
  • packages.ent

    rf3704c6 re713e66c  
    909909<!-- Part X -->
    910910<!-- Chapter 39 -->
    911 <!ENTITY AbiWord-version              "3.0.4">
     911<!ENTITY AbiWord-version              "3.0.5">
    912912<!ENTITY gnumeric-version             "1.12.50">
    913913<!ENTITY gnucash-version              "2.4.11">
  • postlfs/security/polkit-gnome.xml

    rf3704c6 re713e66c  
    7373    </itemizedlist>
    7474
     75    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
     76    <itemizedlist spacing="compact">
     77      <listitem>
     78        <para>
     79          Required patch:
     80          <ulink url="&patch-root;/polkit-gnome-&polkit-gnome-version;-consolidated_fixes-1.patch"/>
     81        </para>
     82      </listitem>
     83    </itemizedlist>
     84
    7585    <bridgehead renderas="sect3">Polkit GNOME Dependencies</bridgehead>
    7686
    7787    <bridgehead renderas="sect4">Required</bridgehead>
    7888    <para role="required">
    79       <xref linkend="gtk3"/> and
     89      <!-- due to the patch -->
     90      <xref linkend="accountsservice"/>,
     91      <xref linkend="gtk3"/>, and
    8092      <xref linkend="polkit"/>
    8193    </para>
     
    88100  <sect2 role="installation">
    89101    <title>Installation of Polkit GNOME</title>
     102
     103    <para>
     104      First, apply some fixes that allow for the proper user icon to be used,
     105      as well as some security fixes:
     106    </para>
     107
     108<screen><userinput remap="pre">patch -Np1 -i ../polkit-gnome-&polkit-gnome-version;-consolidated_fixes-1.patch</userinput></screen>
    90109
    91110    <para>
  • xsoft/office/abiword.xml

    rf3704c6 re713e66c  
    1111           "https://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-&AbiWord-version;.tar.gz">
    1212  <!ENTITY AbiWord-download-ftp  " ">
    13   <!ENTITY AbiWord-md5sum        "04e31887049a8c72297881bc153b77c4">
     13  <!ENTITY AbiWord-md5sum        "a8f218b711450e4ccae43a0522e0e806">
    1414  <!ENTITY AbiWord-size          "11 MB">
    1515
     
    1919  <!ENTITY AbiWordDocs-size          "1.5 MB">
    2020
    21   <!ENTITY AbiWord-buildsize     "605 MB, with docs (76 MB installed)">
     21  <!ENTITY AbiWord-buildsize     "690 MB, with docs (76 MB installed)">
    2222  <!ENTITY AbiWord-time          "2.4 SBU (Using parallelism=4, with docs)">
    2323]>
     
    9797        </para>
    9898      </listitem>
     99<!--
    99100      <listitem>
    100101        <para>
     
    103104        </para>
    104105      </listitem>
     106-->
    105107    </itemizedlist>
     108
    106109
    107110    <bridgehead renderas="sect3">AbiWord Dependencies</bridgehead>
     
    163166    <title>Installation of AbiWord</title>
    164167
     168<!--
    165169    <para>
    166170      First, fix a build failure when using GCC-11:
     
    168172
    169173<screen><userinput remap="pre">patch -Np1 -i ../abiword-&AbiWord-version;-gcc11_fixes-1.patch</userinput></screen>
     174-->
    170175
    171176    <para>
Note: See TracChangeset for help on using the changeset viewer.