Changeset 81679dd6


Ignore:
Timestamp:
05/15/2004 08:01:29 AM (17 years ago)
Author:
Tushar Teredesai <tushar@…>
Branches:
10.0, 10.1, 11.0, 6.0, 6.1, 6.2, 6.2.0, 6.2.0-rc1, 6.2.0-rc2, 6.3, 6.3-rc1, 6.3-rc2, 6.3-rc3, 7.10, 7.4, 7.5, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, krejzi/svn, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, v5_1, v5_1-pre1, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
9c12e42
Parents:
46faf17
Message:

Added comment to vim section related to an editor for emergency use

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@2166 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
4 edited

Legend:

Unmodified
Added
Removed
  • introduction/welcome/changelog.xml

    r46faf17 r81679dd6  
    1111
    1212<itemizedlist>
     13
     14<listitem><para>May 15th, 2004 [tushar]: Added note in the vim page
     15for keeping an editor for emergency use.</para></listitem>
    1316
    1417<listitem><para>May 15th, 2004 [tushar]: Updated to whois-4.6.14.</para></listitem>
  • postlfs/editors/vim/vim-exp.xml

    r46faf17 r81679dd6  
    55features available in <application>Vim</application>.</para>
    66
     7<para><parameter>--enable-gui=no</parameter>: If you prefer not to link vim against X, use
     8this switch.</para>
     9
    710</sect2>
    811
  • postlfs/editors/vim/vim-inst.xml

    r46faf17 r81679dd6  
    11<sect2>
    22<title>Installation of <application>Vim</application></title>
     3
     4<note><para>If you recompile vim to link against <application>X</application>,
     5and your X libs are not on the root partition, you will no longer have
     6an editor for use in emergencies. You may choose to install an additional editor,
     7not link vim against X, or move the current <command>vim</command> executable to the
     8<filename>/bin</filename> directory under a different name such as <filename>vi</filename>.</para></note>
    39
    410<para>Install <application>Vim</application> by running the following commands:</para>
  • postlfs/editors/vim/vim-intro.xml

    r46faf17 r81679dd6  
    88
    99<para>The default <acronym>LFS</acronym> instructions install
    10 <application>vim</application> as a part of the base system, but
    11 owing to the lack of <application>X</application> libraries during the
    12 base install, <application>Vim</application> needs to be
    13 recompiled once <application>X</application> is installed to enable the
     10<application>vim</application> as a part of the base system.
     11If you would prefer to link vim against <application>X</application>,
     12you should recompile vim to enable
    1413<acronym>GUI</acronym> mode. There is no need for
    1514special instructions since <application>X</application> support is automatically detected.</para>
     
    2524
    2625<sect3><title><application>Vim</application> dependencies</title>
    27 <sect4><title>Required</title>
     26<sect4><title>Recommended</title>
    2827<para>X (<xref linkend="xfree86"/> or <xref linkend="xorg"/>)</para></sect4>
    2928<sect4><title>Optional</title>
Note: See TracChangeset for help on using the changeset viewer.