Changeset 8c986cd


Ignore:
Timestamp:
04/17/2004 03:57:02 PM (17 years ago)
Author:
Igor Živković <igor@…>
Branches:
10.0, 10.1, 6.0, 6.1, 6.2, 6.2.0, 6.2.0-rc1, 6.2.0-rc2, 6.3, 6.3-rc1, 6.3-rc2, 6.3-rc3, 7.10, 7.4, 7.5, 7.6, 7.6-blfs, 7.6-systemd, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 9.0, 9.1, basic, bdubbs/svn, elogind, gnome, kde5-13430, kde5-14269, kde5-14686, krejzi/svn, nosym, perl-modules, qt5new, systemd-11177, systemd-13485, trunk, v5_1, v5_1-pre1, xry111/git-date, xry111/git-date-for-trunk, xry111/git-date-test
Children:
b4623fd
Parents:
69e90004
Message:

gtk-doc corrections

git-svn-id: svn://svn.linuxfromscratch.org/BLFS/trunk/BOOK@2000 af4574ff-66df-0310-9fd7-8a98e5e911e0

Files:
9 edited

Legend:

Unmodified
Added
Removed
  • gnome/gnome-intro.xml

    r69e90004 r8c986cd  
    1616installed software, especially if you are testing
    1717<application><acronym>GNOME</acronym></application> on your machine.
    18 <application><acronym>GNOME</acronym></application>-&gnome-version; packages utilize the --prefix= option for configure, so we will
     18<application><acronym>GNOME</acronym></application>-&gnome-version;
     19packages utilize the <parameter>--prefix=option</parameter> for
     20<command>configure</command>, so we will
    1921use that and an Environment variable (<envar>GNOME_PREFIX</envar>) to add flexibility to
    2022the install.</para>
     
    2325<application><acronym>GNOME</acronym></application> as a desktop
    2426alternative, it is recommended that
    25 you install with --prefix=/usr. If you are not sure that you are going
     27you install with <parameter>--prefix=/usr</parameter>. If you are not sure that you are going
    2628to keep <application><acronym>GNOME</acronym></application> on your
    2729installation, you may install with
    28 --prefix=/opt/gnome-&gnome-version;.  Setting the Environment variable and the
     30<parameter>--prefix=/opt/gnome-&gnome-version;</parameter>.  Setting the Environment variable and the
    2931additional edits required by the second option are covered on the
    3032pre-installation page. Since
    3133<application><acronym>GNOME</acronym></application> has matured,
    32 installing with --prefix=/usr is the preferable approach.</para>
     34installing with <parameter>--prefix=/usr</parameter> is the preferable approach.</para>
    3335
    3436<para>If you choose the second option, removal of
     
    7779<para><application><acronym>GNOME</acronym></application>-&gnome-version; dependencies</para>
    7880<para>Required</para>
    79 <para><xref linkend="xfree86"/>, <xref linkend="GTK2"/>, <xref
    80 linkend="libpng"/>,
    81 <xref linkend="libjpeg"/>, <xref linkend="libtiff"/> and <xref
    82 linkend="popt"/></para>
     81<para>
     82<xref linkend="GTK2"/> and
     83<xref linkend="popt"/>
     84</para>
    8385<para>Optional</para>
    84 <para><xref linkend="libxml2"/>, <xref linkend="libxslt"/>, <xref
    85 linkend="DocBook"/>,
    86 <xref linkend="docbook-xsl"/> and <xref linkend="fam"/></para>
     86<para>
     87<xref linkend="libxml2"/>,
     88<xref linkend="libxslt"/>,
     89<xref linkend="DocBook"/>,
     90<xref linkend="docbook-xsl"/> and
     91<xref linkend="fam"/>
     92<!-- mozilla -->
     93</para>
    8794
    8895</partintro>
  • gnome/lib/gtk-doc/gtk-doc-desc.xml

    r69e90004 r8c986cd  
    99<command>gtkdoc-mktmpl</command>,
    1010<command>gtkdoc-scan</command>,
    11 <command>gtkdoc-scangobj</command> and
    12 <command>gtkdoc-scanobj</command>.</para>
     11<command>gtkdoc-scangobj</command>,
     12<command>gtkdoc-scanobj</command> and
     13<command>gtkdocize</command>.
     14</para>
    1315
    1416</sect2>
     
    1618<sect2><title>Description</title>
    1719
    18 
    1920<para>These are all <application>Perl</application> scripts used by
    2021<filename>Makefile</filename> scripts to generate
    2122documentation for the package.</para>
    2223
    23 
    2424</sect2>
    25 
  • gnome/lib/gtk-doc/gtk-doc-intro.xml

    r69e90004 r8c986cd  
    3232<sect3><title><application><application><acronym>GTK</acronym>-Doc</application></application> dependencies</title>
    3333<sect4><title>Required</title>
    34 <para><xref linkend="openjade"/>, <xref linkend="libxslt"/>, <xref
    35 linkend="DocBook"/>, <xref linkend="docbook-xsl"/>
    36 <xref linkend="sgml-dtd-3"/>, <xref linkend="sgml-dtd"/> and <xref
    37 linkend="docbook-dsssl"/></para></sect4>
     34<para>
     35<xref linkend="openjade"/>,
     36<xref linkend="libxslt"/>,
     37<xref linkend="DocBook"/> and
     38<xref linkend="docbook-xsl"/>
     39<!--
     40<xref linkend="sgml-dtd-3"/>,
     41<xref linkend="sgml-dtd"/> and
     42<xref linkend="docbook-dsssl"/>
     43-->
     44</para></sect4>
    3845</sect3>
    3946
    40 
    4147</sect2>
  • pst/sgml/openjade/openjade-config.xml

    r69e90004 r8c986cd  
    66<screen><userinput><command>echo "SYSTEM \"/usr/share/docbook/docbookx.dtd\" \
    77\"/usr/share/xml/docbook/xml-dtd-&DocBook-version;/docbookx.dtd\"" &gt;&gt; \
    8 /usr/share/sgml/openjade-&openjade-version;/catalog</command></userinput></screen>
     8    /usr/share/sgml/openjade-&openjade-version;/catalog</command></userinput></screen>
    99<para>This configuration is only necessary if you intend to use
    1010<application>OpenJade</application> to process the
     
    1515
    1616</sect2>
    17 
  • pst/sgml/openjade/openjade-exp.xml

    r69e90004 r8c986cd  
    1818<filename class="directory">/usr/share</filename>.</para>
    1919
    20 <para><screen>ln -sf openjade /usr/bin/jade
     20<para><screen><command>ln -sf openjade /usr/bin/jade
    2121ln -sf libogrove.so /usr/lib/libgrove.so
    2222ln -sf libospgrove.so /usr/lib/libspgrove.so
    23 ln -sf libostyle.so /usr/lib/libstyle.so</screen>
    24 These commands create the Jade equivlents of OpenJade executables and
     23ln -sf libostyle.so /usr/lib/libstyle.so</command></screen>
     24These commands create the Jade equivalents of OpenJade executables and
    2525libraries.</para>
    2626
    2727</sect2>
    28 
  • pst/sgml/openjade/openjade-inst.xml

    r69e90004 r8c986cd  
    55
    66<screen><userinput><command>./configure --prefix=/usr --enable-http --disable-static \
    7 --enable-default-catalog=/etc/sgml/catalog \
    8 --enable-default-search-path=/usr/share/sgml \
    9 --datadir=/usr/share/sgml/openjade-&openjade-version; &amp;&amp;
     7    --enable-default-catalog=/etc/sgml/catalog \
     8    --enable-default-search-path=/usr/share/sgml \
     9    --datadir=/usr/share/sgml/openjade-&openjade-version; &amp;&amp;
    1010make &amp;&amp;
    1111make install &amp;&amp;
     
    1616install -m644 dsssl/catalog /usr/share/sgml/openjade-&openjade-version;/ &amp;&amp;
    1717install -m644 dsssl/*.dtd dsssl/*.dsl dsssl/*.sgm \
    18 /usr/share/sgml/openjade-&openjade-version; &amp;&amp;
     18    /usr/share/sgml/openjade-&openjade-version; &amp;&amp;
    1919install-catalog --add /etc/sgml/openjade-&openjade-version;.cat \
    20 /usr/share/sgml/openjade-&openjade-version;/catalog &amp;&amp;
    21 install-catalog --add /etc/sgml/sgml-docbook.cat /etc/sgml/openjade-&openjade-version;.cat</command></userinput></screen>
     20    /usr/share/sgml/openjade-&openjade-version;/catalog &amp;&amp;
     21install-catalog --add /etc/sgml/sgml-docbook.cat \
     22    /etc/sgml/openjade-&openjade-version;.cat</command></userinput></screen>
    2223
    2324</sect2>
    24 
  • pst/sgml/opensp/opensp-inst.xml

    r69e90004 r8c986cd  
    1010
    1111<screen><userinput><command>./configure --prefix=/usr --disable-static --enable-http \
    12 --enable-default-catalog=/etc/sgml/catalog \
    13 --enable-default-search-path=/usr/share/sgml &amp;&amp;
     12    --enable-default-catalog=/etc/sgml/catalog \
     13    --enable-default-search-path=/usr/share/sgml &amp;&amp;
    1414make pkgdatadir=/usr/share/sgml/OpenSP-&opensp-version; &amp;&amp;
    1515make pkgdatadir=/usr/share/sgml/OpenSP-&opensp-version; install &amp;&amp;
     
    2323ln -sf libosp.so /usr/lib/libsp.so &amp;&amp;
    2424install-catalog --add /etc/sgml/OpenSP-&opensp-version;.cat \
    25 /usr/share/sgml/OpenSP-&opensp-version;/catalog &amp;&amp;
     25    /usr/share/sgml/OpenSP-&opensp-version;/catalog &amp;&amp;
    2626install-catalog --add /etc/sgml/sgml-docbook.cat \
    27 /etc/sgml/OpenSP-&opensp-version;.cat</command></userinput></screen>
     27    /etc/sgml/OpenSP-&opensp-version;.cat</command></userinput></screen>
    2828
    2929<tip><title>Update hint</title>
    3030<para>Remove the above catalog items prior to upgrading with:
    3131<screen><command>install-catalog --remove /etc/sgml/OpenSP-<replaceable>[version]</replaceable>.cat \
    32 /usr/share/sgml/OpenSP-<replaceable>[version]</replaceable>/catalog &amp;&amp;
     32    /usr/share/sgml/OpenSP-<replaceable>[version]</replaceable>/catalog &amp;&amp;
    3333install-catalog --remove /etc/sgml/sgml-docbook.cat \
    34 /etc/sgml/OpenSP-<replaceable>[version]</replaceable>.cat</command></screen></para></tip>
     34    /etc/sgml/OpenSP-<replaceable>[version]</replaceable>.cat</command></screen></para></tip>
    3535
    3636</sect2>
  • pst/sgml/sgml-common/sgml-common-inst.xml

    r69e90004 r8c986cd  
    1616running the following commands:</para>
    1717
    18 <screen><userinput><command>./configure --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man &amp;&amp;
     18<screen><userinput><command>./configure --prefix=/usr --sysconfdir=/etc &amp;&amp;
    1919make &amp;&amp;
    2020make install &amp;&amp;
  • pst/xml/docbook/docbook-intro.xml

    r69e90004 r8c986cd  
    1818<sect3><title><application>DocBook <acronym>XML</acronym> <acronym>DTD</acronym></application> &DocBook-version; dependencies</title>
    1919<sect4><title>Required</title>
    20 <para><xref linkend="libxml2"/> and <xref linkend="unzip"/></para></sect4>
     20<para><xref linkend="libxml2"/></para></sect4>
    2121</sect3>
    2222
Note: See TracChangeset for help on using the changeset viewer.