Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10117 closed defect (fixed)

Current Poppler does not work with LibreOffice

Reported by: Chris Staub Owned by: ken@…
Priority: normal Milestone: 8.2
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

The latest Poppler version (0.62.0) has changes that make it incompatible with LibreOffice. One of the headers has been renamed (UTF8.h -> UnicodeMapFuncs.h) and some of the related functions have also changed. I haven't found a patch to fix this yet, so for now I've just disabled system Poppler in LibreOffice to make it build.

Change History (10)

comment:1 by bdubbs@…, 5 years ago

The latest version of LibreOffice (5.4.3.2) is not in the book. Have you checked against that version?

I do note that some other distros (e.g. arch) have not updated to this version of poppler yet.

We probably have to check the latest version of poppler against okular, cups-filters, epdfview, cairo, tumbler, inkscape, gimp, and texlive.

in reply to:  1 comment:2 by Chris Staub, 5 years ago

Replying to bdubbs@…:

The latest version of LibreOffice (5.4.3.2) is not in the book. Have you checked against that version?

Yes, I tried with 5.4.3.2, as well as 5.4.4.1 - both have the same failure with system Poppler.

I do note that some other distros (e.g. arch) have not updated to this version of poppler yet.

We probably have to check the latest version of poppler against okular, cups-filters, epdfview, cairo, tumbler, inkscape, gimp, and texlive.

Cups-filters at least works fine with the latest Poppler for me.

comment:3 by Armin K, 5 years ago

The ticket title and description are kinda confusing.

It should say "Libreoffice is not compatible with latest Poppler", not the other way around, no?

comment:4 by bdubbs@…, 5 years ago

The title is clear enough for our use.

in reply to:  1 comment:5 by ken@…, 5 years ago

Replying to bdubbs@…:

We probably have to check the latest version of poppler against okular, cups-filters, epdfview, cairo, tumbler, inkscape, gimp, and texlive.

epdfview works fine, gimp seems to work fine (not quite sure what it will use poppler for, perhaps adding text which is not something I normally do, but it builds and runs ok).

I thought I would be testing it re cairo, but in fact I build cairo long before poppler.

comment:6 by ken@…, 5 years ago

Type: enhancementdefect

Latest libreoffice is 6.0.0.1, but the problem is still there.

Changing from enhancement to defect.

in reply to:  1 comment:7 by Armin K, 5 years ago

Replying to bdubbs@…:

We probably have to check the latest version of poppler against okular, cups-filters, epdfview, cairo, tumbler, inkscape, gimp, and texlive.

Note that it does not apply to all of those, as they don't use libpoppler and unsupported xpdf headers directly, but rather a higher level bindings (glib, qt5, cpp).

Only cups-filters (mostly uses cpp bindings, but still uses some of raw libpoppler.so), texlive and libreoffice use libpoppler.so and headers installed by ENABLE_XPDF_HEADERS (or whatever the option is called now).

comment:8 by ken@…, 5 years ago

Owner: changed from blfs-book@… to ken@…
Status: newassigned

Despite Armin's comment that some of this will be unnecessary, I've now also built okular, tumbler, inkscape, texlive (source - the install-tl-unx ships linked against static libs). I've also rebuilt cairo against poppler (and if that really adds any functionality, I cannot detect it, although configure certainly tests for poppler-glib).

I have an issue with tumbler - I assumed ristretto would use it for thumbnails (and poppler might be used by tumbler for thumbnails of PDF and PS files), but even running an xfce desktop I'm not getting any thumbnails in ristretto, e.g. for jpegs. And of course ristretto cannot open PDFs. So I can't regard that as a cairo problem.

AFAICS, only libreoffice is broken, I'll remove system poppler from it for the moment. At least the build breaks quickly (within a few minutes) when trying that.

comment:9 by ken@…, 5 years ago

Resolution: fixed
Status: assignedclosed

r19622 - no changes to the noted measurements, in this context the change is tiny, and my build is somewhat different.

comment:10 by tnut, 5 years ago

For info, it's the same issue with the latest libreoffice version 5.4.4.2 removing poppler as a dependencies makes the build going well. So you could adjust the version to the latest version if you want. If any interest, my compilation log: http://downloads.nutyx.org/logs/x86_64/development/gui-extra/libreoffice.log

Note: See TracTickets for help on using tickets.