Opened 5 years ago

Closed 5 years ago

#10119 closed enhancement (wontfix)

sddm-0.17.0

Reported by: bdubbs@… Owned by: blfs-book@…
Priority: normal Milestone: 8.2
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (7)

comment:1 by ken@…, 5 years ago

Owner: changed from blfs-book@… to ken@…
Status: newassigned

comment:2 by ken@…, 5 years ago

My current thoughts are that this is very nasty!

For the first build, I omitted the sed to remove the broken ConsoleKit support (I didn't think it had been fixed, but since I wasn't sure where the breakage was or had been, it seemed worth trying).

Changing to runlevel 5, it didn't appear anywhere. Later, I found it had its own log, and ConsoleKit was the problem.

But in the meantime I set the default runlevel to 5, and rebooted. Got an onscreen keyboard, clicking on the 'keyboard' button took me to the greeter, where I could enter username and password, either directly or by dropping to the onscreen keyboard (which shows which key was pressed, so not secure if people around), and I could select which WM/desktop.

But the password was never accepted.

Killed it, looked around and found the log. Reinstated the sed, tried runlevel 5 again: the onscreen keyboard, but that dropped me to 'select your user icon and enter the password' : that worked, I'm in now, but no choice of WM and it has selected fluxbox (probably the first on the list).

Will try changing /etc/inittab and rebooting, but the onscreen keyboard fills me with horror.

comment:3 by ken@…, 5 years ago

Owner: changed from ken@… to blfs-book@…
Status: assignednew

Well, the direct-login was because reinstalling overwrote sddm.conf so that my theme was no longer mentioned. With that corrected, it sort of works, but instead of the greeter it drops me at the onscreen keyboard (set in my case to British English, which is fine, but would be "interesting" if I'd chosen to use accented letters in my password).

If I use the onscreen keyboard, I have already found that it shows which key was pressed, which is not secure.

If I click on the 'keyboard' symbol (bottom right) it takes me to the theme. I thought the idea of a themed display manager was to display something acceptable between user logins. This version seems very regressive, I'm not willing to use it. Passing back to the book.

comment:4 by bdubbs@…, 5 years ago

## 0.17.0 - 2017-12-05

  • Added possibility to change border width of ComboBox widget.
  • Added missing utmp/wtmp/btmp handling.
  • Make greeter see icons set by AccountsServices.
  • Fix sddm.conf man page syntax error and update.
  • Fix ComboBox widget.
  • Fix connection of PropertiesChanged event for LogindSeat.
  • Avoid race conditions with Xsetup.
  • Update de translation.
  • Update lt translation.
  • Update zh_TW translation.
  • Adjust order of components in the default PATH.
  • Set default input method to qtvirtualkeyboard.

comment:5 by bdubbs@…, 5 years ago

This does not work satisfactorily for me.

Building, I needed to make a change to the first sed:

sed -e '/UPOWER_SERVICE),+1/ s:^://:' \
    -i src/daemon/PowerManager.cpp

But I cannot get the keyboard to work correctly or to use the mouse to select a user.

If I select some keys and then select the session, some dots come up in the default user. The KB then kinda/sorta works and I can log in. I chose lxde and that seems fine, but upon logging out I could not do anything.

The first time I tried, I had power buttons in the upper right corner, but never since.

For the keyboard I tried editing /usr/share/sddm/scripts/Xsetup and adding:

/opt/xorg/bin/setxkbmap -model pc105 -layout us -keycodes evdev

but that did not seem to help. Almost everything is default. No custom theme, etc. The only changes to sddm.conf were to add /opt/xorg in a few places, but that really shouldn't affect the keyboard reaction.

I did install lxdm as an alternative and it worked fine.

Perhaps we should remove sddm from the book and try lightdm:

https://www.freedesktop.org/wiki/Software/LightDM/

comment:6 by thomas, 5 years ago

+1 for lightdm

in my build scripts i have

function buildpkg() {
    unpack ${sources[0]}
    cd ${pkgname}-${pkgvers}

    patch -Np1 -i $CONGLOMERATION/lightdm-default-config.patch

    belfs_configure --prefix=/usr \
                    --sysconfdir=/etc \
                    --localstatedir=/var \
                    --libexecdir=/usr/lib \
                    --with-greeter-user=lightdm \
                    --with-greeter-session=lightdm-gtk-greeter \
                    --disable-static \
                    --disable-tests
    belfs_make
    belfs_make_install DESTDIR=$BELFS_DESTDIR

    mkdir -p $BELFS_DESTDIR/var/lib/lightdm

    echo 'GDK_CORE_DEVICE_EVENTS=true' \
         > $BELFS_DESTDIR/var/lib/lightdm/.pam_environment
    chmod 644 $BELFS_DESTDIR/var/lib/lightdm/.pam_environment

    mkdir -p $BELFS_DESTDIR/etc/lightdm
    install $PKGSRC_DIR/Xsession $BELFS_DESTDIR/etc/lightdm/

    mkdir -p $BELFS_DESTDIR/etc/pam.d
   install $PKGSRC_DIR/lightdm $BELFS_DESTDIR/etc/pam.d/
    install $PKGSRC_DIR/lightdm-autologin $BELFS_DESTDIR/etc/pam.d/
    install $PKGSRC_DIR/lightdm-greeter $BELFS_DESTDIR/etc/pam.d/

    mkdir -p $BELFS_DESTDIR/etc/polkit-1/rules.d
    install $PKGSRC_DIR/lightdm.rules $BELFS_DESTDIR/etc/polkit-1/rules.d/
}

function post_install() {

    getent group lightdm >/dev/null || groupadd -g 38 lightdm
    getent passwd lightdm >/dev/null || useradd -c "LightDM user" \
            -g lightdm -u 38 -d /var/lib/lightdm \
            -s /sbin/nologin lightdm

    mkdir -p /var/{lib,log}/lightdm
    chmod 770 /var/lib/lightdm
    chmod 711 /var/log/lightdm
    chmod +t /var/lib/lightdm
    chown lightdm:lightdm -R /var/{lib,log}/lightdm

    sed -e "s;x:5:respawn:.*;#&\nx:5:respawn:/usr/sbin/lightdm >& /dev/null;" \
        -i.belfssave /etc/inittab

    chmod 755 /etc/lightdm/Xsession
    chmod 644 /etc/pam.d/lightdm{,-autologin,-greeter}

    chmod 700 /etc/polkit-1/rules.d
    chmod 600 /etc/polkit-1/rules.d/lightdm.rules
    chown polkitd /etc/polkit-1/rules.d
    chown polkitd /etc/polkit-1/rules.d/lightdm.rules

    sed -e "/lightdm/d" -i /etc/sysconfig/createfiles
    echo "/run/lightdm dir 0711 lightdm lightdm" >> /etc/sysconfig/createfiles
}

works pretty fine with lightdm-gtk-greeter. The above is just a starting point in case you are interested...

comment:7 by bdubbs@…, 5 years ago

Resolution: wontfix
Status: newclosed

I archived sddm at revision 19654. We can restore it if someone can to get it to work properly with xorg in /opt.

Marking as wontfix.

Note: See TracTickets for help on using tickets.