Opened 4 years ago

Closed 4 years ago

#10399 closed defect (fixed)

MuPDF security fix, and new dependency on GLU

Reported by: Pierre Labastie Owned by: Pierre Labastie
Priority: high Milestone: 8.2
Component: BOOK Version: SVN
Severity: major Keywords:
Cc:

Description

AS reported by Spiky, book's instructions imply a dependency on GLU. Actually, MuPDF-1.12.0 bundles freeglut, so we should recommend freeglut (and GLU), and remove thirdparty/freeglut.

A CVE with score 6.8 has also been fixed upstream, at commit 55c3f68

Change History (2)

comment:1 by Pierre Labastie, 4 years ago

Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

comment:2 by Pierre Labastie, 4 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r19803

Note: See TracTickets for help on using tickets.