Opened 3 years ago

Closed 3 years ago

#10442 closed enhancement (fixed)

libinput-1.10.1

Reported by: bdubbs@… Owned by: bdubbs@…
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by bdubbs@…, 3 years ago

Owner: changed from blfs-book@… to bdubbs@…
Status: newassigned

comment:2 by bdubbs@…, 3 years ago

[ANNOUNCE] libinput 1.10.1

Wed Feb 28 00:27:40 UTC 2018

libinput 1.10.1 is now available. This release fixes three crashers, one

during tapping, two on startup/resume when the device node or seat weren't assigned correctly. You're strongly advised to update just to get those fixes.

Three fixes to the libinput measure* tools as well, they should now work as intended. And fixes for the 'libinput-debug-events' and 'libinput-list-devices' compat scripts that could lead to the wrong bindir/libdir being used.

Maxin B. John (1):

  • libinput-measure-touchpad-tap: use /usr/bin/env to invoke python3

Peter Hutterer (7):

  • evdev: fail before open_restricted if the devnode doesn't exist
  • evdev: add a quirk to disable debouncing on the MS Nano Transcievers
  • udev: fix segfault when resuming before assigning a seat
  • touchpad: only begin fake touches when we have at least one finger down
  • tools: fix option parsing in libinput measure
  • tools: fix inverse up/down threshold handling in measure touch-size

Quentin Glidic (2):

  • meson: Fix bindir usage in install script
  • meson: Fix absolute libdir case in install script

comment:3 by bdubbs@…, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 19920.

Note: See TracTickets for help on using tickets.