Opened 4 years ago

Closed 3 years ago

#10477 closed enhancement (fixed)

librsvg-2.44.7

Reported by: bdubbs@… Owned by: Tim Tassonis
Priority: normal Milestone: 8.4
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (10)

comment:1 by Tim Tassonis, 4 years ago

Owner: changed from blfs-book@… to Tim Tassonis
Status: newassigned
Summary: librsvg-2.41.3librsvg-2.42.3

comment:2 by Tim Tassonis, 4 years ago

The book has 2.42.2 currently, so I assume 2.41.3 was a typo and 2.42.3 is meant.

comment:3 by Tim Tassonis, 4 years ago

Sorry, I thought this was a real low-hanging fruit, upgrading from 2.42.2. However, rsvg 2.42.3 now suddenly requires cairo 1.15.4:

Currently, cairo 1.15.4 or later must also be installed manually....

This release is not even currently avalaible under:

https://www.cairographics.org/releases/

Oh, how I sometime just love those gnome developers....

comment:4 by Bruce Dubbs, 3 years ago

Summary: librsvg-2.42.3librsvg-2.42.3 (Waiting for cairo 1.16.0)

comment:5 by Bruce Dubbs, 3 years ago

Milestone: 8.3y-hold

comment:6 by Bruce Dubbs, 3 years ago

Milestone: y-holdhold

Milestone renamed

comment:7 by Douglas R. Reno, 3 years ago

There is a possibility that I will have to patch to this in order for GNOME-3.28.x to work. My goal is to have BLFS 8.3 with the latest version of GNOME (including the GDM security fixes) prior to release.

I'll update this ticket and cairo if I need to update it.

comment:8 by Douglas R. Reno, 3 years ago

Summary: librsvg-2.42.3 (Waiting for cairo 1.16.0)librsvg-2.44.7 (Waiting for cairo 1.16.0)

comment:9 by Bruce Dubbs, 3 years ago

Milestone: hold8.4
Summary: librsvg-2.44.7 (Waiting for cairo 1.16.0)librsvg-2.44.7

cairo 1.16.0 has been released. See ticket #10485.

comment:10 by Tim Tassonis, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed inrevision 20649.

Note: See TracTickets for help on using tickets.