Opened 3 years ago

Closed 3 years ago

#10728 closed enhancement (fixed)

gnupg-2.2.7

Reported by: Bruce Dubbs Owned by: Bruce Dubbs
Priority: normal Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Bruce Dubbs, 3 years ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 3 years ago

Noteworthy changes in version 2.2.7 (2018-05-02)

  • gpg: New option --no-symkey-cache to disable the passphrase cache for symmetrical en- and decryption.
  • gpg: The ERRSIG status now prints the fingerprint if that is part of the signature.
  • gpg: Relax emitting of FAILURE status lines
  • gpg: Add a status flag to "sig" lines printed with --list-sigs.
  • gpg: Fix "Too many open files" when using --multifile.
  • ssh: Return an error for unknown ssh-agent flags.
  • dirmngr: Fix a regression since 2.1.16 which caused corrupted CRL caches under Windows.
  • dirmngr: Fix a CNAME problem with pools and TLS. Also use a fixed mapping of keys.gnupg.net to sks-keyservers.net.
  • dirmngr: Try resurrecting dead hosts earlier (from 3 to 1.5 hours).
  • dirmngr: Fallback to CRL if no default OCSP responder is configured.
  • dirmngr: Implement CRL fetching via https. Here a redirection to http is explictly allowed.
  • dirmngr: Make LDAP searching and CRL fetching work under Windows. This stopped working with 2.1.
  • agent,dirmngr: New sub-command "getenv" for "getinfo" to ease debugging.

comment:3 by Bruce Dubbs, 3 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 20158.

Note: See TracTickets for help on using tickets.